aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--web/templates/categories.html2
-rw-r--r--web/templates/index.xml2
-rw-r--r--web/templates/layout.html14
3 files changed, 9 insertions, 9 deletions
diff --git a/web/templates/categories.html b/web/templates/categories.html
index 02e6589..f878574 100644
--- a/web/templates/categories.html
+++ b/web/templates/categories.html
@@ -21,7 +21,7 @@ PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
<tr py:for="row in center_categories">
<span py:for="cell in row" py:strip="True">
<td py:if="cell[0] is not None">
- <a href="${relurl('/category/'+cell[0])}">${HTML(cell[0])}</a> (${cell[1]}/${cell[2]})
+ <a href="${relurl('/category/'+cell[0])}">${HTML(cell[0], encoding='utf-8')}</a> (${cell[1]}/${cell[2]})
</td>
</span>
</tr>
diff --git a/web/templates/index.xml b/web/templates/index.xml
index dc1a5ef..8bc852f 100644
--- a/web/templates/index.xml
+++ b/web/templates/index.xml
@@ -34,7 +34,7 @@ from datetime import datetime
<uri>${links.ciavc_link(pkg.meta.authorid)}</uri>
</author>
<updated>${pkg.meta.ebuildchange.strftime("%Y-%m-%dT%H:%M:%SZ")}</updated>
- <summary type="xhtml" xmlns:xhtml="http://www.w3.org/1999/xhtml"><xhtml:div xmlns="http://www.w3.org/1999/xhtml">${HTML(pkg.meta.commitmsg)}</xhtml:div></summary>
+ <summary type="xhtml" xmlns:xhtml="http://www.w3.org/1999/xhtml"><xhtml:div xmlns="http://www.w3.org/1999/xhtml">${HTML(pkg.meta.commitmsg, encoding='utf-8')}</xhtml:div></summary>
</entry>
</feed>
diff --git a/web/templates/layout.html b/web/templates/layout.html
index cebb3d5..71b0026 100644
--- a/web/templates/layout.html
+++ b/web/templates/layout.html
@@ -96,7 +96,7 @@ def alpha_url(baseurl):
<div py:for="day, pvs in daylist">
<p>${day}</p>
<ul>
- <li py:for="pv,pn in pvs"><a href="${relurl('/package/'+pn)}">${HTML(pv)}</a></li>
+ <li py:for="pv,pn in pvs"><a href="${relurl('/package/'+pn)}">${HTML(pv, encoding='utf-8')}</a></li>
</ul>
</div>
</div>
@@ -105,7 +105,7 @@ def alpha_url(baseurl):
<py:match path="rightcontent" once="true">
<div id="rightcontent">
<p class="update">
- Last update:<br />${HTML(lastmodified_rightcontent(lastupdate))}
+ Last update:<br />${HTML(lastmodified_rightcontent(lastupdate), encoding='utf-8')}
</p>
<div>
@@ -176,8 +176,8 @@ def alpha_url(baseurl):
<table class="pkginfo">
<tr>
<td class="category"><a href="${relurl('/category/'+pkg.meta.atom.category)}">${pkg.meta.atom.category}</a></td>
- <td class="homepage">${HTML(pkg.homepage)}</td>
- <td class="license">${HTML(pkg.license)}</td>
+ <td class="homepage">${HTML(pkg.homepage, encoding='utf-8')}</td>
+ <td class="license">${HTML(pkg.license, encoding='utf-8')}</td>
<td class="changelog" ><a href="${pkg.changelog}">ChangeLog</a> <a href="${pkg.metadataxml}">Metadata</a></td>
<td class="similar" >Similar</td>
<td class="bugz" ><a href="${pkg.bugzilla}">Bugs</a></td>
@@ -213,7 +213,7 @@ def alpha_url(baseurl):
<div class="centerpkgs" py:for="pkg in center_pkgs">
<p class="package"><a href="${relurl('/package/'+pkg.atom.key)}">${pkg.atom.cpvstr}</a></p>
<p class="description">${pkg.meta.description}</p>
- <div class="changelogmsg">${HTML(pkg.meta.commitmsg)}</div>
+ <div class="changelogmsg">${HTML(pkg.meta.commitmsg, encoding='utf-8')}</div>
<!-- <pkgarches> -->
<div style="overflow-x: auto">
<table class="main">
@@ -235,8 +235,8 @@ def alpha_url(baseurl):
<table class="pkginfo">
<tr>
<td class="category"><a href="${relurl('/category/'+pkg.meta.atom.category)}">${pkg.meta.atom.category}</a></td>
- <td class="homepage">${HTML(pkg.homepage)}</td>
- <td class="license">${HTML(pkg.license)}</td>
+ <td class="homepage">${HTML(pkg.homepage, encoding='utf-8')}</td>
+ <td class="license">${HTML(pkg.license, encoding='utf-8')}</td>
<td class="changelog" ><a href="${pkg.changelog}">ChangeLog</a> <a href="${pkg.metadataxml}">Metadata</a></td>
<td class="similar" >Similar</td>
<td class="bugz" ><a href="${pkg.bugzilla}">Bugs</a></td>