summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-12-01 17:57:38 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-12-01 17:57:38 +0000
commit6b57522c75ec7d93e655b085cbd81d5b4d426fcf (patch)
tree2cac80dc4ccc664a6ebbbaa4024a0a363b78ccba
parentAdd ~alpha/~ia64/~sparc wrt #439394, #432974 (diff)
downloadgentoo-2-6b57522c75ec7d93e655b085cbd81d5b4d426fcf.tar.gz
gentoo-2-6b57522c75ec7d93e655b085cbd81d5b4d426fcf.tar.bz2
gentoo-2-6b57522c75ec7d93e655b085cbd81d5b4d426fcf.zip
Fix issue with the working directory
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
-rw-r--r--app-benchmarks/ramspeed/ChangeLog5
-rw-r--r--app-benchmarks/ramspeed/ramspeed-3.5.0-r1.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/app-benchmarks/ramspeed/ChangeLog b/app-benchmarks/ramspeed/ChangeLog
index fbd02268778b..07f5809a8f6a 100644
--- a/app-benchmarks/ramspeed/ChangeLog
+++ b/app-benchmarks/ramspeed/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-benchmarks/ramspeed
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ramspeed/ChangeLog,v 1.6 2012/12/01 17:51:26 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ramspeed/ChangeLog,v 1.7 2012/12/01 17:57:38 blueness Exp $
+
+ 01 Dec 2012; Anthony G. Basile <blueness@gentoo.org> ramspeed-3.5.0-r1.ebuild:
+ Fix issue with the working directory
*ramspeed-3.5.0-r1 (01 Dec 2012)
diff --git a/app-benchmarks/ramspeed/ramspeed-3.5.0-r1.ebuild b/app-benchmarks/ramspeed/ramspeed-3.5.0-r1.ebuild
index dfe668516430..fb759f958138 100644
--- a/app-benchmarks/ramspeed/ramspeed-3.5.0-r1.ebuild
+++ b/app-benchmarks/ramspeed/ramspeed-3.5.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ramspeed/ramspeed-3.5.0-r1.ebuild,v 1.1 2012/12/01 17:51:26 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ramspeed/ramspeed-3.5.0-r1.ebuild,v 1.2 2012/12/01 17:57:38 blueness Exp $
-EAPI="4"
+EAPI=2
inherit flag-o-matic toolchain-funcs
MY_PN="ramsmp"
@@ -57,11 +57,11 @@ src_configure(){
obj=( "${obj[@]}" ${arch_prefix}{mmxmark,mmxmem,ssemark,ssemem}.o )
fi
- echo "ramsmp: ${obj[@]}" > Makefile
+ echo "ramsmp: ${obj[@]}" > Makefile || die
}
src_install(){
- dobin ramsmp
- dosym /usr/bin/ramsmp /usr/bin/ramspeed
- dodoc HISTORY README
+ dobin ramsmp || die
+ dosym /usr/bin/ramsmp /usr/bin/ramspeed || die
+ dodoc HISTORY README || die
}