summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-06 07:21:08 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-06 07:21:08 +0000
commit776845c19f38f1b929a96277f29f9fe8ddd9f5fc (patch)
tree6b2ad5f54274a15da872b60dcd3c76de07eae214
parentdev-python/python-nbxmpp: Version Bump (diff)
downloadgentoo-2-776845c19f38f1b929a96277f29f9fe8ddd9f5fc.tar.gz
gentoo-2-776845c19f38f1b929a96277f29f9fe8ddd9f5fc.tar.bz2
gentoo-2-776845c19f38f1b929a96277f29f9fe8ddd9f5fc.zip
sci-libs/ccpn-data: Version BUmp
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
-rw-r--r--sci-libs/ccpn-data/ChangeLog7
-rw-r--r--sci-libs/ccpn-data/ccpn-data-2.4.1.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/sci-libs/ccpn-data/ChangeLog b/sci-libs/ccpn-data/ChangeLog
index b258357a8dab..e355af1d848c 100644
--- a/sci-libs/ccpn-data/ChangeLog
+++ b/sci-libs/ccpn-data/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/ccpn-data
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ChangeLog,v 1.24 2014/04/25 14:01:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ChangeLog,v 1.25 2014/10/06 07:21:08 jlec Exp $
+
+*ccpn-data-2.4.1 (06 Oct 2014)
+
+ 06 Oct 2014; Justin Lecher <jlec@gentoo.org> +ccpn-data-2.4.1.ebuild:
+ Version BUmp
25 Apr 2014; Justin Lecher <jlec@gentoo.org> ccpn-data-2.4.0_p140425.ebuild:
Fix new location of S
diff --git a/sci-libs/ccpn-data/ccpn-data-2.4.1.ebuild b/sci-libs/ccpn-data/ccpn-data-2.4.1.ebuild
new file mode 100644
index 000000000000..16019a45df1b
--- /dev/null
+++ b/sci-libs/ccpn-data/ccpn-data-2.4.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ccpn-data-2.4.1.ebuild,v 1.1 2014/10/06 07:21:08 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils portability python-r1 versionator
+
+#PATCHSET="${PV##*_p}"
+MY_PN="${PN/-data}mr"
+MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
+MY_MAJOR="$(get_version_component_range 1-3)"
+
+DESCRIPTION="The Collaborative Computing Project for NMR - Data"
+HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
+SRC_URI="http://www2.ccpn.ac.uk/download/${MY_PN}/analysis${MY_PV}.tar.gz"
+[[ -n ${PATCHSET} ]] && SRC_URI+=" http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch.xz"
+
+SLOT="0"
+LICENSE="|| ( CCPN LGPL-2.1 )"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ !<sci-chemistry/ccpn-${PVR}"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}"/ccpnmr/ccpnmr2.4
+
+src_prepare() {
+ [[ -n ${PATCHSET} ]] && \
+ epatch "${WORKDIR}"/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch
+ cp "${FILESDIR}"/312+ccpn_rhf22_2013-10-02-16-17-30-923_00001.xml data/ccp/nmr/NmrExpPrototype/ || die
+}
+
+src_install() {
+ local i pydocs in_path ein_path
+
+ dodir /usr/share/doc/${PF}/html
+ sed \
+ -e "s:../ccpnmr2.1:${EPREFIX}/usr/share/doc/${PF}/html:g" \
+ ../doc/index.html > "${ED}"/usr/share/doc/${PF}/html/index.html || die
+ treecopy $(find python/ -name doc -type d) "${ED}"/usr/share/doc/${PF}/html/
+
+ pydocs="$(find python -name doc -type d)"
+
+ symlinking() {
+ in_path=$(python_get_sitedir)/ccpn
+ ein_path="${in_path#${EPREFIX}}"
+ dosym ../../../../share/doc/${PF}/html ${ein_path}/doc
+ for i in ${pydocs}; do
+ dosym /usr/share/doc/${PF}/html/${i} ${ein_path}/${i}
+ done
+ dosym /usr/share/ccpn/data ${ein_path}/data
+ dosym /usr/share/ccpn/model ${ein_path}/model
+ }
+ python_foreach_impl symlinking
+
+ dohtml -r doc/*
+ insinto /usr/share/ccpn
+ doins -r data model
+}