summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2012-12-14 22:35:13 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2012-12-14 22:35:13 +0000
commitb3576aaa7cb321579100f65a47eba6125c1cbc65 (patch)
tree737b16a2c402f9784e06fa955b92582c231d415c
parentSolve gentoo mirror breakage due to restrict fetch, bug#434458 (diff)
downloadgentoo-2-b3576aaa7cb321579100f65a47eba6125c1cbc65.tar.gz
gentoo-2-b3576aaa7cb321579100f65a47eba6125c1cbc65.tar.bz2
gentoo-2-b3576aaa7cb321579100f65a47eba6125c1cbc65.zip
Fix ar detection per bug#438160 by Sean McGovern
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-libs/nettle/ChangeLog6
-rw-r--r--dev-libs/nettle/files/nettle-2.5-build-ar.patch39
-rw-r--r--dev-libs/nettle/nettle-2.5-r1.ebuild3
3 files changed, 46 insertions, 2 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index a341a0249c7f..3f422a836d74 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/nettle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.71 2012/12/14 21:45:31 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.72 2012/12/14 22:35:13 alonbl Exp $
+
+ 14 Dec 2012; <alonbl@gentoo.org> +files/nettle-2.5-build-ar.patch,
+ nettle-2.5-r1.ebuild:
+ Fix ar detection per bug#438160 by Sean McGovern
*nettle-2.5-r1 (14 Dec 2012)
diff --git a/dev-libs/nettle/files/nettle-2.5-build-ar.patch b/dev-libs/nettle/files/nettle-2.5-build-ar.patch
new file mode 100644
index 000000000000..636c1fafc08b
--- /dev/null
+++ b/dev-libs/nettle/files/nettle-2.5-build-ar.patch
@@ -0,0 +1,39 @@
+From 3f35444ca2ae842a546010180e2b16cdd0169b6c Mon Sep 17 00:00:00 2001
+From: Sean McGovern <gseanmcg@gmail.com>
+Date: Tue, 30 Oct 2012 19:23:27 -0400
+Subject: [PATCH] Probe for archiver tool
+
+Gentoo bug#438160.
+---
+ config.make.in | 2 +-
+ configure.ac | 1 +
+ 2 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/config.make.in b/config.make.in
+index 58ee19c..f42421f 100644
+--- a/config.make.in
++++ b/config.make.in
+@@ -46,7 +46,7 @@ LIBHOGWEED_FORLINK = @LIBHOGWEED_FORLINK@
+ LIBHOGWEED_LIBS = @LIBHOGWEED_LIBS@
+ LIBHOGWEED_LINK = @LIBHOGWEED_LINK@
+
+-AR = ar
++AR = @AR@
+ ARFLAGS = cru
+ AUTOCONF = autoconf
+ AUTOHEADER = autoheader
+diff --git a/configure.ac b/configure.ac
+index dea9bd4..737febb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -104,6 +104,7 @@ AC_PROG_RANLIB
+ AC_CHECK_TOOL(NM, nm, strings)
+ # Used only for the GNU-stack configure test.
+ AC_CHECK_TOOL(OBJDUMP, objdump, false)
++AC_CHECK_TOOL(AR, ar, false)
+
+ if test "x$ac_cv_prog_cc_stdc" = xno ; then
+ AC_ERROR([the C compiler doesn't handle ANSI-C]) #'
+--
+1.7.8.6
+
diff --git a/dev-libs/nettle/nettle-2.5-r1.ebuild b/dev-libs/nettle/nettle-2.5-r1.ebuild
index 19cdd91c5a22..a7e825705160 100644
--- a/dev-libs/nettle/nettle-2.5-r1.ebuild
+++ b/dev-libs/nettle/nettle-2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.5-r1.ebuild,v 1.1 2012/12/14 21:45:31 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.5-r1.ebuild,v 1.2 2012/12/14 22:35:13 alonbl Exp $
EAPI="4"
@@ -23,6 +23,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.5-missing-libm-link.patch
sed -i -e 's/solaris\*)/sunldsolaris*)/' configure.ac || die
epatch "${FILESDIR}/${P}-static-libs.patch"
+ epatch "${FILESDIR}/${P}-build-ar.patch"
eautoreconf
}