summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-11-06 10:33:05 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-11-06 10:33:05 +0000
commitb8f1ca919b39e9fe5e788af8ecd2c491dafbaac5 (patch)
tree698eeb525d0476ac44edc5187e176c01008932f1
parentVersion bump proxied for Troy Bowman in bug 388711. (diff)
downloadgentoo-2-b8f1ca919b39e9fe5e788af8ecd2c491dafbaac5.tar.gz
gentoo-2-b8f1ca919b39e9fe5e788af8ecd2c491dafbaac5.tar.bz2
gentoo-2-b8f1ca919b39e9fe5e788af8ecd2c491dafbaac5.zip
Apply patch from http://kmess.org/board/viewtopic.php?f=4&t=20549 to fix recent contact list problem
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
-rw-r--r--net-im/kmess/ChangeLog9
-rw-r--r--net-im/kmess/files/kmess-2.0.6-contact-list.patch38
-rw-r--r--net-im/kmess/kmess-2.0.6-r2.ebuild63
3 files changed, 109 insertions, 1 deletions
diff --git a/net-im/kmess/ChangeLog b/net-im/kmess/ChangeLog
index 5796456eae96..d4598fcf22ca 100644
--- a/net-im/kmess/ChangeLog
+++ b/net-im/kmess/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/kmess
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/ChangeLog,v 1.82 2011/10/28 23:24:03 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/ChangeLog,v 1.83 2011/11/06 10:33:05 hwoarang Exp $
+
+*kmess-2.0.6-r2 (06 Nov 2011)
+
+ 06 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +kmess-2.0.6-r2.ebuild,
+ +files/kmess-2.0.6-contact-list.patch:
+ Apply patch from http://kmess.org/board/viewtopic.php?f=4&t=20549 to fix
+ recent contact list problem
28 Oct 2011; Jonathan Callen <abcd@gentoo.org> kmess-2.0.9999.ebuild,
kmess-9999.ebuild:
diff --git a/net-im/kmess/files/kmess-2.0.6-contact-list.patch b/net-im/kmess/files/kmess-2.0.6-contact-list.patch
new file mode 100644
index 000000000000..59f8c4099fb4
--- /dev/null
+++ b/net-im/kmess/files/kmess-2.0.6-contact-list.patch
@@ -0,0 +1,38 @@
+Index: kmess-2.0.6/src/network/soap/addressbookservice.cpp
+===================================================================
+--- kmess-2.0.6.orig/src/network/soap/addressbookservice.cpp
++++ kmess-2.0.6/src/network/soap/addressbookservice.cpp
+@@ -35,13 +35,12 @@
+ /**
+ * @brief URL of the Address Book Service
+ */
+-#define SERVICE_URL_ADDRESSBOOK "https://omega.contacts.msn.com/abservice/abservice.asmx"
++#define SERVICE_URL_ADDRESSBOOK "https://local-sn.contacts.msn.com/abservice/abservice.asmx"
+
+ /**
+ * @brief URL of the Address Book Sharing Service
+ */
+-#define SERVICE_URL_ADDRESSBOOK_SHARING "https://omega.contacts.msn.com/abservice/SharingService.asmx"
+-
++#define SERVICE_URL_ADDRESSBOOK_SHARING "https://local-sn.contacts.msn.com/abservice/SharingService.asmx"
+
+
+ /**
+Index: kmess-2.0.6/src/network/soap/httpsoapconnection.cpp
+===================================================================
+--- kmess-2.0.6.orig/src/network/soap/httpsoapconnection.cpp
++++ kmess-2.0.6/src/network/soap/httpsoapconnection.cpp
+@@ -546,6 +546,13 @@ void HttpSoapConnection::slotRequestFini
+ kmDebug() << "Received hostname suggestion from:" << originalUrl << "to:" << preferredHostName;
+ #endif
+
++ if( preferredHostName.compare("proxy-sn.contacts.msn.com") == 0 )
++ {
++#ifdef KMESSDEBUG_HTTPSOAPCONNECTION_GENERAL
++ kmDebug() << "Overriding hostname" << preferredHostName << "with local-sn.contacts.msn.com";
++#endif
++ preferredHostName = "local-sn.contacts.msn.com";
++ }
+ redirectionCounts_[ originalHost ] = 0;
+ redirections_[ originalHost ] = preferredHostName;
+ }
diff --git a/net-im/kmess/kmess-2.0.6-r2.ebuild b/net-im/kmess/kmess-2.0.6-r2.ebuild
new file mode 100644
index 000000000000..3234c41dff57
--- /dev/null
+++ b/net-im/kmess/kmess-2.0.6-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/kmess-2.0.6-r2.ebuild,v 1.1 2011/11/06 10:33:05 hwoarang Exp $
+
+EAPI=3
+
+KDE_LINGUAS="ar ca de el es et fi fr gl hu it ja nl pt_BR ru sk tr zh_CN zh_TW"
+inherit kde4-base
+
+MY_P="${P/_/}"
+
+DESCRIPTION="KMess is an alternative MSN Messenger chat client for Linux"
+HOMEPAGE="http://www.kmess.org"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug gif konqueror libnotify xscreensaver"
+RESTRICT="test"
+
+COMMONDEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ gif? ( media-libs/giflib )
+ konqueror? ( $(add_kdebase_dep libkonq) )
+ libnotify? ( $(add_kdebase_dep knotify) )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+"
+DEPEND="${COMMONDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ xscreensaver? ( x11-proto/scrnsaverproto )
+"
+RDEPEND="${COMMONDEPEND}
+ konqueror? ( $(add_kdebase_dep konqueror) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-login-fix.patch
+ "${FILESDIR}"/${P}-contact-list.patch
+)
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with gif GIF)
+ $(cmake-utils_use_with konqueror LibKonq)
+ $(cmake-utils_use_want xscreensaver XSCREENSAVER)"
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ echo
+ elog "KMess can use the following optional packages:"
+ elog "- www-plugins/adobe-flash provides support for winks"
+ echo
+}