summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-07 21:30:37 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-07 21:30:37 +0000
commitd816cdfc2f61e2a012feef38c345ad88810c422d (patch)
tree97dbed40e83fe5518fb9151aa88e951f33f2763f /app-accessibility
parentVersion bump. RC that works with php 5.4 (diff)
downloadgentoo-2-d816cdfc2f61e2a012feef38c345ad88810c422d.tar.gz
gentoo-2-d816cdfc2f61e2a012feef38c345ad88810c422d.tar.bz2
gentoo-2-d816cdfc2f61e2a012feef38c345ad88810c422d.zip
Fix building with >=glib-2.31; thanks to biohazrd for reporting in bug #401437 comment #1.
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/gnome-speech/ChangeLog9
-rw-r--r--app-accessibility/gnome-speech/files/gnome-speech-0.4.25-glib-2.31.patch333
-rw-r--r--app-accessibility/gnome-speech/gnome-speech-0.4.25-r1.ebuild5
3 files changed, 343 insertions, 4 deletions
diff --git a/app-accessibility/gnome-speech/ChangeLog b/app-accessibility/gnome-speech/ChangeLog
index 64b897817975..493b9976ce33 100644
--- a/app-accessibility/gnome-speech/ChangeLog
+++ b/app-accessibility/gnome-speech/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/gnome-speech
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-speech/ChangeLog,v 1.151 2011/10/23 16:49:03 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-speech/ChangeLog,v 1.152 2012/04/07 21:30:37 tetromino Exp $
+
+ 07 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gnome-speech-0.4.25-r1.ebuild, +files/gnome-speech-0.4.25-glib-2.31.patch:
+ Fix building with >=glib-2.31; thanks to biohazrd for reporting in bug
+ #401437 comment #1.
23 Oct 2011; Raúl Porcel <armin76@gentoo.org> gnome-speech-0.4.25-r1.ebuild:
alpha stable
diff --git a/app-accessibility/gnome-speech/files/gnome-speech-0.4.25-glib-2.31.patch b/app-accessibility/gnome-speech/files/gnome-speech-0.4.25-glib-2.31.patch
new file mode 100644
index 000000000000..e1d260a090ee
--- /dev/null
+++ b/app-accessibility/gnome-speech/files/gnome-speech-0.4.25-glib-2.31.patch
@@ -0,0 +1,333 @@
+Description: Fix build failure with glib 2.32
+ where including individual glib headers is no longer allowed.
+Author: Michael Biebl <biebl@debian.org>
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665538
+Index: gnome-speech-0.4.25/drivers/dectalk/dectalkspeaker.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/dectalk/dectalkspeaker.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/dectalk/dectalkspeaker.c 2012-03-26 00:00:26.094898631 +0200
+@@ -27,8 +27,7 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <dtk/ttsapi.h>
+ #include "dectalkspeaker.h"
+Index: gnome-speech-0.4.25/drivers/dectalk/dectalkspeaker.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/dectalk/dectalkspeaker.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/dectalk/dectalkspeaker.h 2012-03-26 00:00:26.230898631 +0200
+@@ -30,7 +30,7 @@
+ #define __DECTALK_SPEAKER_H_
+
+ #include <bonobo/bonobo-object.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+
+ #define DECTALK_SPEAKER_TYPE (dectalk_speaker_get_type())
+Index: gnome-speech-0.4.25/drivers/dectalk/dectalksynthesisdriver.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/dectalk/dectalksynthesisdriver.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/dectalk/dectalksynthesisdriver.c 2012-03-26 00:00:26.014898624 +0200
+@@ -26,7 +26,7 @@
+
+ #include <string.h>
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include "dectalksynthesisdriver.h"
+ #include <dtk/ttsapi.h>
+Index: gnome-speech-0.4.25/drivers/dectalk/dectalksynthesisdriver.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/dectalk/dectalksynthesisdriver.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/dectalk/dectalksynthesisdriver.h 2012-03-26 00:00:26.158898631 +0200
+@@ -28,7 +28,7 @@
+ #ifndef __DECTALK_SYNTHESIS_DRIVER_H_
+ #define __DECTALK_SYNTHESIS_DRIVER_H_
+
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <bonobo/bonobo-object.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <dtk/ttsapi.h>
+Index: gnome-speech-0.4.25/drivers/eloquence/eloquencespeaker.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/eloquence/eloquencespeaker.c 2009-02-08 17:14:55.000000000 +0100
++++ gnome-speech-0.4.25/drivers/eloquence/eloquencespeaker.c 2012-03-26 00:00:27.542898672 +0200
+@@ -25,8 +25,7 @@
+
+ #include <unistd.h>
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include "eloquencespeaker.h"
+
+Index: gnome-speech-0.4.25/drivers/eloquence/eloquencespeaker.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/eloquence/eloquencespeaker.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/eloquence/eloquencespeaker.h 2012-03-26 00:00:27.462898668 +0200
+@@ -34,7 +34,7 @@
+ #endif /* __cplusplus */
+
+ #include <bonobo/bonobo-object.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <eci.h>
+ #include <gnome-speech/gnome-speech.h>
+
+Index: gnome-speech-0.4.25/drivers/eloquence/eloquencesynthesisdriver.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/eloquence/eloquencesynthesisdriver.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/eloquence/eloquencesynthesisdriver.c 2012-03-26 00:00:27.566898672 +0200
+@@ -24,7 +24,7 @@
+ */
+
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include "eloquencesynthesisdriver.h"
+ #include "eloquencespeaker.h"
+Index: gnome-speech-0.4.25/drivers/espeak/espeakspeaker.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/espeak/espeakspeaker.c 2009-02-15 18:24:06.000000000 +0100
++++ gnome-speech-0.4.25/drivers/espeak/espeakspeaker.c 2012-03-26 00:00:26.886898652 +0200
+@@ -26,7 +26,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <speak_lib.h>
+ #include "espeaksynthesisdriver.h"
+Index: gnome-speech-0.4.25/drivers/espeak/espeakspeaker.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/espeak/espeakspeaker.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/espeak/espeakspeaker.h 2012-03-26 00:00:27.318898664 +0200
+@@ -34,7 +34,7 @@
+ #endif /* __cplusplus */
+
+ #include <bonobo/bonobo-object.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <speak_lib.h>
+ #include <gnome-speech/gnome-speech.h>
+
+Index: gnome-speech-0.4.25/drivers/espeak/espeaksynthesisdriver.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/espeak/espeaksynthesisdriver.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/espeak/espeaksynthesisdriver.c 2012-03-26 00:00:27.246898659 +0200
+@@ -28,7 +28,6 @@
+ #include <stdlib.h>
+ #include <libbonobo.h>
+ #include <glib.h>
+-#include <glib/gmain.h>
+ #include <speak_lib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include "espeaksynthesisdriver.h"
+Index: gnome-speech-0.4.25/drivers/espeak/espeaksynthesisdriver.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/espeak/espeaksynthesisdriver.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/espeak/espeaksynthesisdriver.h 2012-03-26 00:00:27.390898668 +0200
+@@ -29,7 +29,7 @@
+ #define __ESPEAK_SYNTHESIS_DRIVER_H_
+
+ #include <bonobo/bonobo-object.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <speak_lib.h>
+ #include "espeakspeaker.h"
+Index: gnome-speech-0.4.25/drivers/loquendo/loquendospeaker.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/loquendo/loquendospeaker.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/loquendo/loquendospeaker.c 2012-03-26 00:00:26.442898637 +0200
+@@ -27,8 +27,7 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <loqtts.h>
+ #include "loquendospeaker.h"
+Index: gnome-speech-0.4.25/drivers/loquendo/loquendospeaker.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/loquendo/loquendospeaker.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/loquendo/loquendospeaker.h 2012-03-26 00:00:26.366898638 +0200
+@@ -34,7 +34,7 @@
+ #endif /* __cplusplus */
+
+ #include <bonobo/bonobo-object.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <loqtts.h>
+ #include <gnome-speech/gnome-speech.h>
+
+Index: gnome-speech-0.4.25/drivers/loquendo/loquendosynthesisdriver.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/loquendo/loquendosynthesisdriver.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/loquendo/loquendosynthesisdriver.c 2012-03-26 00:00:26.494898640 +0200
+@@ -23,7 +23,7 @@
+ */
+
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <loqtts.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include "loquendosynthesisdriver.h"
+Index: gnome-speech-0.4.25/drivers/loquendo/loquendosynthesisdriver.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/loquendo/loquendosynthesisdriver.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/loquendo/loquendosynthesisdriver.h 2012-03-26 00:00:26.298898635 +0200
+@@ -31,7 +31,7 @@
+
+
+ #include <bonobo/bonobo-object.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include "loquendospeaker.h"
+
+Index: gnome-speech-0.4.25/drivers/swift/swiftspeaker.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/swift/swiftspeaker.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/swift/swiftspeaker.c 2012-03-26 00:00:25.862898620 +0200
+@@ -28,8 +28,7 @@
+ #include <math.h>
+ #include <unistd.h>
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <swift.h>
+ #include "swiftspeaker.h"
+Index: gnome-speech-0.4.25/drivers/swift/swiftspeaker.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/swift/swiftspeaker.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/swift/swiftspeaker.h 2012-03-26 00:00:25.930898624 +0200
+@@ -28,7 +28,7 @@
+ #define __SWIFT_SPEAKER_H_
+
+ #include <bonobo/bonobo-object.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <swift.h>
+
+Index: gnome-speech-0.4.25/drivers/swift/swiftsynthesisdriver.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/swift/swiftsynthesisdriver.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/swift/swiftsynthesisdriver.c 2012-03-26 00:00:25.786898622 +0200
+@@ -28,7 +28,7 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <swift.h>
+ #include "swiftsynthesisdriver.h"
+Index: gnome-speech-0.4.25/drivers/theta/thetaspeaker.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/theta/thetaspeaker.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/theta/thetaspeaker.c 2012-03-26 00:00:27.782898679 +0200
+@@ -28,8 +28,7 @@
+ #include <math.h>
+ #include <unistd.h>
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <theta.h>
+ #include "thetaspeaker.h"
+Index: gnome-speech-0.4.25/drivers/theta/thetaspeaker.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/theta/thetaspeaker.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/theta/thetaspeaker.h 2012-03-26 00:00:27.622898671 +0200
+@@ -30,7 +30,7 @@
+ #define __THETA_SPEAKER_H_
+
+ #include <bonobo/bonobo-object.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <theta.h>
+
+Index: gnome-speech-0.4.25/drivers/theta/thetasynthesisdriver.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/theta/thetasynthesisdriver.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/theta/thetasynthesisdriver.c 2012-03-26 00:00:27.706898675 +0200
+@@ -28,7 +28,7 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <theta.h>
+ #include "thetasynthesisdriver.h"
+Index: gnome-speech-0.4.25/drivers/viavoice/viavoicespeaker.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/viavoice/viavoicespeaker.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/viavoice/viavoicespeaker.c 2012-03-26 00:00:26.734898649 +0200
+@@ -26,7 +26,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include "viavoicesynthesisdriver.h"
+ #include "viavoicespeaker.h"
+Index: gnome-speech-0.4.25/drivers/viavoice/viavoicespeaker.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/viavoice/viavoicespeaker.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/viavoice/viavoicespeaker.h 2012-03-26 00:00:26.578898644 +0200
+@@ -34,7 +34,7 @@
+ #endif /* __cplusplus */
+
+ #include <bonobo/bonobo-object.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <eci.h>
+ #include <gnome-speech/gnome-speech.h>
+
+Index: gnome-speech-0.4.25/drivers/viavoice/viavoicesynthesisdriver.c
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/viavoice/viavoicesynthesisdriver.c 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/viavoice/viavoicesynthesisdriver.c 2012-03-26 00:00:26.654898643 +0200
+@@ -24,7 +24,7 @@
+ */
+
+ #include <libbonobo.h>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <string.h>
+ #include "viavoicesynthesisdriver.h"
+Index: gnome-speech-0.4.25/drivers/viavoice/viavoicesynthesisdriver.h
+===================================================================
+--- gnome-speech-0.4.25.orig/drivers/viavoice/viavoicesynthesisdriver.h 2008-12-10 14:36:00.000000000 +0100
++++ gnome-speech-0.4.25/drivers/viavoice/viavoicesynthesisdriver.h 2012-03-26 00:00:26.806898647 +0200
+@@ -30,7 +30,7 @@
+ #define __VIAVOICE_SYNTHESIS_DRIVER_H_
+
+ #include <bonobo/bonobo-object.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <eci.h>
+ #include "viavoicespeaker.h"
diff --git a/app-accessibility/gnome-speech/gnome-speech-0.4.25-r1.ebuild b/app-accessibility/gnome-speech/gnome-speech-0.4.25-r1.ebuild
index 9c3c50d96c40..7c1bf70d3f10 100644
--- a/app-accessibility/gnome-speech/gnome-speech-0.4.25-r1.ebuild
+++ b/app-accessibility/gnome-speech/gnome-speech-0.4.25-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-speech/gnome-speech-0.4.25-r1.ebuild,v 1.7 2011/10/23 16:49:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-speech/gnome-speech-0.4.25-r1.ebuild,v 1.8 2012/04/07 21:30:37 tetromino Exp $
EAPI="4"
GNOME_TARBALL_SUFFIX="bz2"
@@ -42,6 +42,7 @@ src_prepare() {
gnome2_src_prepare
epatch "${FILESDIR}/${P}-disable-java.patch"
+ epatch "${FILESDIR}/${P}-glib-2.31.patch"
sed -i \
-e 's:\(GNOME_SPEECH_JAR_DIR=\).*:\1"/usr/share/java-access-bridge/lib/":' \