summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-10-15 16:25:43 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-10-15 16:25:43 +0000
commit260b3190d3e4b17526ba9ab7e14beee1a23f2755 (patch)
treef2650f87ba2d25013230956fac488bd1cab8605f /app-backup
parent~ -> = (diff)
downloadgentoo-2-260b3190d3e4b17526ba9ab7e14beee1a23f2755.tar.gz
gentoo-2-260b3190d3e4b17526ba9ab7e14beee1a23f2755.tar.bz2
gentoo-2-260b3190d3e4b17526ba9ab7e14beee1a23f2755.zip
Version bumped, bug #195319.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/dar/ChangeLog7
-rw-r--r--app-backup/dar/dar-2.3.6.ebuild61
-rw-r--r--app-backup/dar/files/digest-dar-2.3.63
3 files changed, 70 insertions, 1 deletions
diff --git a/app-backup/dar/ChangeLog b/app-backup/dar/ChangeLog
index 03325cf0415a..6e20c6301d19 100644
--- a/app-backup/dar/ChangeLog
+++ b/app-backup/dar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/dar
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.26 2007/09/12 23:30:56 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.27 2007/10/15 16:25:42 matsuu Exp $
+
+*dar-2.3.6 (15 Oct 2007)
+
+ 15 Oct 2007; <matsuu@gentoo.org> +dar-2.3.6.ebuild:
+ Version bumped, bug #195319.
*dar-2.3.5 (12 Sep 2007)
diff --git a/app-backup/dar/dar-2.3.6.ebuild b/app-backup/dar/dar-2.3.6.ebuild
new file mode 100644
index 000000000000..a272816c9c7d
--- /dev/null
+++ b/app-backup/dar/dar-2.3.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/dar-2.3.6.ebuild,v 1.1 2007/10/15 16:25:42 matsuu Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks (floppy,CDR(W),DVDR(W),zip,jazz etc.)"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="acl dar32 dar64 doc nls ssl"
+
+DEPEND=">=sys-libs/zlib-1.2.3
+ >=app-arch/bzip2-1.0.2
+ acl? ( sys-apps/attr )
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ if use dar32 && use dar64 ; then
+ eerror "dar32 and dar64 cannot be enabled together."
+ eerror "Please remove one of them and try the emerge again."
+ die "Please remove dar32 or dar64."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/^dist_noinst_DATA/s/$/ macro_tools.hpp/' \
+ -e '/^noinst_HEADERS/s/macro_tools.hpp//' \
+ src/libdar/Makefile* || die
+}
+
+src_compile() {
+ local myconf="--disable-upx"
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ use acl || myconf="${myconf} --disable-ea-support"
+ use dar32 && myconf="${myconf} --enable-mode=32"
+ use dar64 && myconf="${myconf} --enable-mode=64"
+ use doc || myconf="${myconf} --disable-build-html"
+ # use examples && myconf="${myconf} --enable-examples"
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl || myconf="${myconf} --disable-libcrypto-linking"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir=/usr/share/doc/${PF}/html install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
diff --git a/app-backup/dar/files/digest-dar-2.3.6 b/app-backup/dar/files/digest-dar-2.3.6
new file mode 100644
index 000000000000..fbbf931f2b38
--- /dev/null
+++ b/app-backup/dar/files/digest-dar-2.3.6
@@ -0,0 +1,3 @@
+MD5 de290b9d4ff93838be0779a6daa66fff dar-2.3.6.tar.gz 1189996
+RMD160 df78cdd068b893caad43a72e45e90e2af5c66cc7 dar-2.3.6.tar.gz 1189996
+SHA256 ae5c1c196eb8b0bfe0cad1776fd330307a886bc7619e687abdfffc74bd31dddb dar-2.3.6.tar.gz 1189996