summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-02 10:41:16 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-02 10:41:16 +0000
commit0cdfb7d605fe1b6983420e8287fa8dc51e439bc0 (patch)
tree098f9ed369adaf09b77e7ad91a774a6dc7d82d6d /app-crypt/ophcrack-tables
parentchange use flag name (gst to gstreamer) (diff)
downloadgentoo-2-0cdfb7d605fe1b6983420e8287fa8dc51e439bc0.tar.gz
gentoo-2-0cdfb7d605fe1b6983420e8287fa8dc51e439bc0.tar.bz2
gentoo-2-0cdfb7d605fe1b6983420e8287fa8dc51e439bc0.zip
[QA] Revision bump to 1.0-r2. EAPI 5 and Prefix support, added die to cd and cp call.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-crypt/ophcrack-tables')
-rw-r--r--app-crypt/ophcrack-tables/ChangeLog12
-rw-r--r--app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild (renamed from app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild)10
-rw-r--r--app-crypt/ophcrack-tables/ophcrack-tables-1.0.ebuild37
3 files changed, 14 insertions, 45 deletions
diff --git a/app-crypt/ophcrack-tables/ChangeLog b/app-crypt/ophcrack-tables/ChangeLog
index e84f6a7c224b..b4b0fcbea99b 100644
--- a/app-crypt/ophcrack-tables/ChangeLog
+++ b/app-crypt/ophcrack-tables/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/ophcrack-tables
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack-tables/ChangeLog,v 1.4 2009/10/31 00:38:46 ikelos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack-tables/ChangeLog,v 1.5 2014/04/02 10:41:16 tomwij Exp $
+
+*ophcrack-tables-1.0-r2 (02 Apr 2014)
+
+ 02 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +ophcrack-tables-1.0-r2.ebuild,
+ -ophcrack-tables-1.0-r1.ebuild, -ophcrack-tables-1.0.ebuild:
+ [QA] Revision bump to 1.0-r2. EAPI 5 and Prefix support, added die to cd and
+ cp call.
31 Oct 2009; Mike Auty <ikelos@gentoo.org> ophcrack-tables-1.0.ebuild,
ophcrack-tables-1.0-r1.ebuild:
@@ -19,4 +26,3 @@
21 Jul 2008; Mike Auty <ikelos@gentoo.org> +metadata.xml,
+ophcrack-tables-1.0.ebuild:
Initial commit of split-out ophcrack tables.
-
diff --git a/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
index ddc7930c6bda..7494bd4b47a4 100644
--- a/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild
+++ b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild,v 1.2 2009/10/31 00:38:46 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild,v 1.1 2014/04/02 10:41:16 tomwij Exp $
-EAPI="1"
+EAPI="5"
DESCRIPTION="Tables available for ophcrack"
HOMEPAGE="http://ophcrack.sourceforge.net/"
@@ -26,12 +26,12 @@ src_unpack() {
table=${i#tables_}
table=${table%.zip}
mkdir "${S}/${table}"
- cd "${S}/${table}"
+ cd $_ || die
unpack "${i}"
done
}
src_install() {
dodir /usr/share/ophcrack/
- cp -r "${S}"/* "${D}/usr/share/ophcrack"
+ cp -r "${S}"/* "${ED}"/usr/share/ophcrack/ || die
}
diff --git a/app-crypt/ophcrack-tables/ophcrack-tables-1.0.ebuild b/app-crypt/ophcrack-tables/ophcrack-tables-1.0.ebuild
deleted file mode 100644
index 8cff13a2ae89..000000000000
--- a/app-crypt/ophcrack-tables/ophcrack-tables-1.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack-tables/ophcrack-tables-1.0.ebuild,v 1.2 2009/10/31 00:38:46 ikelos Exp $
-
-EAPI="1"
-
-DESCRIPTION="Tables available for ophcrack"
-HOMEPAGE="http://ophcrack.sourceforge.net/"
-SRC_URI="xpfast? ( mirror://sourceforge/ophcrack/tables_xp_free_fast.zip )
- xpsmall? ( mirror://sourceforge/ophcrack/tables_xp_free_small.zip )
- vistafree? ( mirror://sourceforge/ophcrack/tables_vista_free.zip )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="+xpfast xpsmall +vistafree"
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-S=${WORKDIR}
-
-src_unpack() {
- for i in ${A};
- do
- table=${i#tables_}
- table=${table%.zip}
- mkdir "${S}/${table}"
- cd "${S}/${table}"
- unpack "${i}"
- done
-}
-
-src_install() {
- dodir /usr/share/ophcrack/
- cp -r "${S}/*" "${D}/usr/share/ophcrack"
-}