summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-04-26 15:32:25 +0000
committerBen de Groot <yngwin@gentoo.org>2009-04-26 15:32:25 +0000
commit419aec34d8121f22eaa35672201a787a0f3423bd (patch)
tree85136ff4e204e23f9672eb5ef6ad1f2fbbb42794 /app-crypt
parentkeyworded ~arch for ppc, bug 267052 (diff)
downloadgentoo-2-419aec34d8121f22eaa35672201a787a0f3423bd.tar.gz
gentoo-2-419aec34d8121f22eaa35672201a787a0f3423bd.tar.bz2
gentoo-2-419aec34d8121f22eaa35672201a787a0f3423bd.zip
Fix qt dep, move 2.0.1 to eapi-2 with use dep
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca/ChangeLog7
-rw-r--r--app-crypt/qca/qca-2.0.0-r2.ebuild10
-rw-r--r--app-crypt/qca/qca-2.0.1-r1.ebuild31
3 files changed, 18 insertions, 30 deletions
diff --git a/app-crypt/qca/ChangeLog b/app-crypt/qca/ChangeLog
index 98381b86bd7c..bb710476f203 100644
--- a/app-crypt/qca/ChangeLog
+++ b/app-crypt/qca/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-crypt/qca
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.59 2008/12/02 23:15:17 ranger Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.60 2009/04/26 15:32:25 yngwin Exp $
+
+ 26 Apr 2009; Ben de Groot <yngwin@gentoo.org> qca-2.0.0-r2, qca-2.0.1-r1:
+ Fix qt dep, move 2.0.1 to eapi-2 with use dep
02 Dec 2008; Brent Baude <ranger@gentoo.org> qca-1.0-r3.ebuild:
stable ppc64, bug 238000
diff --git a/app-crypt/qca/qca-2.0.0-r2.ebuild b/app-crypt/qca/qca-2.0.0-r2.ebuild
index 415350278f40..7055befe552c 100644
--- a/app-crypt/qca/qca-2.0.0-r2.ebuild
+++ b/app-crypt/qca/qca-2.0.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.0-r2.ebuild,v 1.17 2008/09/20 10:02:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.0-r2.ebuild,v 1.18 2009/04/26 15:32:25 yngwin Exp $
EAPI="1"
@@ -16,10 +16,8 @@ KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="debug doc examples"
RESTRICT="test"
-DEPEND="
- !<app-crypt/qca-1.0-r3
- || ( x11-libs/qt-core:4
- >=x11-libs/qt-4.2.0:4 )"
+DEPEND="!<app-crypt/qca-1.0-r3
+ x11-libs/qt-core:4"
RDEPEND="${DEPEND}"
pkg_setup() {
diff --git a/app-crypt/qca/qca-2.0.1-r1.ebuild b/app-crypt/qca/qca-2.0.1-r1.ebuild
index 560fd5b46d77..0cbf0518197f 100644
--- a/app-crypt/qca/qca-2.0.1-r1.ebuild
+++ b/app-crypt/qca/qca-2.0.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.1-r1.ebuild,v 1.1 2008/09/06 00:16:21 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.1-r1.ebuild,v 1.2 2009/04/26 15:32:25 yngwin Exp $
-EAPI="1"
+EAPI="2"
inherit eutils multilib qt4
@@ -17,30 +17,14 @@ IUSE="debug doc examples"
RESTRICT="test"
DEPEND="!<app-crypt/qca-1.0-r3
- || ( x11-libs/qt-core:4
- >=x11-libs/qt-4.2.0:4 )"
+ x11-libs/qt-core:4[debug=]"
RDEPEND="${DEPEND}"
-pkg_setup() {
- if use debug; then
- if has_version "<x11-libs/qt-4.4.0_alpha1:4" && ! built_with_use x11-libs/qt:4 debug; then
- eerror "You are trying to compile ${PN} with USE=\"debug\""
- eerror "while x11-libs/qt:4 is built without this particular flag."
- die "Rebuild x11-libs/qt:4 with USE=\"debug\"."
- elif has_version "x11-libs/qt-core:4" && ! built_with_use x11-libs/qt-core:4 debug; then
- eerror "You are trying to compile ${PN} with USE=\"debug\""
- eerror "while x11-libs/qt-core:4 is built without this particular flag."
- die "Rebuild x11-libs/qt-core:4 with USE=\"debug\"."
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
+src_prepare() {
epatch "${FILESDIR}"/${P}-pcfilespath.patch
}
-src_compile() {
+src_configure() {
_libdir=$(get_libdir)
local myconf
use debug && myconf="--debug" || myconf="--release"
@@ -57,6 +41,9 @@ src_compile() {
|| die "configure failed"
eqmake4 ${PN}.pro
+}
+
+src_compile() {
emake || die "emake failed"
}