summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-04-22 16:54:28 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-04-22 16:54:28 +0000
commita1c173ad8e8e59473fb3161fdba9c44e5d48a0a4 (patch)
tree0ac038be9c05485c299173fb5f29e191a2ef4126 /app-dicts/kasumi
parentVersion bumped. (diff)
downloadgentoo-2-a1c173ad8e8e59473fb3161fdba9c44e5d48a0a4.tar.gz
gentoo-2-a1c173ad8e8e59473fb3161fdba9c44e5d48a0a4.tar.bz2
gentoo-2-a1c173ad8e8e59473fb3161fdba9c44e5d48a0a4.zip
Fixed to compile with gcc-4.3, bug #218107.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-dicts/kasumi')
-rw-r--r--app-dicts/kasumi/ChangeLog10
-rw-r--r--app-dicts/kasumi/files/kasumi-2.3-gcc43.patch33
-rw-r--r--app-dicts/kasumi/kasumi-2.3-r1.ebuild40
3 files changed, 81 insertions, 2 deletions
diff --git a/app-dicts/kasumi/ChangeLog b/app-dicts/kasumi/ChangeLog
index 646e1e01c5a4..38e135657e79 100644
--- a/app-dicts/kasumi/ChangeLog
+++ b/app-dicts/kasumi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-dicts/kasumi
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/ChangeLog,v 1.36 2007/11/02 16:08:37 matsuu Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/ChangeLog,v 1.37 2008/04/22 16:54:28 matsuu Exp $
+
+*kasumi-2.3-r1 (22 Apr 2008)
+
+ 22 Apr 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/kasumi-2.3-gcc43.patch, +kasumi-2.3-r1.ebuild:
+ Fixed to compile with gcc-4.3, bug #218107.
*kasumi-2.3 (02 Nov 2007)
diff --git a/app-dicts/kasumi/files/kasumi-2.3-gcc43.patch b/app-dicts/kasumi/files/kasumi-2.3-gcc43.patch
new file mode 100644
index 000000000000..9949974d9ac0
--- /dev/null
+++ b/app-dicts/kasumi/files/kasumi-2.3-gcc43.patch
@@ -0,0 +1,33 @@
+diff -pruN kasumi-2.3.orig/KasumiAddWindow.cxx kasumi-2.3/KasumiAddWindow.cxx
+--- kasumi-2.3.orig/KasumiAddWindow.cxx 2007-10-28 17:40:43.000000000 +0900
++++ kasumi-2.3/KasumiAddWindow.cxx 2008-02-19 16:59:45.000000000 +0900
+@@ -25,6 +25,7 @@
+ *********************************************************************/
+
+ #include <gtk/gtk.h>
++#include <algorithm>
+ #include <iostream>
+ #include "KasumiAddWindow.hxx"
+ #include "KasumiWord.hxx"
+diff -pruN kasumi-2.3.orig/KasumiWord.cxx kasumi-2.3/KasumiWord.cxx
+--- kasumi-2.3.orig/KasumiWord.cxx 2007-10-30 23:01:05.000000000 +0900
++++ kasumi-2.3/KasumiWord.cxx 2008-02-19 16:59:22.000000000 +0900
+@@ -24,6 +24,7 @@
+ *********************************************************************/
+
+ #include <cstdlib>
++#include <cstring>
+ #include <string>
+ #include <map>
+ #include <iconv.h>
+diff -pruN kasumi-2.3.orig/main.cxx kasumi-2.3/main.cxx
+--- kasumi-2.3.orig/main.cxx 2007-10-30 23:01:22.000000000 +0900
++++ kasumi-2.3/main.cxx 2008-02-19 16:59:22.000000000 +0900
+@@ -28,6 +28,7 @@
+ #include "config.h"
+ #endif
+
++#include <cstring>
+ #include <gtk/gtk.h>
+ #include <stdlib.h>
+ #include <time.h>
diff --git a/app-dicts/kasumi/kasumi-2.3-r1.ebuild b/app-dicts/kasumi/kasumi-2.3-r1.ebuild
new file mode 100644
index 000000000000..5e2cd3ed60a6
--- /dev/null
+++ b/app-dicts/kasumi/kasumi-2.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/kasumi-2.3-r1.ebuild,v 1.1 2008/04/22 16:54:28 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Anthy dictionary maintenance tool"
+HOMEPAGE="http://kasumi.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/27825/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ nls? ( virtual/libintl )
+ virtual/libiconv
+ >=app-i18n/anthy-6131"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README ChangeLog AUTHORS
+}