summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-27 22:16:46 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-27 22:16:46 +0000
commit42d0a4e6e015a7b499eef60646a2580ece8d7dc6 (patch)
treebb85dac09290cf2d4ebad531b310de43badba704 /app-editors
parentmetadata + LICENSE (Manifest recommit) (diff)
downloadgentoo-2-42d0a4e6e015a7b499eef60646a2580ece8d7dc6.tar.gz
gentoo-2-42d0a4e6e015a7b499eef60646a2580ece8d7dc6.tar.bz2
gentoo-2-42d0a4e6e015a7b499eef60646a2580ece8d7dc6.zip
touch the libc
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/hexedit/hexedit-1.2.2.ebuild6
-rw-r--r--app-editors/hexedit/hexedit-1.2.9.ebuild4
-rw-r--r--app-editors/hteditor/hteditor-0.7.3.ebuild7
-rw-r--r--app-editors/hteditor/hteditor-0.7.4.ebuild7
-rw-r--r--app-editors/hteditor/hteditor-0.8.0_pre1.ebuild6
-rw-r--r--app-editors/jasspa-microemacs/jasspa-microemacs-20021205.ebuild7
-rw-r--r--app-editors/jasspa-microemacs/jasspa-microemacs-20040301.ebuild7
-rw-r--r--app-editors/le/le-1.9.2.ebuild4
-rw-r--r--app-editors/mp/mp-3.1.9.ebuild4
-rw-r--r--app-editors/mp/mp-3.2.10.ebuild4
-rw-r--r--app-editors/mp/mp-3.2.11.ebuild4
-rw-r--r--app-editors/mp/mp-3.2.7.ebuild4
-rw-r--r--app-editors/mp/mp-3.2.8.ebuild4
13 files changed, 32 insertions, 36 deletions
diff --git a/app-editors/hexedit/hexedit-1.2.2.ebuild b/app-editors/hexedit/hexedit-1.2.2.ebuild
index ab58c23741f5..89efcd8ccd23 100644
--- a/app-editors/hexedit/hexedit-1.2.2.ebuild
+++ b/app-editors/hexedit/hexedit-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hexedit/hexedit-1.2.2.ebuild,v 1.14 2004/06/24 21:56:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hexedit/hexedit-1.2.2.ebuild,v 1.15 2004/06/27 22:13:31 vapier Exp $
DESCRIPTION="View and edit files in hex or ASCII"
HOMEPAGE="http://www.chez.com/prigaux/hexedit.html"
@@ -11,13 +11,13 @@ SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/ncurses"
RDEPEND="sys-libs/ncurses"
S=${WORKDIR}/hexedit
-src_install () {
+src_install() {
dobin hexedit || die
doman hexedit.1
dodoc Changes TODO
diff --git a/app-editors/hexedit/hexedit-1.2.9.ebuild b/app-editors/hexedit/hexedit-1.2.9.ebuild
index fb8664778027..03687070d2ae 100644
--- a/app-editors/hexedit/hexedit-1.2.9.ebuild
+++ b/app-editors/hexedit/hexedit-1.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hexedit/hexedit-1.2.9.ebuild,v 1.7 2004/06/24 21:56:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hexedit/hexedit-1.2.9.ebuild,v 1.8 2004/06/27 22:13:31 vapier Exp $
DESCRIPTION="View and edit files in hex or ASCII"
HOMEPAGE="http://www.chez.com/prigaux/hexedit.html"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc ~alpha arm hppa amd64"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/ncurses"
RDEPEND=""
diff --git a/app-editors/hteditor/hteditor-0.7.3.ebuild b/app-editors/hteditor/hteditor-0.7.3.ebuild
index 6e518ac6e8e6..5efb1dca89cb 100644
--- a/app-editors/hteditor/hteditor-0.7.3.ebuild
+++ b/app-editors/hteditor/hteditor-0.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.7.3.ebuild,v 1.5 2004/06/24 21:56:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.7.3.ebuild,v 1.6 2004/06/27 22:13:51 vapier Exp $
DESCRIPTION="editor for executable files"
HOMEPAGE="http://hte.sourceforge.net/"
@@ -11,14 +11,13 @@ SLOT="0"
KEYWORDS="x86 -alpha"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
S="${WORKDIR}/ht-${PV}"
src_compile() {
chmod +x configure
- local myconf="--prefix=/usr --sysconfdir=/etc"
- ./configure ${myconf} || die
+ ./configure --prefix=/usr --sysconfdir=/etc || die
emake || die
}
diff --git a/app-editors/hteditor/hteditor-0.7.4.ebuild b/app-editors/hteditor/hteditor-0.7.4.ebuild
index 5b92b9c37c2a..ea1b9560243a 100644
--- a/app-editors/hteditor/hteditor-0.7.4.ebuild
+++ b/app-editors/hteditor/hteditor-0.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.7.4.ebuild,v 1.5 2004/06/24 21:56:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.7.4.ebuild,v 1.6 2004/06/27 22:13:51 vapier Exp $
DESCRIPTION="editor for executable files"
HOMEPAGE="http://hte.sourceforge.net/"
@@ -11,14 +11,13 @@ SLOT="0"
KEYWORDS="x86 ~ppc -alpha"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
S="${WORKDIR}/ht-${PV}"
src_compile() {
chmod +x configure
- local myconf="--prefix=/usr --sysconfdir=/etc"
- ./configure ${myconf} || die
+ ./configure --prefix=/usr --sysconfdir=/etc || die
emake || die
}
diff --git a/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild b/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild
index 9a8193c3ceb4..8e83efd9b2b9 100644
--- a/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild
+++ b/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild,v 1.2 2004/06/24 21:56:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild,v 1.3 2004/06/27 22:13:51 vapier Exp $
DESCRIPTION="editor for executable files"
HOMEPAGE="http://hte.sourceforge.net/"
SRC_URI="mirror://sourceforge/hte/ht-${PV/_/}.tar.bz2"
-RESTRICT="nomirror"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc -alpha"
IUSE=""
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
virtual/x11
sys-libs/ncurses"
diff --git a/app-editors/jasspa-microemacs/jasspa-microemacs-20021205.ebuild b/app-editors/jasspa-microemacs/jasspa-microemacs-20021205.ebuild
index c408bacfec73..3b65c1ca5762 100644
--- a/app-editors/jasspa-microemacs/jasspa-microemacs-20021205.ebuild
+++ b/app-editors/jasspa-microemacs/jasspa-microemacs-20021205.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/jasspa-microemacs-20021205.ebuild,v 1.4 2004/06/24 21:56:26 agriffis Exp $
-
-IUSE="X"
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/jasspa-microemacs-20021205.ebuild,v 1.5 2004/06/27 22:14:10 vapier Exp $
MY_PV=${PV:2} # 20021205 -> 021205
@@ -22,8 +20,9 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE="X"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/ncurses
X? ( virtual/x11 )"
diff --git a/app-editors/jasspa-microemacs/jasspa-microemacs-20040301.ebuild b/app-editors/jasspa-microemacs/jasspa-microemacs-20040301.ebuild
index 2fb36cffb612..400a53e8d08c 100644
--- a/app-editors/jasspa-microemacs/jasspa-microemacs-20040301.ebuild
+++ b/app-editors/jasspa-microemacs/jasspa-microemacs-20040301.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/jasspa-microemacs-20040301.ebuild,v 1.4 2004/06/24 21:56:26 agriffis Exp $
-
-IUSE="X"
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/jasspa-microemacs-20040301.ebuild,v 1.5 2004/06/27 22:14:10 vapier Exp $
MY_PV=${PV:2} # 20021205 -> 021205
@@ -20,8 +18,9 @@ SRC_URI="http://www.jasspa.com/release_${MY_PV}/jasspa-memacros-${PV}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
+IUSE="X"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/ncurses
X? ( virtual/x11 )"
diff --git a/app-editors/le/le-1.9.2.ebuild b/app-editors/le/le-1.9.2.ebuild
index f73e6c0f6aa0..34ecb3b4e51e 100644
--- a/app-editors/le/le-1.9.2.ebuild
+++ b/app-editors/le/le-1.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/le/le-1.9.2.ebuild,v 1.7 2004/06/24 21:58:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/le/le-1.9.2.ebuild,v 1.8 2004/06/27 22:15:58 vapier Exp $
DESCRIPTION="Terminal text editor"
HOMEPAGE="http://www.gnu.org/directory/text/editors/le-editor.html"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-libs/ncurses-5.2-r5"
src_install() {
diff --git a/app-editors/mp/mp-3.1.9.ebuild b/app-editors/mp/mp-3.1.9.ebuild
index 092f35fc8673..11420a37a2e9 100644
--- a/app-editors/mp/mp-3.1.9.ebuild
+++ b/app-editors/mp/mp-3.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.1.9.ebuild,v 1.12 2004/06/24 21:59:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.1.9.ebuild,v 1.13 2004/06/27 22:16:46 vapier Exp $
DESCRIPTION="the definitive text editor"
HOMEPAGE="http://www.triptico.com/software/mp.html"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/ncurses"
RDEPEND="${DEPEND}
dev-lang/perl"
diff --git a/app-editors/mp/mp-3.2.10.ebuild b/app-editors/mp/mp-3.2.10.ebuild
index 9f42525de47a..1a985220044c 100644
--- a/app-editors/mp/mp-3.2.10.ebuild
+++ b/app-editors/mp/mp-3.2.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.10.ebuild,v 1.5 2004/06/24 21:59:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.10.ebuild,v 1.6 2004/06/27 22:16:46 vapier Exp $
DESCRIPTION="the definitive text editor"
HOMEPAGE="http://www.triptico.com/software/mp.html"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 ~sparc"
IUSE="ncurses gtk"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
ncurses? ( sys-libs/ncurses )
gtk? ( =x11-libs/gtk+-1.2* )
!gtk? ( sys-libs/ncurses )"
diff --git a/app-editors/mp/mp-3.2.11.ebuild b/app-editors/mp/mp-3.2.11.ebuild
index 3613dd5d4324..99ec8bfb03ae 100644
--- a/app-editors/mp/mp-3.2.11.ebuild
+++ b/app-editors/mp/mp-3.2.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.11.ebuild,v 1.6 2004/06/24 21:59:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.11.ebuild,v 1.7 2004/06/27 22:16:46 vapier Exp $
inherit eutils
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="x86 sparc"
IUSE="ncurses gtk"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
ncurses? ( sys-libs/ncurses )
gtk? ( =x11-libs/gtk+-1.2* )
!gtk? ( sys-libs/ncurses )"
diff --git a/app-editors/mp/mp-3.2.7.ebuild b/app-editors/mp/mp-3.2.7.ebuild
index 33d7851840e4..458cb4931cca 100644
--- a/app-editors/mp/mp-3.2.7.ebuild
+++ b/app-editors/mp/mp-3.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.7.ebuild,v 1.8 2004/06/24 21:59:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.7.ebuild,v 1.9 2004/06/27 22:16:46 vapier Exp $
DESCRIPTION="the definitive text editor"
HOMEPAGE="http://www.triptico.com/software/mp.html"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/ncurses"
RDEPEND="${DEPEND}
dev-lang/perl"
diff --git a/app-editors/mp/mp-3.2.8.ebuild b/app-editors/mp/mp-3.2.8.ebuild
index f6af2d42da91..b3297e311e49 100644
--- a/app-editors/mp/mp-3.2.8.ebuild
+++ b/app-editors/mp/mp-3.2.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.8.ebuild,v 1.7 2004/06/24 21:59:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.8.ebuild,v 1.8 2004/06/27 22:16:46 vapier Exp $
DESCRIPTION="the definitive text editor"
HOMEPAGE="http://www.triptico.com/software/mp.html"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 ~sparc ~amd64"
IUSE="ncurses gtk"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
ncurses? ( sys-libs/ncurses )
gtk? ( =x11-libs/gtk+-1.2* )
!gtk? ( sys-libs/ncurses )"