summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-07-11 05:23:59 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-07-11 05:23:59 +0000
commit2558ec8da99093f8965de1b07064a003ae1ef306 (patch)
treeaecfa0a14c6e59bef30bcc0698438b0e19f635ed /app-emulation/virtinst
parentUpdate dependencies. (diff)
downloadgentoo-2-2558ec8da99093f8965de1b07064a003ae1ef306.tar.gz
gentoo-2-2558ec8da99093f8965de1b07064a003ae1ef306.tar.bz2
gentoo-2-2558ec8da99093f8965de1b07064a003ae1ef306.zip
Version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/virtinst')
-rw-r--r--app-emulation/virtinst/ChangeLog7
-rw-r--r--app-emulation/virtinst/virtinst-0.600.2.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/app-emulation/virtinst/ChangeLog b/app-emulation/virtinst/ChangeLog
index 80ee1fa3001f..58ca84d8af8f 100644
--- a/app-emulation/virtinst/ChangeLog
+++ b/app-emulation/virtinst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virtinst
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.39 2012/03/24 17:11:35 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.40 2012/07/11 05:23:59 cardoe Exp $
+
+*virtinst-0.600.2 (10 Jul 2012)
+
+ 10 Jul 2012; Doug Goldstein <cardoe@gentoo.org> +virtinst-0.600.2.ebuild:
+ Version bump
24 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> virtinst-0.600.1.ebuild:
x86 stable wrt bug #407557
diff --git a/app-emulation/virtinst/virtinst-0.600.2.ebuild b/app-emulation/virtinst/virtinst-0.600.2.ebuild
new file mode 100644
index 000000000000..7de38cf88191
--- /dev/null
+++ b/app-emulation/virtinst/virtinst-0.600.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.600.2.ebuild,v 1.1 2012/07/11 05:23:59 cardoe Exp $
+
+#BACKPORTS=2
+
+EAPI=3
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="http://git.fedorahosted.org/git/python-virtinst.git"
+ GIT_ECLASS="git-2"
+fi
+
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils ${GIT_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-bp-${BACKPORTS}.tar.bz2
+ http://dev.gentoo.org/~cardoe/distfiles/${P}-bp-${BACKPORTS}.tar.bz2}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Python modules for starting virtualized guest installations"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+RDEPEND=">=app-emulation/libvirt-0.7.0[python]
+ dev-python/urlgrabber
+ dev-libs/libxml2[python]"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="virtconv virtinst"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ distutils_src_prepare
+}