summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-10 10:35:27 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-10 10:35:27 +0000
commit47cc74b90370a839065239068a1215e2e7ee9c39 (patch)
tree7c2f7a27e736ab54c9c3b9eedc35a152bc17ca3e /app-i18n
parentStable on alpha, bug 69985. (Manifest recommit) (diff)
downloadgentoo-2-47cc74b90370a839065239068a1215e2e7ee9c39.tar.gz
gentoo-2-47cc74b90370a839065239068a1215e2e7ee9c39.tar.bz2
gentoo-2-47cc74b90370a839065239068a1215e2e7ee9c39.zip
Fixed compilation if canna is not installed (and USE="-canna"); bug #70578.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/iiimf-skk/ChangeLog5
-rw-r--r--app-i18n/iiimf-skk/iiimf-skk-0.1.22.95.ebuild15
2 files changed, 13 insertions, 7 deletions
diff --git a/app-i18n/iiimf-skk/ChangeLog b/app-i18n/iiimf-skk/ChangeLog
index 1259183eed00..fb7d2a9f2c1b 100644
--- a/app-i18n/iiimf-skk/ChangeLog
+++ b/app-i18n/iiimf-skk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-i18n/iiimf-skk
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/iiimf-skk/ChangeLog,v 1.2 2004/09/14 08:27:21 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/iiimf-skk/ChangeLog,v 1.3 2004/11/10 10:35:27 usata Exp $
+
+ 10 Nov 2004; Mamoru KOMACHI <usata@gentoo.org> iiimf-skk-0.1.22.95.ebuild:
+ Fixed compilation if canna is not installed (and USE="-canna"); bug #70578.
14 Sep 2004; Mamoru KOMACHI <usata@gentoo.org> iiimf-skk-0.1.22.95.ebuild:
Added einfos to tell how to use the module.
diff --git a/app-i18n/iiimf-skk/iiimf-skk-0.1.22.95.ebuild b/app-i18n/iiimf-skk/iiimf-skk-0.1.22.95.ebuild
index e1bc8d37b3b2..a218e355f11e 100644
--- a/app-i18n/iiimf-skk/iiimf-skk-0.1.22.95.ebuild
+++ b/app-i18n/iiimf-skk/iiimf-skk-0.1.22.95.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/iiimf-skk/iiimf-skk-0.1.22.95.ebuild,v 1.2 2004/09/14 08:27:21 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/iiimf-skk/iiimf-skk-0.1.22.95.ebuild,v 1.3 2004/11/10 10:35:27 usata Exp $
inherit eutils
@@ -31,14 +31,17 @@ src_unpack() {
src_compile() {
+ local myconf
+ # configure script is broken wrt --disable-*
+ use nls && myconf="${myconf} --enable-nls"
+ use gtk2 && myconf="${myconf} --enable-gtk2"
+ use debug && myconf="${myconf} --enable-debug"
+ use canna && myconf="${myconf} --enable-canna"
+
econf \
- `use_enable nls` \
- `use_enable gtk2` \
- `use_enable debug` \
- `use_enable canna` \
--with-skkserv-host="localhost" \
--with-skkserv-port=1178 \
- || die "econf failed"
+ ${myconf} || die "econf failed"
emake -j1 || die
}