summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-08-14 19:21:58 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-08-14 19:21:58 +0000
commit5b764f3fb0ef81d07264b3422fb69b2272d68e3c (patch)
tree3b380e3aca7819379f042082c12b20f956800373 /app-office/mozilla-sunbird-bin
parentStable on alpha. (diff)
downloadgentoo-2-5b764f3fb0ef81d07264b3422fb69b2272d68e3c.tar.gz
gentoo-2-5b764f3fb0ef81d07264b3422fb69b2272d68e3c.tar.bz2
gentoo-2-5b764f3fb0ef81d07264b3422fb69b2272d68e3c.zip
version bump thanks to Martin Wegner <bugzilla-gentoo@mroot.net> and others in bug 114995
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'app-office/mozilla-sunbird-bin')
-rw-r--r--app-office/mozilla-sunbird-bin/ChangeLog9
-rw-r--r--app-office/mozilla-sunbird-bin/files/digest-mozilla-sunbird-bin-0.3_alpha23
-rw-r--r--app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.3_alpha2.ebuild82
3 files changed, 93 insertions, 1 deletions
diff --git a/app-office/mozilla-sunbird-bin/ChangeLog b/app-office/mozilla-sunbird-bin/ChangeLog
index 7503ec15d7e6..6950b2698a7b 100644
--- a/app-office/mozilla-sunbird-bin/ChangeLog
+++ b/app-office/mozilla-sunbird-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/mozilla-sunbird-bin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/ChangeLog,v 1.12 2006/08/14 19:02:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/ChangeLog,v 1.13 2006/08/14 19:21:58 genstef Exp $
+
+*mozilla-sunbird-bin-0.3_alpha2 (14 Aug 2006)
+
+ 14 Aug 2006; Stefan Schweizer <genstef@gentoo.org>
+ +mozilla-sunbird-bin-0.3_alpha2.ebuild:
+ version bump thanks to Martin Wegner <bugzilla-gentoo@mroot.net> and others
+ in bug 114995
14 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org>
-mozilla-sunbird-bin-0.2.ebuild:
diff --git a/app-office/mozilla-sunbird-bin/files/digest-mozilla-sunbird-bin-0.3_alpha2 b/app-office/mozilla-sunbird-bin/files/digest-mozilla-sunbird-bin-0.3_alpha2
new file mode 100644
index 000000000000..9dce840bcb2d
--- /dev/null
+++ b/app-office/mozilla-sunbird-bin/files/digest-mozilla-sunbird-bin-0.3_alpha2
@@ -0,0 +1,3 @@
+MD5 59af4313b245737425ebea5476ea2452 sunbird-0.3a2.en-US.linux-i686.tar.bz2 6943637
+RMD160 e27b1a472440f3e01dfc99f6b6cb0ae8d7ea480d sunbird-0.3a2.en-US.linux-i686.tar.bz2 6943637
+SHA256 6bbfff449775c6312f0c09ccdb7b793803a03ca6630f66ef3672ae68b954f6e3 sunbird-0.3a2.en-US.linux-i686.tar.bz2 6943637
diff --git a/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.3_alpha2.ebuild b/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.3_alpha2.ebuild
new file mode 100644
index 000000000000..06941c813b52
--- /dev/null
+++ b/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.3_alpha2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.3_alpha2.ebuild,v 1.1 2006/08/14 19:21:58 genstef Exp $
+
+inherit eutils mozilla-launcher multilib
+
+MY_PV=${PV/_alpha/a}
+DESCRIPTION="The Mozilla Sunbird Calendar"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/calendar/sunbird/releases/${MY_PV}/sunbird-${MY_PV}.en-US.linux-i686.tar.bz2"
+HOMEPAGE="http://www.mozilla.org/projects/calendar/sunbird.html"
+RESTRICT="nostrip"
+
+KEYWORDS="-* ~x86 ~amd64"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="|| ( ( x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXt
+ )
+ virtual/x11
+ )
+ virtual/xft
+ x86? (
+ >=sys-libs/lib-compat-1.0-r2
+ >=x11-libs/gtk+-2.2
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ )
+ >=www-client/mozilla-launcher-1.44"
+
+S=${WORKDIR}/sunbird
+
+pkg_config() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/sunbird
+
+ # Install sunbird in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv ${S} ${D}${MOZILLA_FIVE_HOME}
+
+ # Install initialization file that is normally created by root running
+ # sunbird the first time
+ insinto ${MOZILLA_FIVE_HOME}/chrome
+ newins ${FILESDIR}/app-chrome.manifest-${PV} app-chrome.manifest
+ keepdir ${MOZILLA_FIVE_HOME}/extensions # required to run!
+
+ # Create /usr/bin/sunbird-bin
+ install_mozilla_launcher_stub sunbird-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ doicon ${FILESDIR}/icon/mozillasunbird-bin-icon.png
+ domenu ${FILESDIR}/icon/mozillasunbird-bin.desktop
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/sunbird
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf ${ROOT}${MOZILLA_FIVE_HOME}
+}
+
+pkg_postinst() {
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}