summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-14 09:44:45 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-14 09:44:45 +0000
commit0cbf0b43961db81d9289b831f944ec9eb72d3ddd (patch)
tree5f641026f9cd9cac7605efca1846ca2412b88193 /dev-haskell/snap-core
parentInitial commit. Enumeratees for the incremental conversion of builders to byt... (diff)
downloadgentoo-2-0cbf0b43961db81d9289b831f944ec9eb72d3ddd.tar.gz
gentoo-2-0cbf0b43961db81d9289b831f944ec9eb72d3ddd.tar.bz2
gentoo-2-0cbf0b43961db81d9289b831f944ec9eb72d3ddd.zip
Initial commit. Snap: A Haskell Web Framework (core interfaces and types).
(Portage version: 2.2.7_p18/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/snap-core')
-rw-r--r--dev-haskell/snap-core/ChangeLog9
-rw-r--r--dev-haskell/snap-core/Manifest3
-rw-r--r--dev-haskell/snap-core/metadata.xml47
-rw-r--r--dev-haskell/snap-core/snap-core-0.9.5.0.ebuild51
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-haskell/snap-core/ChangeLog b/dev-haskell/snap-core/ChangeLog
new file mode 100644
index 000000000000..18270e22a6cc
--- /dev/null
+++ b/dev-haskell/snap-core/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/snap-core
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/snap-core/ChangeLog,v 1.1 2013/11/14 09:44:45 slyfox Exp $
+
+*snap-core-0.9.5.0 (14 Nov 2013)
+
+ 14 Nov 2013; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+ +snap-core-0.9.5.0.ebuild:
+ Initial commit. Snap: A Haskell Web Framework (core interfaces and types).
diff --git a/dev-haskell/snap-core/Manifest b/dev-haskell/snap-core/Manifest
new file mode 100644
index 000000000000..5adc464f4305
--- /dev/null
+++ b/dev-haskell/snap-core/Manifest
@@ -0,0 +1,3 @@
+DIST snap-core-0.9.5.0.tar.gz 90539 SHA256 a4520d108be8fffe42fcdbd14637c22b719bd23ff7d0439ca9f900e4ddabbdc4 SHA512 6f8e0db2e2f0eca1d4f9031d4e73ff8f0b7fc294f428ef6826c26fa9a7da7083dcfa85ef6db4c88ccc7b4836e029f4734efd058eb72cff71d0804922ecac06c7 WHIRLPOOL ff67b688228d031f516ada882e62ba03a10dbb367e2ef3a1cd5fecfbf2bc6a9d381abd4158e20184499be2536c16479b53b9dc1c5cc8748341778d5de2a4b32c
+EBUILD snap-core-0.9.5.0.ebuild 2454 SHA256 678091e2d3957fde279107fcd9afea905bbe8becc79b35f82a3690f2ae4e2c0b SHA512 c6253303480c437de79e00d8244ca0e49ef5fe816ec390612062be682bec7c02e32b628bba6e41a5b13598bf0df6e7875daf644491bb9c6b3ff24d9bcc796cef WHIRLPOOL 6aecfbc74d29bfb16bd19330aca1b59b380b818879f272024315a1900ccde371de969697a5573cb92e1cb177796db4c8e6499654b8f48127998e601b2757eda9
+MISC metadata.xml 1874 SHA256 469dc6b144c7c12bf1a9983805a598e683dc70d0e0858544c0276439428ad357 SHA512 e75ec122a3c4338fb7cf80111459839dda1f26f15a88eacd9c1921d7fea10505ec6cac8b9e522f2f21b1da8bedb0e7816bada3b00f1fba7d72d89d0bb6db8a61 WHIRLPOOL 9c1f3596586aab525c447337f16fed2ef7fbab7130b2f3809c8b55bd8c809566bacba2c919d58817fa9e9fe9115cfd8f0e682b0bd4062f2f902f7bdca33d95e5
diff --git a/dev-haskell/snap-core/metadata.xml b/dev-haskell/snap-core/metadata.xml
new file mode 100644
index 000000000000..46de3f9fbec7
--- /dev/null
+++ b/dev-haskell/snap-core/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='portable'>No non-haskell unportable code.</flag>
+ </use>
+ <longdescription>
+ Snap is a simple and fast web development framework and server written in
+ Haskell. For more information or to download the latest version, you can
+ visit the Snap project website at &lt;http://snapframework.com/&gt;.
+
+ This library contains the core definitions and types for the Snap framework,
+ including:
+
+ 1. Primitive types and functions for HTTP (requests, responses, cookies,
+ post/query parameters, etc)
+
+ 2. Type aliases and helper functions for Iteratee I/O
+
+ 3. A monad for programming web handlers called \&quot;Snap\&quot;, inspired by
+ happstack&#39;s (&lt;http://happstack.com/index.html&gt;), which allows:
+
+ * Stateful access to the HTTP request and response objects
+
+ * Monadic failure (i.e. MonadPlus/Alternative instances) for declining
+ to handle requests and chaining handlers together
+
+ * Early termination of the computation if you know early what you want
+ to return and want to prevent further monadic processing
+
+ /Quick start/: The &#39;Snap&#39; monad and HTTP definitions are in &quot;Snap.Core&quot;,
+ some iteratee utilities are in &quot;Snap.Iteratee&quot;.
+
+ Higher-level facilities for building web applications (like user/session
+ management, component interfaces, data modeling, etc.) are planned but not
+ yet implemented, so this release will mostly be of interest for those who:
+
+ * need a fast and minimal HTTP API at roughly the same level of abstraction
+ as Java servlets, or
+
+ * are interested in contributing to the Snap Framework project.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/snap-core/snap-core-0.9.5.0.ebuild b/dev-haskell/snap-core/snap-core-0.9.5.0.ebuild
new file mode 100644
index 000000000000..aa35a1bb219a
--- /dev/null
+++ b/dev-haskell/snap-core/snap-core-0.9.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/snap-core/snap-core-0.9.5.0.ebuild,v 1.1 2013/11/14 09:44:45 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Snap: A Haskell Web Framework (core interfaces and types)"
+HOMEPAGE="http://snapframework.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug portable"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.11:=[profile?]
+ >=dev-haskell/attoparsec-enumerator-0.3:=[profile?] <dev-haskell/attoparsec-enumerator-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-enumerator-0.2:=[profile?] <dev-haskell/blaze-builder-enumerator-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-0.3:=[profile?] <dev-haskell/case-insensitive-1.2:=[profile?]
+ >=dev-haskell/deepseq-1.1:=[profile?] <dev-haskell/deepseq-1.4:=[profile?]
+ >=dev-haskell/enumerator-0.4.15:=[profile?] <dev-haskell/enumerator-0.5:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-2:=[profile?]
+ >=dev-haskell/monadcatchio-transformers-0.2.1:=[profile?] <dev-haskell/monadcatchio-transformers-0.4:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.2:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-2:=[profile?]
+ >=dev-haskell/regex-posix-0.95:=[profile?] <dev-haskell/regex-posix-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?] <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.4.3:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/zlib-enum-0.2.1:=[profile?] <dev-haskell/zlib-enum-0.3:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ !portable? ( >=dev-haskell/bytestring-mmap-0.2.2:=[profile?] <dev-haskell/bytestring-mmap-0.3:=[profile?] )
+ || ( ( >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.2:=[profile?] )
+ ( >=dev-haskell/hashable-1.2.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?] ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug) \
+ $(cabal_flag portable portable)
+}