summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-04-11 20:41:26 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2015-04-11 20:41:26 +0000
commite0bb5e3f1b18c4b8573de8f82afa0eb71c76037c (patch)
tree5abd6dc6b05e4a78ab4d2dacd18481f4f6cdbc20 /dev-lang/rust-bin
parentAdd libecwj2 to lcms:0 revdeps mask (diff)
downloadgentoo-2-e0bb5e3f1b18c4b8573de8f82afa0eb71c76037c.tar.gz
gentoo-2-e0bb5e3f1b18c4b8573de8f82afa0eb71c76037c.tar.bz2
gentoo-2-e0bb5e3f1b18c4b8573de8f82afa0eb71c76037c.zip
version bump, sync with overlay, cargo support, close bug#541298
(Portage version: 2.2.18/cvs/Linux i686, signed Manifest commit with key B2EFA1D4)
Diffstat (limited to 'dev-lang/rust-bin')
-rw-r--r--dev-lang/rust-bin/ChangeLog8
-rw-r--r--dev-lang/rust-bin/metadata.xml4
-rw-r--r--dev-lang/rust-bin/rust-bin-1.0.0_beta.ebuild (renamed from dev-lang/rust-bin/rust-bin-1.0.0_alpha2.ebuild)21
3 files changed, 27 insertions, 6 deletions
diff --git a/dev-lang/rust-bin/ChangeLog b/dev-lang/rust-bin/ChangeLog
index 327323362b1b..9709ebd930cb 100644
--- a/dev-lang/rust-bin/ChangeLog
+++ b/dev-lang/rust-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/rust-bin
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/ChangeLog,v 1.4 2015/03/31 19:12:31 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/ChangeLog,v 1.5 2015/04/11 20:41:26 jauhien Exp $
+
+*rust-bin-1.0.0_beta (11 Apr 2015)
+
+ 11 Apr 2015; <jauhien@gentoo.org> +rust-bin-1.0.0_beta.ebuild,
+ -rust-bin-1.0.0_alpha2.ebuild, metadata.xml:
+ version bump, sync with overlay, cargo support, close bug#541298
31 Mar 2015; Ulrich Müller <ulm@gentoo.org> rust-bin-1.0.0_alpha2.ebuild:
Update dependency after package move of eselect modules to app-eselect.
diff --git a/dev-lang/rust-bin/metadata.xml b/dev-lang/rust-bin/metadata.xml
index 0b7db932cfa4..f16616d7bdb8 100644
--- a/dev-lang/rust-bin/metadata.xml
+++ b/dev-lang/rust-bin/metadata.xml
@@ -5,4 +5,8 @@
<email>jauhien@gentoo.org</email>
<name>Jauhien Piatlicki</name>
</maintainer>
+ <use>
+ <flag name="cargo-bundled">Use the bundled cargo
+ instead of <pkg>dev-rust/cargo</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/dev-lang/rust-bin/rust-bin-1.0.0_alpha2.ebuild b/dev-lang/rust-bin/rust-bin-1.0.0_beta.ebuild
index ec6f96ee0521..3464cb931ea9 100644
--- a/dev-lang/rust-bin/rust-bin-1.0.0_alpha2.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.0.0_beta.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/rust-bin-1.0.0_alpha2.ebuild,v 1.2 2015/03/31 19:12:31 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/rust-bin-1.0.0_beta.ebuild,v 1.1 2015/04/11 20:41:26 jauhien Exp $
-EAPI="5"
+EAPI=5
-inherit eutils
+inherit eutils bash-completion-r1
-MY_PV="1.0.0-alpha.2"
+MY_PV="${PV/_/-}"
DESCRIPTION="Systems programming language from Mozilla"
HOMEPAGE="http://www.rust-lang.org/"
SRC_URI="amd64? ( http://static.rust-lang.org/dist/rust-${MY_PV}-x86_64-unknown-linux-gnu.tar.gz )
@@ -16,10 +16,11 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="emacs vim-syntax zsh-completion"
+IUSE="cargo-bundled doc"
DEPEND=">=app-eselect/eselect-rust-0.2_pre20150206
!dev-lang/rust:0
+ cargo-bundled? ( !dev-rust/cargo )
"
RDEPEND="${DEPEND}"
@@ -33,7 +34,11 @@ src_unpack() {
}
src_install() {
+ local components=rustc
+ use cargo-bundled && components="${components},cargo"
+ use doc && components="${components},rust-docs"
./install.sh \
+ --components="${components}" \
--disable-verify \
--prefix="${D}/opt/${P}" \
--mandir="${D}/usr/share/${P}/man" \
@@ -59,6 +64,12 @@ src_install() {
dodir /etc/env.d/rust
touch "${D}/etc/env.d/rust/provider-${P}" || die
+ if use cargo-bundled ; then
+ dosym "/opt/${P}/bin/cargo" /usr/bin/cargo
+ dosym "/opt/${P}/share/zsh/site-functions/_cargo" /usr/share/zsh/site-functions/_cargo
+ newbashcomp "${D}/opt/${P}/etc/bash_completion.d/cargo" cargo
+ rm -rf "${D}/opt/${P}/etc"
+ fi
}
pkg_postinst() {