summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-12-13 20:54:39 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-12-13 20:54:39 +0000
commitbb55ca3b5dac43ce11787bc4a147ef6547201bcb (patch)
treecab84c00a96ee7dff400757f46672fc1b9eb96b9 /dev-lang
parentChanged maintainer to net-p2p, acked by armin76 (diff)
downloadgentoo-2-bb55ca3b5dac43ce11787bc4a147ef6547201bcb.tar.gz
gentoo-2-bb55ca3b5dac43ce11787bc4a147ef6547201bcb.tar.bz2
gentoo-2-bb55ca3b5dac43ce11787bc4a147ef6547201bcb.zip
Version bump
(Portage version: 2.2_rc16/cvs/Linux 2.6.18-gentoo-r3 i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog8
-rw-r--r--dev-lang/python/files/python-2.6_turkish.patch130
-rw-r--r--dev-lang/python/python-2.6.1.ebuild268
3 files changed, 405 insertions, 1 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index ffde3ee2c781..3b4a4524ba6c 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.357 2008/12/09 18:46:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.358 2008/12/13 20:54:39 neurogeek Exp $
+
+*python-2.6.1 (13 Dec 2008)
+
+ 13 Dec 2008; Jesus Rivero <neurogeek@gentoo.org>
+ +files/python-2.6_turkish.patch, +python-2.6.1.ebuild:
+ Version bump
09 Dec 2008; Mike Frysinger <vapier@gentoo.org> python-2.5.2-r8.ebuild,
python-2.6-r5.ebuild:
diff --git a/dev-lang/python/files/python-2.6_turkish.patch b/dev-lang/python/files/python-2.6_turkish.patch
new file mode 100644
index 000000000000..2eb50527eed7
--- /dev/null
+++ b/dev-lang/python/files/python-2.6_turkish.patch
@@ -0,0 +1,130 @@
+diff -uNr Python-2.6.1.orig/Lib/decimal.py Python-2.6.1/Lib/decimal.py
+--- Python-2.6.1.orig/Lib/decimal.py 2008-12-13 14:30:59.000000000 -0430
++++ Python-2.6.1/Lib/decimal.py 2008-12-13 14:32:59.000000000 -0430
+@@ -152,6 +152,13 @@
+ ROUND_HALF_DOWN = 'ROUND_HALF_DOWN'
+ ROUND_05UP = 'ROUND_05UP'
+
++import string
++
++def ascii_upper(s):
++ trans_table = string.maketrans(string.ascii_lowercase, string.ascii_uppercase)
++ return s.translate(trans_table)
++
++
+ # Errors
+
+ class DecimalException(ArithmeticError):
+@@ -3563,7 +3570,7 @@
+ if name.startswith('_round_')]
+ for name in rounding_functions:
+ # name is like _round_half_even, goes to the global ROUND_HALF_EVEN value.
+- globalname = name[1:].upper()
++ globalname = ascii_upper(name[1:])
+ val = globals()[globalname]
+ Decimal._pick_rounding_function[val] = name
+
+diff -uNr Python-2.6.1.orig/Lib/email/__init__.py Python-2.6.1/Lib/email/__init__.py
+--- Python-2.6.1.orig/Lib/email/__init__.py 2008-12-13 14:30:59.000000000 -0430
++++ Python-2.6.1/Lib/email/__init__.py 2008-12-13 14:34:13.000000000 -0430
+@@ -109,15 +109,19 @@
+ 'Text',
+ ]
+
++import string
++lower_map = string.maketrans(string.ascii_uppercase, string.ascii_lowercase)
++
++
+ for _name in _LOWERNAMES:
+- importer = LazyImporter(_name.lower())
++ importer = LazyImporter(_name.translate(lower_map))
+ sys.modules['email.' + _name] = importer
+ setattr(sys.modules['email'], _name, importer)
+
+
+ import email.mime
+ for _name in _MIMENAMES:
+- importer = LazyImporter('mime.' + _name.lower())
++ importer = LazyImporter('mime.' + _name.translate(lower_map))
+ sys.modules['email.MIME' + _name] = importer
+ setattr(sys.modules['email'], 'MIME' + _name, importer)
+ setattr(sys.modules['email.mime'], _name, importer)
+diff -uNr Python-2.6.1.orig/Lib/locale.py Python-2.6.1/Lib/locale.py
+--- Python-2.6.1.orig/Lib/locale.py 2008-12-13 14:30:59.000000000 -0430
++++ Python-2.6.1/Lib/locale.py 2008-12-13 14:57:18.000000000 -0430
+@@ -294,6 +294,14 @@
+ # overridden below)
+ _setlocale = setlocale
+
++# Avoid relying on the locale-dependent .lower() method
++# (see bug #1813).
++_ascii_lower_map = ''.join(
++ chr(x + 32 if x >= ord('A') and x <= ord('Z') else x)
++ for x in range(256)
++)
++
++
+ def normalize(localename):
+
+ """ Returns a normalized locale code for the given locale
+@@ -311,7 +319,7 @@
+
+ """
+ # Normalize the locale name and extract the encoding
+- fullname = localename.lower()
++ fullname = localename.translate(_ascii_lower_map)
+ if ':' in fullname:
+ # ':' is sometimes used as encoding delimiter.
+ fullname = fullname.replace(':', '.')
+diff -uNr Python-2.6.1.orig/Lib/test/test_codecs.py Python-2.6.1/Lib/test/test_codecs.py
+--- Python-2.6.1.orig/Lib/test/test_codecs.py 2008-12-13 14:30:59.000000000 -0430
++++ Python-2.6.1/Lib/test/test_codecs.py 2008-12-13 14:58:33.000000000 -0430
+@@ -1,5 +1,6 @@
+ from test import test_support
+ import unittest
++import locale
+ import codecs
+ import sys, StringIO, _testcapi
+
+@@ -1078,6 +1079,16 @@
+ self.assertRaises(LookupError, codecs.lookup, "__spam__")
+ self.assertRaises(LookupError, codecs.lookup, " ")
+
++ def test_lookup_with_locale(self):
++ # Bug #1813: when normalizing codec name, lowercasing must be locale
++ # agnostic, otherwise the looked up codec name might end up wrong.
++ try:
++ locale.setlocale(locale.LC_CTYPE, 'tr')
++ except locale.Error:
++ # SKIPped test
++ return
++ codecs.lookup('ISO8859_1')
++
+ def test_getencoder(self):
+ self.assertRaises(TypeError, codecs.getencoder)
+ self.assertRaises(LookupError, codecs.getencoder, "__spam__")
+diff -uNr Python-2.6.1.orig/Python/codecs.c Python-2.6.1/Python/codecs.c
+--- Python-2.6.1.orig/Python/codecs.c 2008-12-13 14:31:00.000000000 -0430
++++ Python-2.6.1/Python/codecs.c 2008-12-13 14:59:43.000000000 -0430
+@@ -45,6 +45,12 @@
+ return -1;
+ }
+
++/* isupper() forced into the ASCII Locale */
++#define ascii_isupper(x) (((x) >= 0x41) && ((x) <= 0x5A))
++/* tolower() forced into the ASCII Locale */
++#define ascii_tolower(x) (ascii_isupper(x) ? ((x) + 0x20) : (x))
++
++
+ /* Convert a string to a normalized Python string: all characters are
+ converted to lower case, spaces are replaced with underscores. */
+
+@@ -70,7 +76,7 @@
+ if (ch == ' ')
+ ch = '-';
+ else
+- ch = tolower(Py_CHARMASK(ch));
++ ch = ascii_tolower(Py_CHARMASK(ch));
+ p[i] = ch;
+ }
+ return v;
diff --git a/dev-lang/python/python-2.6.1.ebuild b/dev-lang/python/python-2.6.1.ebuild
new file mode 100644
index 000000000000..601a0b1d985d
--- /dev/null
+++ b/dev-lang/python/python-2.6.1.ebuild
@@ -0,0 +1,268 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.1.ebuild,v 1.1 2008/12/13 20:54:39 neurogeek Exp $
+
+# NOTE about python-portage interactions :
+# - Do not add a pkg_setup() check for a certain version of portage
+# in dev-lang/python. It _WILL_ stop people installing from
+# Gentoo 1.4 images.
+
+EAPI=2
+
+inherit eutils autotools flag-o-matic python versionator toolchain-funcs libtool
+
+# we need this so that we don't depends on python.eclass
+PYVER_MAJOR=$(get_major_version)
+PYVER_MINOR=$(get_version_component_range 2)
+PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
+
+MY_P="Python-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Python is an interpreted, interactive, object-oriented programming language."
+HOMEPAGE="http://www.python.org/"
+SRC_URI="http://www.python.org/ftp/python/2.6.1/${MY_P}.tar.bz2
+ mirror://gentoo/python-gentoo-patches-2.6-r5.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="berkdb build doc elibc_uclibc examples +expat gdbm ipv6 ncurses readline sqlite ssl +threads tk ucs2 wininst"
+
+# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes,cjkcodecs}
+# do not conflict with the ones in python proper. - liquidx
+
+DEPEND=">=app-admin/eselect-python-20080925
+ >=sys-libs/zlib-1.1.3
+ !build? (
+ sqlite? ( >=dev-db/sqlite-3 )
+ tk? ( >=dev-lang/tk-8.0 )
+ ncurses? ( >=sys-libs/ncurses-5.2
+ readline? ( >=sys-libs/readline-4.1 ) )
+ berkdb? ( >=sys-libs/db-3.1 )
+ gdbm? ( sys-libs/gdbm )
+ ssl? ( dev-libs/openssl )
+ doc? ( dev-python/python-docs:2.5 )
+ expat? ( dev-libs/expat )
+ )"
+
+# NOTE: changed RDEPEND to PDEPEND to resolve bug 88777. - kloeri
+# NOTE: added blocker to enforce correct merge order for bug 88777. - zmedico
+
+PDEPEND="${DEPEND} app-admin/python-updater"
+PROVIDE="virtual/python"
+
+src_prepare() {
+ default
+
+ if tc-is-cross-compiler ; then
+ [[ $(python -V 2>&1) != "Python ${PV}" ]] && \
+ die "Crosscompiling requires the same host and build versions."
+ epatch "${FILESDIR}"/python-2.6-test-cross.patch
+ else
+ rm "${WORKDIR}/${PYVER}"/*_all_crosscompile.patch
+ fi
+
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/${PYVER}"
+
+ epatch "${FILESDIR}/${PN}-${PYVER}_turkish.patch"
+
+ sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
+ Lib/distutils/command/install.py \
+ Lib/distutils/sysconfig.py \
+ Lib/site.py \
+ Makefile.pre.in \
+ Modules/Setup.dist \
+ Modules/getpath.c \
+ setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
+
+ # fix os.utime() on hppa. utimes it not supported but unfortunately reported as working - gmsoft (22 May 04)
+ # PLEASE LEAVE THIS FIX FOR NEXT VERSIONS AS IT'S A CRITICAL FIX !!!
+ [ "${ARCH}" = "hppa" ] && sed -e 's/utimes //' -i "${S}"/configure
+
+ if ! use wininst; then
+ # remove microsoft windows executables
+ rm Lib/distutils/command/wininst-*.exe
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ # disable extraneous modules with extra dependencies
+ if use build; then
+ export PYTHON_DISABLE_MODULES="readline pyexpat dbm gdbm bsddb _curses _curses_panel _tkinter _sqlite3"
+ export PYTHON_DISABLE_SSL=1
+ else
+ # dbm module can link to berkdb or gdbm
+ # defaults to gdbm when both are enabled, #204343
+ local disable
+ use berkdb || use gdbm || disable="${disable} dbm"
+ use berkdb || disable="${disable} bsddb"
+ use expat || disable="${disable} pyexpat"
+ use gdbm || disable="${disable} gdbm"
+ use ncurses || disable="${disable} _curses _curses_panel"
+ use readline || disable="${disable} readline"
+ use sqlite || disable="${disable} sqlite3"
+ use ssl || export PYTHON_DISABLE_SSL=1
+ use tk || disable="${disable} _tkinter"
+ export PYTHON_DISABLE_MODULES="${disable}"
+ fi
+
+ export OPT="${CFLAGS}"
+
+ local myconf
+
+ # super-secret switch. don't use this unless you know what you're
+ # doing. enabling UCS2 support will break your existing python
+ # modules
+ use ucs2 \
+ && myconf="${myconf} --enable-unicode=ucs2" \
+ || myconf="${myconf} --enable-unicode=ucs4"
+
+ filter-flags -malign-double
+
+ # Seems to no longer be necessary
+ #[ "${ARCH}" = "amd64" ] && append-flags -fPIC
+ [ "${ARCH}" = "alpha" ] && append-flags -fPIC
+
+ # http://bugs.gentoo.org/show_bug.cgi?id=50309
+ if is-flag -O3; then
+ is-flag -fstack-protector-all && replace-flags -O3 -O2
+ use hardened && replace-flags -O3 -O2
+ fi
+
+ if tc-is-cross-compiler ; then
+ OPT="-O1" CFLAGS="" LDFLAGS="" CC="" \
+ ./configure || die "cross-configure failed"
+ emake python Parser/pgen || die "cross-make failed"
+ mv python hostpython
+ mv Parser/pgen Parser/hostpgen
+ make distclean
+ sed -i \
+ -e '/^HOSTPYTHON/s:=.*:=./hostpython:' \
+ -e '/^HOSTPGEN/s:=.*:=./Parser/hostpgen:' \
+ Makefile.pre.in || die "sed failed"
+ fi
+
+ # export CXX so it ends up in /usr/lib/python2.x/config/Makefile
+ tc-export CXX
+
+ # set LDFLAGS so we link modules with -lpython2.5 correctly.
+ # Needed on FreeBSD unless python2.5 is already installed.
+ # Please query BSD team before removing this!
+ append-ldflags "-L."
+
+ econf \
+ --with-fpectl \
+ --enable-shared \
+ $(use_enable ipv6) \
+ $(use_with threads) \
+ --infodir='${prefix}'/share/info \
+ --mandir='${prefix}'/share/man \
+ --with-libc='' \
+ ${myconf}
+}
+
+src_install() {
+ dodir /usr
+ emake DESTDIR="${D}" altinstall maninstall || die
+
+ mv "${D}"/usr/bin/python${PYVER}-config "${D}"/usr/bin/python-config-${PYVER}
+
+ # Fix slotted collisions
+ mv "${D}"/usr/bin/2to3 "${D}"/usr/bin/2to3-${PYVER}
+ mv "${D}"/usr/bin/pydoc "${D}"/usr/bin/pydoc${PYVER}
+ mv "${D}"/usr/bin/idle "${D}"/usr/bin/idle${PYVER}
+ mv "${D}"/usr/share/man/man1/python.1 \
+ "${D}"/usr/share/man/man1/python${PYVER}.1
+ rm -f "${D}"/usr/bin/smtpd.py
+
+ # While we're working on the config stuff... Let's fix the OPT var
+ # so that it doesn't have any opts listed in it. Prevents the problem
+ # with compiling things with conflicting opts later.
+ dosed -e 's:^OPT=.*:OPT=-DNDEBUG:' \
+ /usr/$(get_libdir)/python${PYVER}/config/Makefile
+
+ if use build ; then
+ rm -rf "${D}"/usr/$(get_libdir)/python${PYVER}/{test,encodings,email,lib-tk,bsddb/test}
+ else
+ use elibc_uclibc && rm -rf "${D}"/usr/$(get_libdir)/python${PYVER}/{test,bsddb/test}
+ use berkdb || rm -rf "${D}"/usr/$(get_libdir)/python${PYVER}/bsddb
+ use tk || rm -rf "${D}"/usr/$(get_libdir)/python${PYVER}/lib-tk
+ fi
+
+ prep_ml_includes usr/include/python${PYVER}
+
+ # The stuff below this line extends from 2.1, and should be deprecated
+ # in 2.3, or possibly can wait till 2.4
+
+ # seems like the build do not install Makefile.pre.in anymore
+ # it probably shouldn't - use DistUtils, people!
+ insinto /usr/$(get_libdir)/python${PYVER}/config
+ doins "${S}"/Makefile.pre.in
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${S}"/Tools || die "doins failed"
+ fi
+
+ newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT}
+ newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT}
+
+ # Installs empty directory.
+ rmdir "${D}"/usr/$(get_libdir)/${PN}${PV}/lib-old
+}
+
+pkg_postrm() {
+ eselect python update --ignore 3.0
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}
+}
+
+pkg_postinst() {
+ eselect python update --ignore 3.0
+ python_version
+
+ python_mod_optimize -x "(site-packages|test)" \
+ /usr/$(get_libdir)/python${PYVER}
+}
+
+src_test() {
+ # Tests won't work when cross compiling
+ if tc-is-cross-compiler ; then
+ elog "Disabling tests due to crosscompiling."
+ return
+ fi
+
+ # Byte compiling should be enabled here.
+ # Otherwise test_import fails.
+ python_enable_pyc
+
+ #skip all tests that fail during emerge but pass without emerge:
+ #(See bug# 67970)
+ local skip_tests="distutils global httpservers mimetools minidom mmap posix pyexpat sax strptime subprocess syntax tcl time urllib urllib2 webbrowser xml_etree"
+
+ # test_pow fails on alpha.
+ # http://bugs.python.org/issue756093
+ [[ ${ARCH} == "alpha" ]] && skip_tests="${skip_tests} pow"
+
+ for test in ${skip_tests} ; do
+ mv "${S}"/Lib/test/test_${test}.py "${T}"
+ done
+
+ # rerun failed tests in verbose mode (regrtest -w)
+ EXTRATESTOPTS="-w" make test || die "make test failed"
+
+ for test in ${skip_tests} ; do
+ mv "${T}"/test_${test}.py "${S}"/Lib/test/test_${test}.py
+ done
+
+ elog "Portage skipped the following tests which aren't able to run from emerge:"
+ for test in ${skip_tests} ; do
+ elog "test_${test}.py"
+ done
+
+ elog "If you'd like to run them, you may:"
+ elog "cd /usr/lib/python${PYVER}/test"
+ elog "and run the tests separately."
+}