summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-01-20 16:42:21 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-01-20 16:42:21 +0000
commit4d2f5376c15dabc0976860c61f19b6349977df08 (patch)
tree31ac5ca51268451ff1193c34b347e1844492a2ae /dev-libs/botan
parentuse masking xcb. (diff)
downloadgentoo-2-4d2f5376c15dabc0976860c61f19b6349977df08.tar.gz
gentoo-2-4d2f5376c15dabc0976860c61f19b6349977df08.tar.bz2
gentoo-2-4d2f5376c15dabc0976860c61f19b6349977df08.zip
Version bump, bug#162916, thanks to Jack Lloyd
(Portage version: 2.1.2-r1)
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog10
-rw-r--r--dev-libs/botan/botan-1.6.1.ebuild91
-rw-r--r--dev-libs/botan/files/botan-1.6.1-asm.patch39
-rw-r--r--dev-libs/botan/files/digest-botan-1.4.112
-rw-r--r--dev-libs/botan/files/digest-botan-1.4.122
-rw-r--r--dev-libs/botan/files/digest-botan-1.4.42
-rw-r--r--dev-libs/botan/files/digest-botan-1.4.92
-rw-r--r--dev-libs/botan/files/digest-botan-1.6.13
-rw-r--r--dev-libs/botan/metadata.xml5
9 files changed, 149 insertions, 7 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index a23311b26591..36ba51ee1f2f 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/botan
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.20 2006/12/27 17:05:22 peper Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.21 2007/01/20 16:42:21 alonbl Exp $
+
+*botan-1.6.1 (20 Jan 2007)
+
+ 20 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/botan-1.6.1-asm.patch, +botan-1.6.1.ebuild:
+ Version bump, bug#162916, thanks to Jack Lloyd
27 Dec 2006; Piotr Jaroszyński <peper@gentoo.org> botan-1.5.11.ebuild:
Add ~amd64 wrt bug #152692.
diff --git a/dev-libs/botan/botan-1.6.1.ebuild b/dev-libs/botan/botan-1.6.1.ebuild
new file mode 100644
index 000000000000..0d208b0718b7
--- /dev/null
+++ b/dev-libs/botan/botan-1.6.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.6.1.ebuild,v 1.1 2007/01/20 16:42:21 alonbl Exp $
+
+inherit eutils multilib
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://botan.randombit.net/files/${MY_P}.tgz"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="BSD"
+IUSE="bzip2 gmp ssl zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.3 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ gmp? ( >=dev-libs/gmp-4.2.1 )
+ ssl? ( >=dev-libs/openssl-0.9.8c )"
+
+# configure.pl requires Getopt::Long, File::Spec, and File::Copy;
+# all seem included in dev-lang/perl ATM.
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-asm.patch"
+}
+
+src_compile() {
+ # Modules that should work under any semi-recent Unix
+ local modules="alloc_mmap,es_egd,es_ftw,es_unix,fd_unix,ml_unix,tm_unix,tm_posix,mux_pthr"
+
+ if useq bzip2; then modules="$modules,comp_bzip2"; fi
+ if useq zlib; then modules="$modules,comp_zlib"; fi
+ if useq gmp; then modules="$modules,eng_gmp"; fi
+ if useq ssl; then modules="$modules,eng_ossl"; fi
+
+ # This is also supported on i586+ - hope this is correct.
+ # documention says sparc though not enables because of
+ # http://bugs.gentoo.org/show_bug.cgi?id=71760#c11
+
+ if [ "${ARCH}" = "alpha" -o "${ARCH}" = "amd64" ] || \
+ [ "${ARCH}" = "x86" -a "${CHOST:0:4}" != "i386" -a "${CHOST:0:4}" != "i486" ]; then
+ modules="$modules,tm_hard"
+ fi
+
+ # If we have assembly code for this machine, use it
+ if [ "${ARCH}" = "x86" ]; then
+ modules="$modules,mp_ia32,alg_ia32"
+ elif [ "${ARCH}" = "amd64" ]; then
+ modules="$modules,mp_amd64,alg_amd64"
+ elif [ "${ARCH}" = "alpha" -o "${ARCH}" = "ia64" -o \
+ "${ARCH}" = "ppc64" -o "${PROFILE_ARCH}" = "mips64" ]; then
+ modules="$modules,mp_asm64"
+ fi
+
+ # Enable v9 instructions for sparc64
+ if [ "${PROFILE_ARCH}" = "sparc64" ]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="$(echo ${CHOST} | cut -d - -f 1)"
+ fi
+
+ cd "${S}"
+ einfo "Enabling modules: " ${modules}
+
+ # FIXME: We might actually be on *BSD or OS X...
+ ./configure.pl \
+ --noauto gcc-linux-${CHOSTARCH} \
+ --libdir=/usr/$(get_libdir) \
+ --modules=$modules ||
+ die "configure.pl failed"
+ emake "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
+}
+
+src_test() {
+ chmod -R ugo+rX "${S}"
+ emake check || die "emake check failed"
+ env LD_LIBRARY_PATH="${S}" ./check --validate || die "validation tests failed"
+}
+
+src_install() {
+ make INSTALLROOT="${D}/usr" install || die "make install failed"
+}
diff --git a/dev-libs/botan/files/botan-1.6.1-asm.patch b/dev-libs/botan/files/botan-1.6.1-asm.patch
new file mode 100644
index 000000000000..6bb1675860a6
--- /dev/null
+++ b/dev-libs/botan/files/botan-1.6.1-asm.patch
@@ -0,0 +1,39 @@
+#
+# old_revision [0f5f960e749e55bc7b457b944ec168184353c300]
+#
+# patch "modules/alg_amd64/asm_macr.h"
+# from [c8fe2875602bdeeb27250cf791110e664b82cf0e]
+# to [35d79aea75780161d6d8c707a78f17f03955e6f6]
+#
+# patch "modules/alg_ia32/asm_macr.h"
+# from [540af413c630f50e7f0859b972be4d6618c788eb]
+# to [6454d46724e0b61ef2e110644f61b8fe165a2323]
+#
+============================================================
+--- modules/alg_amd64/asm_macr.h c8fe2875602bdeeb27250cf791110e664b82cf0e
++++ modules/alg_amd64/asm_macr.h 35d79aea75780161d6d8c707a78f17f03955e6f6
+@@ -6,6 +6,10 @@
+ #ifndef BOTAN_EXT_ASM_MACROS_H__
+ #define BOTAN_EXT_ASM_MACROS_H__
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
++
+ /*************************************************
+ * General/Global Macros *
+ *************************************************/
+============================================================
+--- modules/alg_ia32/asm_macr.h 540af413c630f50e7f0859b972be4d6618c788eb
++++ modules/alg_ia32/asm_macr.h 6454d46724e0b61ef2e110644f61b8fe165a2323
+@@ -6,6 +6,10 @@
+ #ifndef BOTAN_EXT_ASM_MACROS_H__
+ #define BOTAN_EXT_ASM_MACROS_H__
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
++
+ /*************************************************
+ * General/Global Macros *
+ *************************************************/
diff --git a/dev-libs/botan/files/digest-botan-1.4.11 b/dev-libs/botan/files/digest-botan-1.4.11
index 5df0c9d0cecb..1e965df1188f 100644
--- a/dev-libs/botan/files/digest-botan-1.4.11
+++ b/dev-libs/botan/files/digest-botan-1.4.11
@@ -1 +1,3 @@
MD5 987ad49322cc41496fc2eae38ddd93c1 Botan-1.4.11.tgz 1802089
+RMD160 c8aa827cf10151266b88e17c172999a6ccaab816 Botan-1.4.11.tgz 1802089
+SHA256 02d0482a0f06114e2d7848e4cf393e095c8857501177a5a2d2c03cecd199f1ed Botan-1.4.11.tgz 1802089
diff --git a/dev-libs/botan/files/digest-botan-1.4.12 b/dev-libs/botan/files/digest-botan-1.4.12
index 9ee24af4a786..375b39dafcc3 100644
--- a/dev-libs/botan/files/digest-botan-1.4.12
+++ b/dev-libs/botan/files/digest-botan-1.4.12
@@ -1 +1,3 @@
MD5 0bb60ed7c9f454fab6df9a06916fbec6 Botan-1.4.12.tgz 1801371
+RMD160 c7b78863eaa10668dc8ceaef70245a1a52938c2e Botan-1.4.12.tgz 1801371
+SHA256 b894065634c0822eda943d35169f1444348644269a4d1e53d6a0bd14cb3cc94f Botan-1.4.12.tgz 1801371
diff --git a/dev-libs/botan/files/digest-botan-1.4.4 b/dev-libs/botan/files/digest-botan-1.4.4
index cd21396cb9bf..dc73a17f01a8 100644
--- a/dev-libs/botan/files/digest-botan-1.4.4
+++ b/dev-libs/botan/files/digest-botan-1.4.4
@@ -1 +1,3 @@
MD5 9c71f4ce74fc02484e4499d923961815 Botan-1.4.4.tgz 1436270
+RMD160 836b7e9407636c5ec76b0a1c11d461967fa2f8b1 Botan-1.4.4.tgz 1436270
+SHA256 1ab6ab9e62f199d9f16cdc28653784aee94e6f526f7e4083a45069666fa5009e Botan-1.4.4.tgz 1436270
diff --git a/dev-libs/botan/files/digest-botan-1.4.9 b/dev-libs/botan/files/digest-botan-1.4.9
index 93b6bfbae4f0..b6ae5151e73d 100644
--- a/dev-libs/botan/files/digest-botan-1.4.9
+++ b/dev-libs/botan/files/digest-botan-1.4.9
@@ -1 +1,3 @@
MD5 42acef0f6a0d70d4fb3871f15b49f32f Botan-1.4.9.tgz 1812447
+RMD160 cf4ffbf4aebc08de6e3720a13c9557bae0dd493e Botan-1.4.9.tgz 1812447
+SHA256 234c399adc5694440cc4bc57170c74c3abc6157bad037d4a6d01435e5b330a0d Botan-1.4.9.tgz 1812447
diff --git a/dev-libs/botan/files/digest-botan-1.6.1 b/dev-libs/botan/files/digest-botan-1.6.1
new file mode 100644
index 000000000000..b092471132dc
--- /dev/null
+++ b/dev-libs/botan/files/digest-botan-1.6.1
@@ -0,0 +1,3 @@
+MD5 c7330b4db6408d47db34af7887b8bfca Botan-1.6.1.tgz 1845323
+RMD160 e729d03ac8aba3a8c157cd956f4ddf08d99fe33b Botan-1.6.1.tgz 1845323
+SHA256 4ff3ec8c0c5c21fcb5b56e2c54a4eeddf7101a883e13a816630ccff288c0a9c4 Botan-1.6.1.tgz 1845323
diff --git a/dev-libs/botan/metadata.xml b/dev-libs/botan/metadata.xml
index e5a6aeb8d6cf..b7c22173b3ec 100644
--- a/dev-libs/botan/metadata.xml
+++ b/dev-libs/botan/metadata.xml
@@ -3,11 +3,6 @@
<pkgmetadata>
<herd>crypto</herd>
<maintainer>
- <email>dragonheart@gentoo.org</email>
- <name>Daniel Black</name>
- <description>Gentoo Commiter</description>
-</maintainer>
-<maintainer>
<email>lloyd@randombit.net</email>
<name>Jack Lloyd </name>
<description>Ebuild contributor and botan author</description>