summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-18 18:50:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-18 18:50:50 +0000
commitb956d48ac945f74454014f59dc647338a8ba6f85 (patch)
tree701b5bcab1fb32cb774280d7e5079b14973d363a /dev-libs/libhash
parentAdd ~x86, tested on development container. (diff)
downloadgentoo-2-b956d48ac945f74454014f59dc647338a8ba6f85.tar.gz
gentoo-2-b956d48ac945f74454014f59dc647338a8ba6f85.tar.bz2
gentoo-2-b956d48ac945f74454014f59dc647338a8ba6f85.zip
Respect CPPFLAGS/LDFLAGS and fix linking of tests with --as-needed.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libhash')
-rw-r--r--dev-libs/libhash/ChangeLog8
-rw-r--r--dev-libs/libhash/libhash-1.0.3.ebuild10
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-libs/libhash/ChangeLog b/dev-libs/libhash/ChangeLog
index cdaad7fc771e..ab2ee2716da9 100644
--- a/dev-libs/libhash/ChangeLog
+++ b/dev-libs/libhash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libhash
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhash/ChangeLog,v 1.5 2007/02/09 02:30:32 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhash/ChangeLog,v 1.6 2010/05/18 18:50:50 flameeyes Exp $
+
+ 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ libhash-1.0.3.ebuild:
+ Respect CPPFLAGS/LDFLAGS and fix linking of tests with --as-needed.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-libs/libhash/libhash-1.0.3.ebuild b/dev-libs/libhash/libhash-1.0.3.ebuild
index d060e44fa980..13b33a13a563 100644
--- a/dev-libs/libhash/libhash-1.0.3.ebuild
+++ b/dev-libs/libhash/libhash-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhash/libhash-1.0.3.ebuild,v 1.1 2005/06/14 22:50:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhash/libhash-1.0.3.ebuild,v 1.2 2010/05/18 18:50:50 flameeyes Exp $
inherit toolchain-funcs
@@ -19,15 +19,15 @@ S=${WORKDIR}/${PN}
src_compile() {
rm -f Makefile
- $(tc-getCC) ${CFLAGS} -fPIC -shared -o libhash.so hash.c || die ".so failed"
- $(tc-getCC) ${CFLAGS} -c -o libhash.a hash.c || die ".a failed"
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -fPIC -shared -o libhash.so hash.c || die ".so failed"
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} -c -o libhash.a hash.c || die ".a failed"
}
src_test() {
cd tests
sed -i '/wrappers.h/d' *.c
for n in 2 3 ; do
- $(tc-getCC) -I.. -L.. -lhash ${n}.c -o ${n} || die "compile ${n} failed"
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -I.. -L.. ${n}.c -o ${n} -lhash || die "compile ${n} failed"
LD_LIBRARY_PATH=.. ./${n} || die "test ${n} failed"
done
}