summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-05 19:04:24 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-05 19:04:24 +0000
commit4640d80c71dfd2e2766e65ece2606653f29d9f27 (patch)
tree01aa070138674f18340269a59efcc93863a63991 /dev-libs
parentFix tests with USE=-doc. (diff)
downloadgentoo-2-4640d80c71dfd2e2766e65ece2606653f29d9f27.tar.gz
gentoo-2-4640d80c71dfd2e2766e65ece2606653f29d9f27.tar.bz2
gentoo-2-4640d80c71dfd2e2766e65ece2606653f29d9f27.zip
Version bump.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/nettle/ChangeLog7
-rw-r--r--dev-libs/nettle/nettle-2.7.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index d07b2c6c5f26..87acda6c16e3 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/nettle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.91 2013/05/27 19:46:39 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.92 2013/06/05 19:04:24 radhermit Exp $
+
+*nettle-2.7.1 (05 Jun 2013)
+
+ 05 Jun 2013; Tim Harder <radhermit@gentoo.org> +nettle-2.7.1.ebuild:
+ Version bump.
27 May 2013; Fabian Groffen <grobian@gentoo.org> nettle-2.7.ebuild:
Use prefixed libdir, bug #471298
diff --git a/dev-libs/nettle/nettle-2.7.1.ebuild b/dev-libs/nettle/nettle-2.7.1.ebuild
new file mode 100644
index 000000000000..b91425684a08
--- /dev/null
+++ b/dev-libs/nettle/nettle-2.7.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.7.1.ebuild,v 1.1 2013/06/05 19:04:24 radhermit Exp $
+
+EAPI=5
+
+inherit eutils autotools multilib
+
+DESCRIPTION="Low-level cryptographic library"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 LGPL-2.1 )"
+SLOT="0/4" # subslot = libnettle soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc +gmp neon static-libs test"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.7-shared.patch
+
+ sed -e '/CFLAGS=/s: -ggdb3::' \
+ -e 's/solaris\*)/sunldsolaris*)/' \
+ -i configure.ac || die
+
+ # conditionally build tests and examples required by tests
+ use test || sed -i '/SUBDIRS/s/testsuite examples//' Makefile.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-openssl bug #427526
+ econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable gmp public-key) \
+ $(use_enable static-libs static) \
+ --disable-openssl \
+ $(use_enable doc documentation) \
+ $(use_enable neon arm-neon)
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dohtml nettle.html
+ dodoc nettle.pdf
+ fi
+}