summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-05-23 10:06:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-05-23 10:06:58 +0000
commit45174414c188aea5a2e700425ae47e6b36cc153e (patch)
tree17ad9ba8c849d644eaf40defe0beafc0cb42f1b2 /dev-ml/camlp5
parentversion bump (diff)
downloadgentoo-2-45174414c188aea5a2e700425ae47e6b36cc153e.tar.gz
gentoo-2-45174414c188aea5a2e700425ae47e6b36cc153e.tar.bz2
gentoo-2-45174414c188aea5a2e700425ae47e6b36cc153e.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/camlp5')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-5.12.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 8691ade96ef4..db42bb028529 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.34 2009/05/14 20:02:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.35 2009/05/23 10:06:58 aballier Exp $
+
+*camlp5-5.12 (23 May 2009)
+
+ 23 May 2009; Alexis Ballier <aballier@gentoo.org> +camlp5-5.12.ebuild:
+ version bump
14 May 2009; Alexis Ballier <aballier@gentoo.org> -camlp5-5.09.ebuild,
-camlp5-5.10.ebuild:
diff --git a/dev-ml/camlp5/camlp5-5.12.ebuild b/dev-ml/camlp5/camlp5-5.12.ebuild
new file mode 100644
index 000000000000..bdfe0beae3c0
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.12.ebuild,v 1.1 2009/05/23 10:06:58 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib eutils
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake -j1 || die "emake failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code programs failed"
+ emake -j1 opt.opt || die "Compiling native code programs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}