summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-06-07 10:46:57 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-06-07 10:46:57 +0000
commitd5d3a131427d87d94ee1b86bf7634f5433c54424 (patch)
tree73ff666470ee390517ccf6350d7983a2fffd8a01 /dev-python/bpython
parentVersion bump. (diff)
downloadgentoo-2-d5d3a131427d87d94ee1b86bf7634f5433c54424.tar.gz
gentoo-2-d5d3a131427d87d94ee1b86bf7634f5433c54424.tar.bz2
gentoo-2-d5d3a131427d87d94ee1b86bf7634f5433c54424.zip
Version bump (bug #272917). Added a patch: now you can set light to True in .bpython.ini for light background.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/ChangeLog9
-rw-r--r--dev-python/bpython/bpython-0.9.2.ebuild (renamed from dev-python/bpython/bpython-0.9.1.ebuild)14
-rw-r--r--dev-python/bpython/files/bpython-0.9.2.patch47
3 files changed, 66 insertions, 4 deletions
diff --git a/dev-python/bpython/ChangeLog b/dev-python/bpython/ChangeLog
index bdf3ee24da6e..93b2efdb6a29 100644
--- a/dev-python/bpython/ChangeLog
+++ b/dev-python/bpython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/bpython
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/ChangeLog,v 1.1 2009/06/02 21:57:41 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/ChangeLog,v 1.2 2009/06/07 10:46:56 grozin Exp $
+
+*bpython-0.9.2 (07 Jun 2009)
+
+ 07 Jun 2009; Andrey Grozin <grozin@gentoo.org> -bpython-0.9.1.ebuild,
+ +bpython-0.9.2.ebuild, +files/bpython-0.9.2.patch:
+ Version bump (bug #272917). Added a patch: now you can set light to True
+ in .bpython.ini for light background.
*bpython-0.9.1 (02 Jun 2009)
diff --git a/dev-python/bpython/bpython-0.9.1.ebuild b/dev-python/bpython/bpython-0.9.2.ebuild
index 9678b8f3d8d3..9d4a8b595ceb 100644
--- a/dev-python/bpython/bpython-0.9.1.ebuild
+++ b/dev-python/bpython/bpython-0.9.2.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/bpython-0.9.1.ebuild,v 1.1 2009/06/02 21:57:41 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/bpython-0.9.2.ebuild,v 1.1 2009/06/07 10:46:56 grozin Exp $
+
+EAPI=2
inherit distutils
DESCRIPTION="Curses interface to python"
-HOMEPAGE="http://www.noiseforfree.com/bpython/"
-SRC_URI="http://www.noiseforfree.com/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.bpython-interpreter.org/"
+SRC_URI="http://www.bpython-interpreter.org/releases/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86"
@@ -12,3 +14,9 @@ IUSE=""
DEPEND="dev-python/pygments
dev-python/pyparsing"
RDEPEND="${DEPEND}"
+DOCS="sample.ini"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${P}.patch
+}
diff --git a/dev-python/bpython/files/bpython-0.9.2.patch b/dev-python/bpython/files/bpython-0.9.2.patch
new file mode 100644
index 000000000000..478858a0bb55
--- /dev/null
+++ b/dev-python/bpython/files/bpython-0.9.2.patch
@@ -0,0 +1,47 @@
+Index: bpython-0.9.2/bpython/cli.py
+===================================================================
+--- bpython-0.9.2.orig/bpython/cli.py
++++ bpython-0.9.2/bpython/cli.py
+@@ -55,6 +55,7 @@ from ConfigParser import ConfigParser, N
+ from pygments import format
+ from pygments.lexers import PythonLexer
+ from pygments.token import Token
++import bpython.formatter
+ from bpython.formatter import BPythonFormatter
+ from itertools import chain
+
+@@ -1828,6 +1829,7 @@ def loadini(configfile):
+ OPTS.tab_length = config.safeget('general', 'tab_length', 4)
+ OPTS.auto_display_list = config.safeget('general', 'auto_display_list', True)
+ OPTS.syntax = config.safeget('general', 'syntax', True)
++ OPTS.light = config.safeget('general', 'light', False)
+ OPTS.arg_spec = config.safeget('general', 'arg_spec', True)
+ OPTS.hist_file = config.safeget('general', 'hist_file', '~/.pythonhist')
+ OPTS.hist_length = config.safeget('general', 'hist_length', 100)
+@@ -1920,8 +1922,12 @@ def main(args=None):
+ path = os.path.expanduser('~/.bpythonrc') # migrating old configuration file
+ if os.path.isfile(path):
+ migrate_rc(path)
++
+ loadini(options.config)
+
++ if OPTS.light:
++ bpython.formatter.f_strings = bpython.formatter.f_strings_light
++
+ try:
+ o = curses.wrapper(main_curses)
+ except:
+Index: bpython-0.9.2/sample.ini
+===================================================================
+--- bpython-0.9.2.orig/sample.ini
++++ bpython-0.9.2/sample.ini
+@@ -14,6 +14,9 @@ auto_display_list = True
+ # Syntax highlighting as you type (default: True).
+ syntax = True
+
++# Light background (default: False).
++light = False
++
+ # Display the arg spec (list of arguments) for callables,
+ # when possible (default: True).
+ arg_spec = True