summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-02 08:14:31 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-02 08:14:31 +0000
commitb1695ae35bb6b87b7305b1dd933428e306e40bcf (patch)
treed9b17116620378ae1c9b5d1361e263d09409c433 /dev-python/characteristic
parentadd py3.2 support (diff)
downloadgentoo-2-b1695ae35bb6b87b7305b1dd933428e306e40bcf.tar.gz
gentoo-2-b1695ae35bb6b87b7305b1dd933428e306e40bcf.tar.bz2
gentoo-2-b1695ae35bb6b87b7305b1dd933428e306e40bcf.zip
new package, dep to service_identity, written by me
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/characteristic')
-rw-r--r--dev-python/characteristic/ChangeLog9
-rw-r--r--dev-python/characteristic/Manifest3
-rw-r--r--dev-python/characteristic/characteristic-14.1.0.ebuild42
-rw-r--r--dev-python/characteristic/metadata.xml5
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/characteristic/ChangeLog b/dev-python/characteristic/ChangeLog
new file mode 100644
index 000000000000..829b5724f69f
--- /dev/null
+++ b/dev-python/characteristic/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/characteristic
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/characteristic/ChangeLog,v 1.1 2014/09/02 08:14:31 idella4 Exp $
+
+*characteristic-14.1.0 (02 Sep 2014)
+
+ 02 Sep 2014; Ian Delaney <idella4@gentoo.org> +characteristic-14.1.0.ebuild,
+ +metadata.xml:
+ new package, dep to service_identity, written by me
diff --git a/dev-python/characteristic/Manifest b/dev-python/characteristic/Manifest
new file mode 100644
index 000000000000..0dbf284e8e25
--- /dev/null
+++ b/dev-python/characteristic/Manifest
@@ -0,0 +1,3 @@
+DIST characteristic-14.1.0.tar.gz 24612 SHA256 91e254948180678dd69e6143202b4686f2fa47cce136936079bb4d9a3b82419d SHA512 21bb40814f405c73471a83e15d1cfb07f74ebd157e647799bedffffd3909271145347eaec8ec09470dddad7224d1a15e8984a75f1fce00bbe20f9e1cb385f9b9 WHIRLPOOL d8044dfcbb7d75a383834bee842bd619b4bec65c8a0f467a563b9a80ee908bcf5c7de791eb220f9ba3b35a259a9ea6c6985f743518e2677d8a03a62db70ad98c
+EBUILD characteristic-14.1.0.ebuild 1079 SHA256 ad1a814f6f5ebd040bd8f7326d361d6451d93b364861bb7e790230d53f2db766 SHA512 4d343030482ba61b7a4b9e3d77ed5fe5e0104b5c8cdbdfad16fdee031921ab465792978cb3a717500f68692b0f90c87ab79d3781097755882e05e69bcdd95280 WHIRLPOOL 9afb8eecb3f044b0d04ce523c23e3945c6162e25936e1540b7c7eb3d22a83fe5ae882f0ad2399b4758d25bcda8ff1261e4368d0e0a52245f660ef84f25b94e7f
+MISC metadata.xml 160 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a SHA512 7c02a1de1ddcb6b7c6378cceff0458da3a15d5381417f7cdf01874e7c372664b8899863f41b3a2fd8d6ad67ceb732dac6da0cc17575bf8e3e6d89480417c6628 WHIRLPOOL ed2795e4466eda8c804d5067c87386e269a59fe959393057ca5ddc36851e00f5210c4da1adf4bbdfdbb7d1d3d5c60aced25727ca12fdc8305d9e263a3aca9b13
diff --git a/dev-python/characteristic/characteristic-14.1.0.ebuild b/dev-python/characteristic/characteristic-14.1.0.ebuild
new file mode 100644
index 000000000000..9495b2b1ef34
--- /dev/null
+++ b/dev-python/characteristic/characteristic-14.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/characteristic/characteristic-14.1.0.ebuild,v 1.1 2014/09/02 08:14:31 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python attributes without the boilerplate"
+HOMEPAGE="https://characteristic.readthedocs.org/ https://github.com/hynek/characteristic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test -a "--cov characteristic --cov-report term-missing"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/characteristic/metadata.xml b/dev-python/characteristic/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/characteristic/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>