summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-12-08 03:55:44 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-12-08 03:55:44 +0000
commitf2cd9006a33f2c4f1a5d223dc15aeb0d3cab3afd (patch)
tree7e60ccbf72e0663efdb5fbde9d8bff69f9275582 /dev-python/dbus-python
parentfix php check, add ~amd64 (diff)
downloadgentoo-2-f2cd9006a33f2c4f1a5d223dc15aeb0d3cab3afd.tar.gz
gentoo-2-f2cd9006a33f2c4f1a5d223dc15aeb0d3cab3afd.tar.bz2
gentoo-2-f2cd9006a33f2c4f1a5d223dc15aeb0d3cab3afd.zip
upstream version bump
(Portage version: 2.1.4_rc8)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog7
-rw-r--r--dev-python/dbus-python/dbus-python-0.82.3.ebuild51
-rw-r--r--dev-python/dbus-python/files/digest-dbus-python-0.82.33
3 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 4c995b0b4d9a..8dfa885d492e 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.29 2007/09/07 15:44:20 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.30 2007/12/08 03:55:44 cardoe Exp $
+
+*dbus-python-0.82.3 (08 Dec 2007)
+
+ 08 Dec 2007; Doug Klima <cardoe@gentoo.org> +dbus-python-0.82.3.ebuild:
+ upstream version bump
07 Sep 2007; Doug Goldstein <cardoe@gentoo.org> dbus-python-0.82.2.ebuild:
bug #191590. Appears this is an issue with the old python-config. -r5 and
diff --git a/dev-python/dbus-python/dbus-python-0.82.3.ebuild b/dev-python/dbus-python/dbus-python-0.82.3.ebuild
new file mode 100644
index 000000000000..977c94519967
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-0.82.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.82.3.ebuild,v 1.1 2007/12/08 03:55:44 cardoe Exp $
+
+inherit python multilib
+
+DESCRIPTION="Python bindings for the D-Bus messagebus."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
+http://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-lang/python-2.4.4-r5
+ >=dev-python/pyrex-0.9.3-r2
+ >=dev-libs/dbus-glib-0.71
+ >=sys-apps/dbus-0.91"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pygobject )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # don't run py-compile
+ sed -i \
+ -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
+ dbus/Makefile.in Makefile.in || die "sed in Makefile.in failed"
+}
+
+src_compile() {
+ econf --docdir=/usr/share/doc/dbus-python-${PV} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/$(get_libdir)/python*/site-packages/dbus
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/dev-python/dbus-python/files/digest-dbus-python-0.82.3 b/dev-python/dbus-python/files/digest-dbus-python-0.82.3
new file mode 100644
index 000000000000..67f9987deff1
--- /dev/null
+++ b/dev-python/dbus-python/files/digest-dbus-python-0.82.3
@@ -0,0 +1,3 @@
+MD5 6b7626979b63994613a533a2d244c48c dbus-python-0.82.3.tar.gz 488123
+RMD160 b6f068332a7901d5985f929ee6fac808858355c0 dbus-python-0.82.3.tar.gz 488123
+SHA256 607506773db39b99671535f3bab1ac7f3d4992a9e18017fb7f11fba473e4be03 dbus-python-0.82.3.tar.gz 488123