summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-15 08:26:39 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-15 08:26:39 +0000
commit92d1eff51f5dfc055b11c6c88271ee858a9d8115 (patch)
treebae267142a7c9fae56b3668231d2b112e412a205 /dev-python/flask-peewee/flask-peewee-0.6.6.ebuild
parentRemove old. (diff)
downloadgentoo-2-92d1eff51f5dfc055b11c6c88271ee858a9d8115.tar.gz
gentoo-2-92d1eff51f5dfc055b11c6c88271ee858a9d8115.tar.bz2
gentoo-2-92d1eff51f5dfc055b11c6c88271ee858a9d8115.zip
bump; add doc build and option to install examples
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-peewee/flask-peewee-0.6.6.ebuild')
-rw-r--r--dev-python/flask-peewee/flask-peewee-0.6.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/flask-peewee/flask-peewee-0.6.6.ebuild b/dev-python/flask-peewee/flask-peewee-0.6.6.ebuild
new file mode 100644
index 000000000000..eecf8214db00
--- /dev/null
+++ b/dev-python/flask-peewee/flask-peewee-0.6.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-peewee/flask-peewee-0.6.6.ebuild,v 1.1 2015/06/15 08:26:39 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Flask integration layer for the Peewee ORM"
+HOMEPAGE="https://pypi.python.org/pypi/Flask-Admin"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+ dev-python/wtf-peewee[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+
+ distutils-r1_python_install_all
+}