summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-17 21:43:59 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-17 21:43:59 +0000
commit650df9122105df36f9f10a0ae9e03dc9ed3a9ec1 (patch)
tree76bbdbe94cd868a1369cf3c20b44cf52addfcf51 /dev-python/scientificpython
parentadd kernel version check, bug #305595 (diff)
downloadgentoo-2-650df9122105df36f9f10a0ae9e03dc9ed3a9ec1.tar.gz
gentoo-2-650df9122105df36f9f10a0ae9e03dc9ed3a9ec1.tar.bz2
gentoo-2-650df9122105df36f9f10a0ae9e03dc9ed3a9ec1.zip
PREFIX ready, and keyworded for ~amd64-linux ~x86-linux
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/scientificpython')
-rw-r--r--dev-python/scientificpython/ChangeLog8
-rw-r--r--dev-python/scientificpython/scientificpython-2.9-r1.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-python/scientificpython/ChangeLog b/dev-python/scientificpython/ChangeLog
index 9207ffbf44d0..b1507f9efda0 100644
--- a/dev-python/scientificpython/ChangeLog
+++ b/dev-python/scientificpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/scientificpython
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/ChangeLog,v 1.29 2010/02/02 17:02:19 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/ChangeLog,v 1.30 2010/02/17 21:43:59 jlec Exp $
+
+*scientificpython-2.9-r1 (17 Feb 2010)
+
+ 17 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +scientificpython-2.9-r1.ebuild:
+ PREFIX ready, and keyworded for ~amd64-linux ~x86-linux
02 Feb 2010; Sébastien Fabbro <bicatali@gentoo.org>
scientificpython-2.9.ebuild, +files/scientificpython-2.9-mpi-netcdf.patch:
diff --git a/dev-python/scientificpython/scientificpython-2.9-r1.ebuild b/dev-python/scientificpython/scientificpython-2.9-r1.ebuild
new file mode 100644
index 000000000000..8b525c74d8e1
--- /dev/null
+++ b/dev-python/scientificpython/scientificpython-2.9-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/scientificpython-2.9-r1.ebuild,v 1.1 2010/02/17 21:43:59 jlec Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+MY_PN="ScientificPython"
+DV="2372" # hardcoded download version
+
+DESCRIPTION="Scientific Module for Python"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DV}/${MY_PN}-${PV}.tar.gz"
+HOMEPAGE="http://sourcesup.cru.fr/projects/scientific-py/"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc mpi test"
+
+RDEPEND="dev-python/numpy
+ || ( =sci-libs/netcdf-3.6* >=sci-libs/netcdf-4[mpi=] )
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_PN}-${PV}.0"
+
+PYTHON_MODNAME="Scientific"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-mpi.patch"
+ use mpi && epatch "${FILESDIR}/${P}-mpi-netcdf.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use mpi; then
+ cd Src/MPI
+ building_of_mpipython() {
+ PYTHONPATH="$(ls -d ../../build-${PYTHON_ABI}/lib*)" "$(PYTHON)" compile.py
+ mv -f mpipython mpipython-${PYTHON_ABI}
+ }
+ python_execute_function --action-message 'Building of mpipython with Python ${PYTHON_ABI}...' --failure-message 'Building of mpipython failed with Python ${PYTHON_ABI}' building_of_mpipython
+ fi
+}
+
+src_test() {
+ cd Tests
+ testing() {
+ PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ # do not install bsp related stuff, since we don't compile the interface
+ dodoc README README.MPI Doc/CHANGELOG || die "dodoc failed"
+ insinto /usr/share/doc/${PF}
+ doins Examples/{demomodule.c,netcdf_demo.py} || die "doins examples failed"
+
+ if use mpi; then
+ installation_of_mpipython() {
+ dobin Src/MPI/mpipython-${PYTHON_ABI}
+ }
+ python_execute_function -q installation_of_mpipython
+ python_generate_wrapper_scripts "${ED}usr/bin/mpipython"
+ doins Examples/mpi.py || die "doins mpi example failed failed"
+ fi
+
+ if use doc; then
+ dohtml Doc/Reference/* || die "dohtml failed"
+ fi
+}