summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-11-20 15:49:59 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-11-20 15:49:59 +0000
commitd5953935c5cab6aa98a6d6c1d72aa87a82c2d92b (patch)
tree11bee8aa42c752aa5e3b7a7f01883682fe4d2971 /dev-python/sympy
parentbug fix release from upstream. adds GtkStatusIcon support (diff)
downloadgentoo-2-d5953935c5cab6aa98a6d6c1d72aa87a82c2d92b.tar.gz
gentoo-2-d5953935c5cab6aa98a6d6c1d72aa87a82c2d92b.tar.bz2
gentoo-2-d5953935c5cab6aa98a6d6c1d72aa87a82c2d92b.zip
Version bump, should now work with python-2.6
(Portage version: 2.2_rc14/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/ChangeLog8
-rw-r--r--dev-python/sympy/files/sympy-0.6.3-sphinx.patch43
-rw-r--r--dev-python/sympy/sympy-0.6.3.ebuild72
3 files changed, 122 insertions, 1 deletions
diff --git a/dev-python/sympy/ChangeLog b/dev-python/sympy/ChangeLog
index aa688b56155d..f18a84a78e61 100644
--- a/dev-python/sympy/ChangeLog
+++ b/dev-python/sympy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sympy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sympy/ChangeLog,v 1.2 2008/10/25 13:20:22 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sympy/ChangeLog,v 1.3 2008/11/20 15:49:59 grozin Exp $
+
+*sympy-0.6.3 (20 Nov 2008)
+
+ 20 Nov 2008; Andrey Grozin <grozin@gentoo.org>
+ +files/sympy-0.6.3-sphinx.patch, +sympy-0.6.3.ebuild:
+ Version bump, should now work with python-2.6
*sympy-0.6.2 (02 Sep 2008)
diff --git a/dev-python/sympy/files/sympy-0.6.3-sphinx.patch b/dev-python/sympy/files/sympy-0.6.3-sphinx.patch
new file mode 100644
index 000000000000..96cc926b0c95
--- /dev/null
+++ b/dev-python/sympy/files/sympy-0.6.3-sphinx.patch
@@ -0,0 +1,43 @@
+diff -r -U2 sympy-0.6.3.orig/doc/Makefile sympy-0.6.3/doc/Makefile
+--- sympy-0.6.3.orig/doc/Makefile 2008-11-20 03:12:13.000000000 +0600
++++ sympy-0.6.3/doc/Makefile 2008-11-21 00:42:13.000000000 +0600
+@@ -1,11 +1,8 @@
+ # Makefile for Sphinx documentation
+ #
+-RST2HTML = rst2html
++RST2HTML = rst2html.py
+
+ # You can set these variables from the command line.
+ SPHINXOPTS =
+-SPHINXVER = 0.4.3
+-SPHINXBUILDpy = sphinx/Sphinx-$(SPHINXVER)/sphinx-build.py
+-SPHINXBUILD = PYTHONPATH=.. python $(SPHINXBUILDpy)
+ PAPER =
+
+@@ -31,11 +28,5 @@
+ -rm -rf sphinx
+
+-$(SPHINXBUILDpy):
+- rm -rf sphinx
+- mkdir sphinx
+- cd sphinx; wget http://pypi.python.org/packages/source/S/Sphinx/Sphinx-$(SPHINXVER).tar.gz;
+- cd sphinx; tar xzf Sphinx-$(SPHINXVER).tar.gz
+-
+-html: $(SPHINXBUILDpy) spt-printable
++html: spt-printable
+ mkdir -p src/.static
+ mkdir -p _build/html _build/doctrees
+@@ -52,5 +43,5 @@
+ $(RST2HTML) src/sympy-patches-tutorial.txt > _build/html/spt-printable.html
+
+-htmlapi: $(SPHINXBUILDpy)
++htmlapi:
+ mkdir -p api/.static
+ mkdir -p api/modules
+@@ -77,5 +68,5 @@
+ ".hhp project file in _build/htmlhelp."
+
+-latex: $(SPHINXBUILDpy)
++latex:
+ mkdir -p _build/latex _build/doctrees
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) _build/latex
diff --git a/dev-python/sympy/sympy-0.6.3.ebuild b/dev-python/sympy/sympy-0.6.3.ebuild
new file mode 100644
index 000000000000..29ed43cca92a
--- /dev/null
+++ b/dev-python/sympy/sympy-0.6.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sympy/sympy-0.6.3.ebuild,v 1.1 2008/11/20 15:49:59 grozin Exp $
+EAPI=2
+NEED_PYTHON=2.4
+inherit distutils
+
+DESCRIPTION="Computer algebra system (CAS) in Python"
+HOMEPAGE="http://code.google.com/p/sympy/"
+SRC_URI="http://sympy.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png test texmacs"
+
+RDEPEND="mathml? ( dev-libs/libxml2[python]
+ dev-libs/libxslt[python]
+ gtk? ( x11-libs/gtkmathview[gtk] ) )
+ latex? ( virtual/latex-base
+ png? ( app-text/dvipng )
+ pdf? ( virtual/ghostscript ) )
+ texmacs? ( app-office/texmacs )
+ ipython? ( dev-python/ipython )
+ opengl? ( dev-python/pyopengl )
+ imaging? ( dev-python/imaging )
+ || ( dev-python/ctypes >=dev-lang/python-2.5 )
+ >=dev-python/pexpect-2.0"
+DEPEND="doc? ( dev-python/sphinx )
+ test? ( >=dev-python/py-0.9.0 )"
+
+src_unpack() {
+ distutils_src_unpack
+
+ # use local sphinx
+ epatch "${FILESDIR}"/${P}-sphinx.patch
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd doc
+ PYTHONPATH=.. emake SPHINXBUILD=sphinx-build html \
+ || die "emake html failed"
+ cd ..
+ fi
+}
+
+src_test() {
+ PYTHONPATH=build/lib/ "${python}" setup.py test || die "Unit tests failed!"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r doc/_build/html/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples
+ fi
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}