summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-03-25 16:41:11 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-03-25 16:41:11 +0000
commitf61ef1d0a264a64e5d9f3495fb05633e142c6d32 (patch)
treeee0876c47c12952c363b6f1b2e99055060acd535 /dev-python/urllib3
parentStable for x86, wrt bug #458984 (diff)
downloadgentoo-2-f61ef1d0a264a64e5d9f3495fb05633e142c6d32.tar.gz
gentoo-2-f61ef1d0a264a64e5d9f3495fb05633e142c6d32.tar.bz2
gentoo-2-f61ef1d0a264a64e5d9f3495fb05633e142c6d32.zip
updating urllib3 to support distutils-r1
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/ChangeLog7
-rw-r--r--dev-python/urllib3/urllib3-1.5-r1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/urllib3/ChangeLog b/dev-python/urllib3/ChangeLog
index 9e690bb6b922..92f221a2ee1d 100644
--- a/dev-python/urllib3/ChangeLog
+++ b/dev-python/urllib3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/urllib3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urllib3/ChangeLog,v 1.4 2013/03/19 10:25:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urllib3/ChangeLog,v 1.5 2013/03/25 16:41:11 prometheanfire Exp $
+
+*urllib3-1.5-r1 (25 Mar 2013)
+
+ 25 Mar 2013; Matthew Thode <prometheanfire@gentoo.org> +urllib3-1.5-r1.ebuild:
+ updating urllib3 to support distutils-r1
19 Mar 2013; Patrick Lauer <patrick@gentoo.org> urllib3-1.5.ebuild:
Restrict tests for 3.2 too as tornado is missing there
diff --git a/dev-python/urllib3/urllib3-1.5-r1.ebuild b/dev-python/urllib3/urllib3-1.5-r1.ebuild
new file mode 100644
index 000000000000..913b8d0ddb06
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urllib3/urllib3-1.5-r1.ebuild,v 1.1 2013/03/25 16:41:11 prometheanfire Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="https://github.com/shazow/urllib3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( www-servers/tornado[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ # Replace bundled copy of dev-python/six
+ cat > urllib3/packages/six.py <<-EOF
+ from __future__ import absolute_import
+ from six import *
+ EOF
+
+ sed -i -e "s/'dummyserver',//" setup.py || die
+
+ distutils-r1_python_prepare
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}