summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-05-28 15:20:44 +0000
committerMike Gilbert <floppym@gentoo.org>2014-05-28 15:20:44 +0000
commit7b86637dcc9bd07e94fa10552398a5a5944adcc8 (patch)
treeeecb7e9589caf1ee9d3b84f9e0be6cbb1f919a3b /dev-python
parentVersion bump timezone-data to 2014d (fixes bug 510422) (diff)
downloadgentoo-2-7b86637dcc9bd07e94fa10552398a5a5944adcc8.tar.gz
gentoo-2-7b86637dcc9bd07e94fa10552398a5a5944adcc8.tar.bz2
gentoo-2-7b86637dcc9bd07e94fa10552398a5a5944adcc8.zip
Override faulty curl ssl detection in setup.py, bug 510974 by Hanspeter Spalinger.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycurl/ChangeLog7
-rw-r--r--dev-python/pycurl/pycurl-7.19.0-r3.ebuild9
-rw-r--r--dev-python/pycurl/pycurl-7.19.3.1.ebuild7
3 files changed, 19 insertions, 4 deletions
diff --git a/dev-python/pycurl/ChangeLog b/dev-python/pycurl/ChangeLog
index ea9bfbf3dced..6b89b1df8ed1 100644
--- a/dev-python/pycurl/ChangeLog
+++ b/dev-python/pycurl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycurl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/ChangeLog,v 1.93 2014/05/17 14:47:05 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/ChangeLog,v 1.94 2014/05/28 15:20:44 floppym Exp $
+
+ 28 May 2014; Mike Gilbert <floppym@gentoo.org> pycurl-7.19.0-r3.ebuild,
+ pycurl-7.19.3.1.ebuild:
+ Override faulty curl ssl detection in setup.py, bug 510974 by Hanspeter
+ Spalinger.
17 May 2014; Ian Delaney <idella4@gentoo.org> pycurl-7.19.3.1.ebuild:
restrict test due to extensive keyword deficits in new test deps
diff --git a/dev-python/pycurl/pycurl-7.19.0-r3.ebuild b/dev-python/pycurl/pycurl-7.19.0-r3.ebuild
index bf77c43c598f..3fa44060b78c 100644
--- a/dev-python/pycurl/pycurl-7.19.0-r3.ebuild
+++ b/dev-python/pycurl/pycurl-7.19.0-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/pycurl-7.19.0-r3.ebuild,v 1.12 2013/09/14 22:50:10 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/pycurl-7.19.0-r3.ebuild,v 1.13 2014/05/28 15:20:44 floppym Exp $
EAPI=5
@@ -42,6 +42,11 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+src_configure() {
+ # Override faulty detection in setup.py, bug 510974.
+ export PYCURL_SSL_LIBRARY=${CURL_SSL}
+}
+
python_compile() {
python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile
diff --git a/dev-python/pycurl/pycurl-7.19.3.1.ebuild b/dev-python/pycurl/pycurl-7.19.3.1.ebuild
index 69a43ec824ca..4dc0ceed7355 100644
--- a/dev-python/pycurl/pycurl-7.19.3.1.ebuild
+++ b/dev-python/pycurl/pycurl-7.19.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/pycurl-7.19.3.1.ebuild,v 1.2 2014/05/17 14:47:05 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/pycurl-7.19.3.1.ebuild,v 1.3 2014/05/28 15:20:44 floppym Exp $
EAPI=5
@@ -38,6 +38,11 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+src_configure() {
+ # Override faulty detection in setup.py, bug 510974.
+ export PYCURL_SSL_LIBRARY=${CURL_SSL}
+}
+
python_compile() {
python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile