summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-31 16:17:54 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-31 16:17:54 +0000
commit847ff50792c1307a0d777f4096ae13569e47f5a5 (patch)
tree1e199433d9499b406871b3837b747d2df4f86078 /dev-python
parentfix bug #208309 (diff)
downloadgentoo-2-847ff50792c1307a0d777f4096ae13569e47f5a5.tar.gz
gentoo-2-847ff50792c1307a0d777f4096ae13569e47f5a5.tar.bz2
gentoo-2-847ff50792c1307a0d777f4096ae13569e47f5a5.zip
bye bye broken version
(Portage version: 2.1.4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gst-python/files/gst-python-0.10.8-atexit.patch12
-rw-r--r--dev-python/gst-python/gst-python-0.10.8-r1.ebuild60
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/gst-python/files/gst-python-0.10.8-atexit.patch b/dev-python/gst-python/files/gst-python-0.10.8-atexit.patch
deleted file mode 100644
index 46141f6938aa..000000000000
--- a/dev-python/gst-python/files/gst-python-0.10.8-atexit.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur gst-python-0.10.8.orig/gst/gstmodule.c gst-python-0.10.8/gst/gstmodule.c
---- gst-python-0.10.8.orig/gst/gstmodule.c 2007-07-28 16:38:15.000000000 +0300
-+++ gst-python-0.10.8/gst/gstmodule.c 2007-11-04 08:26:33.000000000 +0200
-@@ -266,8 +266,6 @@
-
- g_timeout_add_full (0, 100, python_do_pending_calls, NULL, NULL);
-
-- atexit(gst_deinit);
--
- if (PyErr_Occurred ()) {
- Py_FatalError ("can't initialize module gst");
- }
diff --git a/dev-python/gst-python/gst-python-0.10.8-r1.ebuild b/dev-python/gst-python/gst-python-0.10.8-r1.ebuild
deleted file mode 100644
index 2e16d4476ae8..000000000000
--- a/dev-python/gst-python/gst-python-0.10.8-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.8-r1.ebuild,v 1.3 2007/11/25 00:28:15 mr_bones_ Exp $
-
-NEED_PYTHON=2.3
-
-inherit eutils flag-o-matic python
-
-DESCRIPTION="A Python Interface to GStreamer"
-HOMEPAGE="http://gstreamer.freedesktop.org"
-SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0.10"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc"
-
-# 0.10.8 is known to fail with current pygobject, please remove this
-# RESTRICT when bumping gst-python.
-RESTRICT="test"
-
-RDEPEND=">=dev-python/pygtk-2.6.3
- >=dev-libs/glib-2.8
- >=x11-libs/gtk+-2.6
- >=dev-python/pygobject-2.11.2
- >=media-libs/gstreamer-0.10.2
- >=media-libs/gst-plugins-base-0.10.0.2
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( app-text/xmlto )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Can be removed with next version, from upstream CVS.
- epatch "${FILESDIR}"/${P}-atexit.patch
-}
-
-src_compile() {
- append-ldflags -Wl,-z,lazy
- econf $(use_enable doc docs)
- emake || die "emake failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog NEWS README TODO
- docinto examples
- cp -pPR examples/* "${D}"/usr/share/doc/${PF}/examples
- prepalldocs
-}
-
-pkg_postinst() {
- python_mod_optimize
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}