summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-08 08:24:44 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-08 08:24:44 +0000
commit9a41e810f3be364b3dd6d412d071b040be6b7e14 (patch)
tree048579067b6a30d216268a4bf855aafff8061f64 /dev-python
parentversion bump (diff)
downloadgentoo-2-9a41e810f3be364b3dd6d412d071b040be6b7e14.tar.gz
gentoo-2-9a41e810f3be364b3dd6d412d071b040be6b7e14.tar.bz2
gentoo-2-9a41e810f3be364b3dd6d412d071b040be6b7e14.zip
bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cliff/ChangeLog8
-rw-r--r--dev-python/cliff/cliff-1.12.0.ebuild58
-rw-r--r--dev-python/cliff/cliff-1.6.1.ebuild37
3 files changed, 65 insertions, 38 deletions
diff --git a/dev-python/cliff/ChangeLog b/dev-python/cliff/ChangeLog
index 7e7717c564ad..157fd8bf508b 100644
--- a/dev-python/cliff/ChangeLog
+++ b/dev-python/cliff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cliff
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/ChangeLog,v 1.19 2015/06/07 11:07:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/ChangeLog,v 1.20 2015/06/08 08:24:44 idella4 Exp $
+
+*cliff-1.12.0 (08 Jun 2015)
+
+ 08 Jun 2015; Ian Delaney <idella4@gentoo.org> +cliff-1.12.0.ebuild,
+ -cliff-1.6.1.ebuild:
+ bump
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-python/cliff/cliff-1.12.0.ebuild b/dev-python/cliff/cliff-1.12.0.ebuild
new file mode 100644
index 000000000000..9254efc7526a
--- /dev/null
+++ b/dev-python/cliff/cliff-1.12.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.12.0.ebuild,v 1.1 2015/06/08 08:24:44 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/dreamhost/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}] )
+ doc? (
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}] )
+ "
+# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.3.0[${PYTHON_USEDEP}]
+ "
+
+python_compile() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/cliff/cliff-1.6.1.ebuild b/dev-python/cliff/cliff-1.6.1.ebuild
deleted file mode 100644
index 34f94d7339f9..000000000000
--- a/dev-python/cliff/cliff-1.6.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.6.1.ebuild,v 1.2 2015/04/08 08:04:52 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Command Line Interface Formulation Framework"
-HOMEPAGE="https://github.com/dreamhost/cliff"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=">=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-0.14[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
- !~dev-python/pbr-0.7[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- nosetests tests || die "Tests fail with ${EPYTHON}"
-}