summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-02 08:36:17 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-02 08:36:17 +0000
commite4b8c1a6390d0753a621c6c2cbf3a6468babf8a1 (patch)
tree9a3ee287f4e8439d94f21360b25908e7c362cac0 /dev-ruby/async_sinatra
parentAdded new snapshot which fixes bug 345801 (diff)
downloadgentoo-2-e4b8c1a6390d0753a621c6c2cbf3a6468babf8a1.tar.gz
gentoo-2-e4b8c1a6390d0753a621c6c2cbf3a6468babf8a1.tar.bz2
gentoo-2-e4b8c1a6390d0753a621c6c2cbf3a6468babf8a1.zip
Version bump. Run new test suite.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/async_sinatra')
-rw-r--r--dev-ruby/async_sinatra/ChangeLog10
-rw-r--r--dev-ruby/async_sinatra/async_sinatra-0.3.0.ebuild43
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-ruby/async_sinatra/ChangeLog b/dev-ruby/async_sinatra/ChangeLog
index 47044ce3e5d6..34a2468fa5a6 100644
--- a/dev-ruby/async_sinatra/ChangeLog
+++ b/dev-ruby/async_sinatra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/async_sinatra
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/async_sinatra/ChangeLog,v 1.2 2010/04/19 18:10:10 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/async_sinatra/ChangeLog,v 1.3 2011/01/02 08:36:17 graaff Exp $
+
+*async_sinatra-0.3.0 (02 Jan 2011)
+
+ 02 Jan 2011; Hans de Graaff <graaff@gentoo.org>
+ +async_sinatra-0.3.0.ebuild:
+ Version bump. Run new test suite.
19 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org>
async_sinatra-0.1.5.ebuild:
diff --git a/dev-ruby/async_sinatra/async_sinatra-0.3.0.ebuild b/dev-ruby/async_sinatra/async_sinatra-0.3.0.ebuild
new file mode 100644
index 000000000000..bcb2048e2372
--- /dev/null
+++ b/dev-ruby/async_sinatra/async_sinatra-0.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/async_sinatra/async_sinatra-0.3.0.ebuild,v 1.1 2011/01/02 08:36:17 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+# the documentation-building requires the gemspec file that is not
+# packaged, this is very unfortunate for us, but the doc does not
+# really tell us much so we're not going out of our way to get this
+# from GIT. Upstream bug filed.
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Asynchronous response API for Sinatra and Thin"
+HOMEPAGE="http://libraggi.rubyforge.org/async_sinatra"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/eventmachine )"
+
+ruby_add_rdepend '>=dev-ruby/sinatra-1.0
+ >=www-servers/thin-1.2.0'
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_async.rb || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}