summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-18 07:13:52 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-18 07:13:52 +0000
commitb09d185c8eb6c5c86b6d3b28382b02207bfae806 (patch)
treebf0d7b7cbd8bc0f00abf060a58eba3819eba61f8 /dev-ruby/childprocess
parentVersion bump. (diff)
downloadgentoo-2-b09d185c8eb6c5c86b6d3b28382b02207bfae806.tar.gz
gentoo-2-b09d185c8eb6c5c86b6d3b28382b02207bfae806.tar.bz2
gentoo-2-b09d185c8eb6c5c86b6d3b28382b02207bfae806.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/childprocess')
-rw-r--r--dev-ruby/childprocess/ChangeLog7
-rw-r--r--dev-ruby/childprocess/childprocess-0.3.6.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/childprocess/ChangeLog b/dev-ruby/childprocess/ChangeLog
index 4bf08ae4a895..4636aa228f6f 100644
--- a/dev-ruby/childprocess/ChangeLog
+++ b/dev-ruby/childprocess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/childprocess
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childprocess/ChangeLog,v 1.23 2012/08/19 10:21:24 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childprocess/ChangeLog,v 1.24 2012/10/18 07:13:52 graaff Exp $
+
+*childprocess-0.3.6 (18 Oct 2012)
+
+ 18 Oct 2012; Hans de Graaff <graaff@gentoo.org> +childprocess-0.3.6.ebuild:
+ Version bump.
19 Aug 2012; Anthony G. Basile <blueness@gentoo.org>
childprocess-0.3.5.ebuild:
diff --git a/dev-ruby/childprocess/childprocess-0.3.6.ebuild b/dev-ruby/childprocess/childprocess-0.3.6.ebuild
new file mode 100644
index 000000000000..220b0e3e9f60
--- /dev/null
+++ b/dev-ruby/childprocess/childprocess-0.3.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childprocess/childprocess-0.3.6.ebuild,v 1.1 2012/10/18 07:13:52 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple and reliable solution for controlling external programs running in the background."
+HOMEPAGE="https://github.com/jarib/childprocess"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:2 )"
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}