summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-06 06:29:39 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-06 06:29:39 +0000
commitd72e2fd55ec71feeb143ab6d1a7f92c8ade867ff (patch)
treec18662c0c84e6189752b85f7ebbc288c6b658cd5 /dev-ruby/cocaine
parentCleanup. (diff)
downloadgentoo-2-d72e2fd55ec71feeb143ab6d1a7f92c8ade867ff.tar.gz
gentoo-2-d72e2fd55ec71feeb143ab6d1a7f92c8ade867ff.tar.bz2
gentoo-2-d72e2fd55ec71feeb143ab6d1a7f92c8ade867ff.zip
Version bump. Drop ree18 since it no longer passes the tests and will be removed shortly anyway.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/cocaine')
-rw-r--r--dev-ruby/cocaine/ChangeLog9
-rw-r--r--dev-ruby/cocaine/cocaine-0.2.1.ebuild3
-rw-r--r--dev-ruby/cocaine/cocaine-0.4.0.ebuild40
3 files changed, 50 insertions, 2 deletions
diff --git a/dev-ruby/cocaine/ChangeLog b/dev-ruby/cocaine/ChangeLog
index 9bdf1c471a46..6503040cef5f 100644
--- a/dev-ruby/cocaine/ChangeLog
+++ b/dev-ruby/cocaine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/cocaine
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/cocaine/ChangeLog,v 1.2 2012/08/14 03:18:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/cocaine/ChangeLog,v 1.3 2012/10/06 06:29:39 graaff Exp $
+
+*cocaine-0.4.0 (06 Oct 2012)
+
+ 06 Oct 2012; Hans de Graaff <graaff@gentoo.org> cocaine-0.2.1.ebuild,
+ +cocaine-0.4.0.ebuild:
+ Version bump. Drop ree18 since it no longer passes the tests and will be
+ removed shortly anyway.
14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> cocaine-0.2.1.ebuild:
Port to rspec helper for testing.
diff --git a/dev-ruby/cocaine/cocaine-0.2.1.ebuild b/dev-ruby/cocaine/cocaine-0.2.1.ebuild
index 614883837ec6..4d09138a42b0 100644
--- a/dev-ruby/cocaine/cocaine-0.2.1.ebuild
+++ b/dev-ruby/cocaine/cocaine-0.2.1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/cocaine/cocaine-0.2.1.ebuild,v 1.2 2012/08/14 03:18:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/cocaine/cocaine-0.2.1.ebuild,v 1.3 2012/10/06 06:29:39 graaff Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 ree18 jruby"
+RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
diff --git a/dev-ruby/cocaine/cocaine-0.4.0.ebuild b/dev-ruby/cocaine/cocaine-0.4.0.ebuild
new file mode 100644
index 000000000000..a7b8e9f0db29
--- /dev/null
+++ b/dev-ruby/cocaine/cocaine-0.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/cocaine/cocaine-0.4.0.ebuild,v 1.1 2012/10/06 06:29:39 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small library for doing command lines"
+HOMEPAGE="http://www.thoughtbot.com/projects/cocaine"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bourne
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ -e '/dependency.*mocha/s:= 0.10.4:~> 0.10.3:' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ rm Gemfile* || die
+
+ sed -i -e '/bundler/d' Rakefile || die
+}