summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-21 06:51:32 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-21 06:51:32 +0000
commitce0f661daaa24c1065e585eb4803dc03a6f8adc9 (patch)
tree5bbe91bfba07b97a2b1614c7a5032cef30a2be6c /dev-ruby/rack
parentdrop IUSE mysql and dep dev-python/mysql-python in RDEPEND, substitute with m... (diff)
downloadgentoo-2-ce0f661daaa24c1065e585eb4803dc03a6f8adc9.tar.gz
gentoo-2-ce0f661daaa24c1065e585eb4803dc03a6f8adc9.tar.bz2
gentoo-2-ce0f661daaa24c1065e585eb4803dc03a6f8adc9.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rack')
-rw-r--r--dev-ruby/rack/ChangeLog9
-rw-r--r--dev-ruby/rack/rack-1.5.2-r4.ebuild42
-rw-r--r--dev-ruby/rack/rack-1.6.0.ebuild40
3 files changed, 90 insertions, 1 deletions
diff --git a/dev-ruby/rack/ChangeLog b/dev-ruby/rack/ChangeLog
index 527b008b94f5..27ef91a9e9d1 100644
--- a/dev-ruby/rack/ChangeLog
+++ b/dev-ruby/rack/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.137 2014/11/12 17:01:27 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.138 2014/12/21 06:51:32 graaff Exp $
+
+*rack-1.6.0 (21 Dec 2014)
+*rack-1.5.2-r4 (21 Dec 2014)
+
+ 21 Dec 2014; Hans de Graaff <graaff@gentoo.org> +rack-1.5.2-r4.ebuild,
+ +rack-1.6.0.ebuild:
+ Version bump.
12 Nov 2014; Manuel Rüger <mrueg@gentoo.org> -rack-1.4.5.ebuild:
Cleanup old.
diff --git a/dev-ruby/rack/rack-1.5.2-r4.ebuild b/dev-ruby/rack/rack-1.5.2-r4.ebuild
new file mode 100644
index 000000000000..f0d6b1d21bbb
--- /dev/null
+++ b/dev-ruby/rack/rack-1.5.2-r4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.5.2-r4.ebuild,v 1.1 2014/12/21 06:51:32 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="KNOWN-ISSUES README.rdoc SPEC"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rack.github.com/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4"
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.6.0.ebuild b/dev-ruby/rack/rack-1.6.0.ebuild
new file mode 100644
index 000000000000..a0033091f6be
--- /dev/null
+++ b/dev-ruby/rack/rack-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.6.0.ebuild,v 1.1 2014/12/21 06:51:32 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="KNOWN-ISSUES README.rdoc SPEC"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rack.github.com/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4 !<dev-ruby/rack-1.5.2-r4"
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}