summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-23 19:27:04 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-23 19:27:04 +0000
commite923f6cb5529887e9b926d782985f54f25ddc24c (patch)
tree54705347fbf782b57716e9df228d4857e5f6a2ca /dev-ruby/tmail
parentFix duplicate ChangeLog entry (diff)
downloadgentoo-2-e923f6cb5529887e9b926d782985f54f25ddc24c.tar.gz
gentoo-2-e923f6cb5529887e9b926d782985f54f25ddc24c.tar.bz2
gentoo-2-e923f6cb5529887e9b926d782985f54f25ddc24c.zip
Version bump for the forthcoming Rails 2.3.6 release.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/tmail')
-rw-r--r--dev-ruby/tmail/ChangeLog7
-rw-r--r--dev-ruby/tmail/tmail-1.2.7.1.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-ruby/tmail/ChangeLog b/dev-ruby/tmail/ChangeLog
index f9092c777528..d516b6a225a8 100644
--- a/dev-ruby/tmail/ChangeLog
+++ b/dev-ruby/tmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tmail
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/ChangeLog,v 1.11 2010/05/22 22:40:08 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/ChangeLog,v 1.12 2010/05/23 19:27:04 graaff Exp $
+
+*tmail-1.2.7.1 (23 May 2010)
+
+ 23 May 2010; Hans de Graaff <graaff@gentoo.org> +tmail-1.2.7.1.ebuild:
+ Version bump for the forthcoming Rails 2.3.6 release.
22 May 2010; Alex Legler <a3li@gentoo.org> tmail-1.2.3.1.ebuild:
Add REE18 support
diff --git a/dev-ruby/tmail/tmail-1.2.7.1.ebuild b/dev-ruby/tmail/tmail-1.2.7.1.ebuild
new file mode 100644
index 000000000000..aeeda203c386
--- /dev/null
+++ b/dev-ruby/tmail/tmail-1.2.7.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/tmail-1.2.7.1.ebuild,v 1.1 2010/05/23 19:27:04 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README CHANGES NOTES"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An email handling library"
+HOMEPAGE="http://rubyforge.org/projects/tmail/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+# Tests seem to be broken with the new encoding handling from Ruby,
+# need to be verified twice; code seems to work anyway.
+RESTRICT=test
+
+ruby_add_bdepend "
+ dev-ruby/racc
+ test? ( >=dev-ruby/mocha-0.9.5 )"
+
+all_ruby_prepare() {
+ # Provide file that is no longer distributed but still needed
+ mkdir meta || die "Failed to mkdir meta."
+ echo "tmail" > meta/unixname || die "Failed to create unixname file."
+}
+
+each_ruby_compile() {
+ if [[ $(basename ${RUBY}) == "ruby18" ]]; then
+ pushd ext/tmailscanner/tmail
+ ${RUBY} extconf.rb || die "extconf failed"
+ emake || die "emake extension failed"
+ popd
+ fi
+
+ emake -C lib/tmail $(use debug && echo DEBUG=true) parser.rb || die "emake failed"
+}
+
+each_ruby_install() {
+ # We cannot use the recursive install because there are
+ # racc source files and a makefile.
+ find lib -name '*.rb' | while read file; do
+ ruby_fakegem_newins $file $file
+ done
+
+ if [[ $(basename ${RUBY}) == "ruby18" ]]; then
+ ruby_fakegem_newins ext/tmailscanner/tmail/tmailscanner.so lib/tmail/tmailscanner.so
+ fi
+
+ ruby_fakegem_genspec
+}