summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-07-26 17:31:29 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-07-26 17:31:29 +0000
commit34caa3a7a8d3f204f9bc6e8dfe9558495965a2a2 (patch)
treeb62095ac7fc1fa686f41397e0e3b0bd1535cc90a /dev-util/cvsd
parentNew package; thanks to Enrico Morelli. (diff)
downloadgentoo-2-34caa3a7a8d3f204f9bc6e8dfe9558495965a2a2.tar.gz
gentoo-2-34caa3a7a8d3f204f9bc6e8dfe9558495965a2a2.tar.bz2
gentoo-2-34caa3a7a8d3f204f9bc6e8dfe9558495965a2a2.zip
New package; thanks to Enrico Morelli.
Diffstat (limited to 'dev-util/cvsd')
-rw-r--r--dev-util/cvsd/ChangeLog10
-rw-r--r--dev-util/cvsd/Manifest1
-rw-r--r--dev-util/cvsd/cvsd-0.9.19.ebuild43
-rw-r--r--dev-util/cvsd/files/cvsd.confd3
-rw-r--r--dev-util/cvsd/files/cvsd.init19
-rw-r--r--dev-util/cvsd/files/digest-cvsd-0.9.191
6 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/cvsd/ChangeLog b/dev-util/cvsd/ChangeLog
new file mode 100644
index 000000000000..dc31cca47a94
--- /dev/null
+++ b/dev-util/cvsd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/cvsd
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsd/ChangeLog,v 1.1 2003/07/26 17:31:24 g2boojum Exp $
+
+*cvsd-0.9.19 (26 Jul 2003)
+
+ 26 Jul 2003; Grant Goodyear <g2boojum@gentoo.org> cvsd-0.9.19.ebuild,
+ files/cvsd.confd, files/cvsd.init:
+ New package, long overdue, with many thanks to Enrico Morelli (Bug 18380).
+
diff --git a/dev-util/cvsd/Manifest b/dev-util/cvsd/Manifest
index b423f9a84b51..0f86b470d00b 100644
--- a/dev-util/cvsd/Manifest
+++ b/dev-util/cvsd/Manifest
@@ -1,4 +1,5 @@
MD5 ac6d1a655630c0a650a38459f113c381 cvsd-0.9.19.ebuild 924
+MD5 f32f1b912ae4b45d6351aa88501fc2ac ChangeLog 425
MD5 76bd46dc82e0c2b97b48ae751a44e3da files/cvsd.init 400
MD5 2e49d8f8e06ad4113a3d0f1906110aa0 files/digest-cvsd-0.9.19 63
MD5 e9233228e6757b330d72e677b1fdae41 files/cvsd.confd 71
diff --git a/dev-util/cvsd/cvsd-0.9.19.ebuild b/dev-util/cvsd/cvsd-0.9.19.ebuild
new file mode 100644
index 000000000000..b8d7ac0a1cad
--- /dev/null
+++ b/dev-util/cvsd/cvsd-0.9.19.ebuild
@@ -0,0 +1,43 @@
+S=${WORKDIR}/${P}
+DESCRIPTION="CVS pserver daemon"
+SRC_URI="http://tiefighter.et.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
+HOMEPAGE="http://tiefighter.et.tudelft.nl/~arthur/cvsd/"
+DEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use tcpd && myconf="${myconf} --with-libwrap"
+
+ econf --prefix=/usr ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ exeinto /usr/sbin
+ doexe cvsd cvsd-buildroot cvsd-passwd
+ insinto /etc/cvsd
+ mv cvsd.conf-dist cvsd.conf
+ doins cvsd.conf
+
+ dodoc COPYING* ChangeLog* FAQ
+ dodoc NEWS README* TODO
+
+ doman cvsd-buildroot.8 cvsd-passwd.8 cvsd.8 cvsd.conf.5
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/cvsd.init cvsd
+ insinto /etc/conf.d ; newins ${FILESDIR}/cvsd.confd cvsd
+
+}
+pkg_postinst() {
+ einfo
+ einfo "To configure cvsd please read /usr/share/cvsd-0.9.17/README.gz"
+ einfo
+}
+
diff --git a/dev-util/cvsd/files/cvsd.confd b/dev-util/cvsd/files/cvsd.confd
new file mode 100644
index 000000000000..c884f6e52420
--- /dev/null
+++ b/dev-util/cvsd/files/cvsd.confd
@@ -0,0 +1,3 @@
+# Config file for /etc/init.d/cvsd
+
+CVSD_OPTS="-f /etc/cvsd/cvsd.conf"
diff --git a/dev-util/cvsd/files/cvsd.init b/dev-util/cvsd/files/cvsd.init
new file mode 100644
index 000000000000..9d79b5d8ceae
--- /dev/null
+++ b/dev-util/cvsd/files/cvsd.init
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting cvsd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/cvsd -- ${CVSD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cvsd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/cvsd
+ eend $?
+}
diff --git a/dev-util/cvsd/files/digest-cvsd-0.9.19 b/dev-util/cvsd/files/digest-cvsd-0.9.19
new file mode 100644
index 000000000000..c155a1995095
--- /dev/null
+++ b/dev-util/cvsd/files/digest-cvsd-0.9.19
@@ -0,0 +1 @@
+MD5 2757c59517e59771bd9d249aea760b41 cvsd-0.9.19.tar.gz 165080