summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-03-12 02:19:23 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-03-12 02:19:23 +0000
commitf91d11009933053c80528354ba2e63957dc420b4 (patch)
treed299fb44a57b7f3667b1265641745e7beff41c39 /dev-util/fujaba/fujaba-4.0.1.ebuild
parentfix slotting to use KV vs OKV (Manifest recommit) (diff)
downloadgentoo-2-f91d11009933053c80528354ba2e63957dc420b4.tar.gz
gentoo-2-f91d11009933053c80528354ba2e63957dc420b4.tar.bz2
gentoo-2-f91d11009933053c80528354ba2e63957dc420b4.zip
Initial Import. Closes #38352
Diffstat (limited to 'dev-util/fujaba/fujaba-4.0.1.ebuild')
-rw-r--r--dev-util/fujaba/fujaba-4.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/fujaba/fujaba-4.0.1.ebuild b/dev-util/fujaba/fujaba-4.0.1.ebuild
new file mode 100644
index 000000000000..a55775412deb
--- /dev/null
+++ b/dev-util/fujaba/fujaba-4.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/fujaba/fujaba-4.0.1.ebuild,v 1.1 2004/03/12 02:19:23 zx Exp $
+
+MY_PV="${PV//./_}"
+MY_PNB="Fujaba_${PV:0:1}"
+
+DESCRIPTION="The Fujaba Tool Suite provides an easy to extend UML and Java development platform"
+HOMEPAGE="http://www.uni-paderborn.de/cs/fujaba/index.html"
+SRC_URI="ftp://ftp.uni-paderborn.de/private/fujaba/${MY_PNB}/FujabaToolSuite_Developer${MY_PV}.zip"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=">=virtual/jdk-1.4.1"
+
+S=${WORKDIR}
+
+src_compile() { :; }
+
+src_install() {
+ dodir /opt/${PN}
+ cp -a . ${D}/opt/${PN}
+ chmod -R 755 ${D}/opt/${PN}/
+
+ echo "#!/bin/sh" > ${PN}
+ echo "cd /opt/${PN}" >> ${PN}
+ echo '${JAVA_HOME}'/bin/java -jar ${PN}.jar '$*' >> ${PN}
+ into /opt
+ dobin ${PN}
+}