summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-09-11 14:05:57 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-09-11 14:05:57 +0000
commit0ea60686dff28ca8f7bc8ebb1fd8e916f2d66583 (patch)
tree7bfa10bdb90638b41371d027688bc50d00e62c6a /dev-util
parentAdd missing dependency on virtual/glu, bug 434434; remove old (diff)
downloadgentoo-2-0ea60686dff28ca8f7bc8ebb1fd8e916f2d66583.tar.gz
gentoo-2-0ea60686dff28ca8f7bc8ebb1fd8e916f2d66583.tar.bz2
gentoo-2-0ea60686dff28ca8f7bc8ebb1fd8e916f2d66583.zip
version bump
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/molecule/ChangeLog7
-rw-r--r--dev-util/molecule/molecule-0.9.24.6.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-util/molecule/ChangeLog b/dev-util/molecule/ChangeLog
index fb67796e1292..f62d9619cb53 100644
--- a/dev-util/molecule/ChangeLog
+++ b/dev-util/molecule/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/molecule
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.35 2012/09/10 12:43:28 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.36 2012/09/11 14:05:57 lxnay Exp $
+
+*molecule-0.9.24.6 (11 Sep 2012)
+
+ 11 Sep 2012; Fabio Erculiani <lxnay@gentoo.org> +molecule-0.9.24.6.ebuild:
+ version bump
*molecule-0.9.24.5 (10 Sep 2012)
diff --git a/dev-util/molecule/molecule-0.9.24.6.ebuild b/dev-util/molecule/molecule-0.9.24.6.ebuild
new file mode 100644
index 000000000000..8e5468b7c9c0
--- /dev/null
+++ b/dev-util/molecule/molecule-0.9.24.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/molecule-0.9.24.6.ebuild,v 1.1 2012/09/11 14:05:57 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+
+inherit python
+
+DESCRIPTION="Release metatool used for creating Sabayon (and Gentoo) releases"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+RDEPEND="net-misc/rsync
+ sys-fs/squashfs-tools
+ sys-process/lsof
+ virtual/cdrtools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/lib" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/molecule"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/molecule"
+}