summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-04 19:25:02 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-04 19:25:02 +0000
commit00632fea5560e1582475a8bfcc110b04ee18f599 (patch)
tree4ade07145dbab3785afbaae76a9dc4369aae0d10 /dev-vcs/tig
parentRaise gobject-introspection dependency from 1.31.1 to latest stable, which is... (diff)
downloadgentoo-2-00632fea5560e1582475a8bfcc110b04ee18f599.tar.gz
gentoo-2-00632fea5560e1582475a8bfcc110b04ee18f599.tar.bz2
gentoo-2-00632fea5560e1582475a8bfcc110b04ee18f599.zip
Version bump (bug #512358).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-vcs/tig')
-rw-r--r--dev-vcs/tig/ChangeLog7
-rw-r--r--dev-vcs/tig/tig-2.0.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index dbef3acd88a9..5c4c19ab7616 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tig
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.30 2014/05/07 06:03:12 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.31 2014/06/04 19:25:02 radhermit Exp $
+
+*tig-2.0.2 (04 Jun 2014)
+
+ 04 Jun 2014; Tim Harder <radhermit@gentoo.org> +tig-2.0.2.ebuild:
+ Version bump (bug #512358).
07 May 2014; Tim Harder <radhermit@gentoo.org> -tig-2.0.1.ebuild:
Remove old.
diff --git a/dev-vcs/tig/tig-2.0.2.ebuild b/dev-vcs/tig/tig-2.0.2.ebuild
new file mode 100644
index 000000000000..deb045f1d04d
--- /dev/null
+++ b/dev-vcs/tig/tig-2.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-2.0.2.ebuild,v 1.1 2014/06/04 19:25:02 radhermit Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="unicode"
+
+DEPEND="sys-libs/ncurses[unicode?]
+ sys-libs/readline:0"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_prepare() {
+ # pre-generated manpages are in the root directory
+ sed -i '/^MANDOC/s#doc/##g' Makefile || die
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dohtml manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+}