summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-16 12:54:16 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-16 12:54:16 +0000
commit80f819517cf185e8cfa7d5024a4e76f719b019f2 (patch)
treecf47c46e705b72b924273423b1a9474863b2e396 /eclass
parentMake KDE use econf as usual, by overriding the directories where the ${PREFIX... (diff)
downloadgentoo-2-80f819517cf185e8cfa7d5024a4e76f719b019f2.tar.gz
gentoo-2-80f819517cf185e8cfa7d5024a4e76f719b019f2.tar.bz2
gentoo-2-80f819517cf185e8cfa7d5024a4e76f719b019f2.zip
Remove danarmak's confcache support, as kde eclass now uses econf, and anyway this is no more supported by the latest confcache patch.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde-meta.eclass22
1 files changed, 1 insertions, 21 deletions
diff --git a/eclass/kde-meta.eclass b/eclass/kde-meta.eclass
index 1ce9ab356834..7b3363dc69f4 100644
--- a/eclass/kde-meta.eclass
+++ b/eclass/kde-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.56 2005/11/12 18:44:55 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.57 2005/11/16 12:54:16 flameeyes Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
# Simone Gotti <motaboy@gentoo.org>
@@ -392,26 +392,6 @@ function kde-meta_src_compile() {
# make sure games are not installed with setgid bit, as it is a security risk.
myconf="$myconf --disable-setgid"
fi
-
- # confcache support. valid only for my (danarmak's) port of stuart's confcache to portage .51,
- # not for stuart's orig version or ferringb's ebuild-daemon version.
- # this could be replaced by just using econf, but i don't want to make that change in kde.eclass
- # just yet. This way is more modular.
- callsections="$*"
- [ -z "$callsections" -o "$callsections" == "all" ] && callsections="myconf configure make"
- for section in $callsections; do
- debug-print "$FUNCNAME: now in section $section"
- if [ "$section" == "configure" ]; then
- # don't log makefile.common stuff in confcache
- [ ! -f "Makefile.in" ] && make -f admin/Makefile.common
- [ "`type -t confcache_start`" == "function" ] && confcache_start
- myconf="$EXTRA_ECONF $myconf"
- fi
- kde_src_compile $section
- if [ "$section" == "configure" ]; then
- [ "`type -t confcache_stop`" == "function" ] && confcache_stop
- fi
- done
}
function kde-meta_src_install() {