summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-04-16 05:01:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-04-16 05:01:58 +0000
commit907f8450971b06db38d405ce08ef50ac1b78e60f (patch)
tree6203686afd5c59114eda23e693e3884aa72106a9 /games-action/cylindrix
parentversion bump (diff)
downloadgentoo-2-907f8450971b06db38d405ce08ef50ac1b78e60f.tar.gz
gentoo-2-907f8450971b06db38d405ce08ef50ac1b78e60f.tar.bz2
gentoo-2-907f8450971b06db38d405ce08ef50ac1b78e60f.zip
eautoreconf to find install (bug #174715); tidy
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-action/cylindrix')
-rw-r--r--games-action/cylindrix/ChangeLog7
-rw-r--r--games-action/cylindrix/cylindrix-1.0.ebuild32
2 files changed, 20 insertions, 19 deletions
diff --git a/games-action/cylindrix/ChangeLog b/games-action/cylindrix/ChangeLog
index 0711fbb22c9f..69b72e8d3b2e 100644
--- a/games-action/cylindrix/ChangeLog
+++ b/games-action/cylindrix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/cylindrix
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/cylindrix/ChangeLog,v 1.4 2006/01/28 21:19:10 joshuabaergen Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/cylindrix/ChangeLog,v 1.5 2007/04/16 05:01:58 mr_bones_ Exp $
+
+ 16 Apr 2007; Michael Sterrett <mr_bones_@gentoo.org> cylindrix-1.0.ebuild:
+ eautoreconf to find install (bug #174715); tidy
28 Jan 2006; Joshua Baergen <joshuabaergen@gentoo.org>
cylindrix-1.0.ebuild:
diff --git a/games-action/cylindrix/cylindrix-1.0.ebuild b/games-action/cylindrix/cylindrix-1.0.ebuild
index b080866fde29..f5f531b25982 100644
--- a/games-action/cylindrix/cylindrix-1.0.ebuild
+++ b/games-action/cylindrix/cylindrix-1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/cylindrix/cylindrix-1.0.ebuild,v 1.4 2006/01/28 21:19:10 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/cylindrix/cylindrix-1.0.ebuild,v 1.5 2007/04/16 05:01:58 mr_bones_ Exp $
-inherit games
+inherit autotools games
DESCRIPTION="Action game in a tube"
HOMEPAGE="http://www.hardgeus.com/cylindrix/"
@@ -10,7 +10,7 @@ SRC_URI="http://www.hardgeus.com/cylindrix/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="~ppc x86"
IUSE=""
DEPEND=">=media-libs/allegro-4.0.3"
@@ -19,23 +19,21 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}
- sed -i "/g_DataPath/s:\./:${GAMES_DATADIR}/${PN}/:" sb_stub.c \
- || die "sed sb_stub.c failed"
+ cd "${S}"
+ sed -i \
+ -e "/g_DataPath/s:\./:${GAMES_DATADIR}/${PN}/:" \
+ sb_stub.c \
+ || die "sed failed"
find -name CVS -exec rm -rf '{}' \; >& /dev/null
+ eautoreconf
}
src_install() {
- make install DESTDIR=${D} || die
- insinto ${GAMES_DATADIR}/${PN}
- doins people.dat cylindrx.fli
- for d in 3d_data gamedata pcx_data ; do
- insinto ${GAMES_DATADIR}/${PN}/${d}
- doins ${d}/*
- done
- cp -r wav_data ${D}/${GAMES_DATADIR}/${PN}/
-
+ emake DESTDIR="${D}" install || die "emake failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins people.dat cylindrx.fli || die "doins failed"
+ doins -r wav_data 3d_data gamedata pcx_data || die "doins failed"
dodoc AUTHORS ChangeLog NEWS README
prepgamesdirs
- fperms g+w ${GAMES_DATADIR}/${PN}/gamedata/game.cfg
+ fperms g+w "${GAMES_DATADIR}"/${PN}/gamedata/game.cfg
}