summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-25 23:30:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-25 23:30:46 +0000
commitdbd7212aed013887c03ccc78842f90d05e850d0c (patch)
tree927d4367644f0594455359cc7e82348a236f768b /games-board
parentFix manifest (diff)
downloadgentoo-2-dbd7212aed013887c03ccc78842f90d05e850d0c.tar.gz
gentoo-2-dbd7212aed013887c03ccc78842f90d05e850d0c.tar.bz2
gentoo-2-dbd7212aed013887c03ccc78842f90d05e850d0c.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/xboard/ChangeLog8
-rw-r--r--games-board/xboard/files/xboard-4.4.3-gentoo.patch63
-rw-r--r--games-board/xboard/xboard-4.4.3.ebuild71
3 files changed, 141 insertions, 1 deletions
diff --git a/games-board/xboard/ChangeLog b/games-board/xboard/ChangeLog
index 1cb7fd9e32fc..91cbfc7259aa 100644
--- a/games-board/xboard/ChangeLog
+++ b/games-board/xboard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/xboard
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xboard/ChangeLog,v 1.29 2010/04/04 13:35:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/xboard/ChangeLog,v 1.30 2010/04/25 23:30:46 mr_bones_ Exp $
+
+*xboard-4.4.3 (25 Apr 2010)
+
+ 25 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org> +xboard-4.4.3.ebuild,
+ +files/xboard-4.4.3-gentoo.patch:
+ version bump
04 Apr 2010; Markos Chandras <hwoarang@gentoo.org> xboard-4.4.1.ebuild:
Revert my previous commit as this app fails to run properly
diff --git a/games-board/xboard/files/xboard-4.4.3-gentoo.patch b/games-board/xboard/files/xboard-4.4.3-gentoo.patch
new file mode 100644
index 000000000000..b31f262d8331
--- /dev/null
+++ b/games-board/xboard/files/xboard-4.4.3-gentoo.patch
@@ -0,0 +1,63 @@
+diff -ru xboard-4.4.1.orig/configure.ac xboard-4.4.1/configure.ac
+--- xboard-4.4.1.orig/configure.ac 2009-10-31 12:50:50.000000000 -0400
++++ xboard-4.4.1/configure.ac 2009-11-02 00:22:17.874375879 -0500
+@@ -123,37 +123,18 @@
+ fi
+
+ dnl | test if user wants ot use Xaw3d headers
+-AC_ARG_WITH([Xaw3d],
+- [AS_HELP_STRING([--with-Xaw3d],
+- [use Xaw3d instead of Xaw])],
+- [with_xaw3d=yes],
+- [with_xaw3d=no])
+-
+-XAW_LIBS=
+-AS_IF([test "x$with_xaw3d" != xno],
+- [AC_CHECK_LIB([Xaw3d],
+- [XawTextReplace],
+- [AC_SUBST([XAW_LIBS],
+- ["-lXaw3d"])
+- AC_DEFINE([USE_XAW3D], [1],
+- [Define if you want to use Xaw3d])],
+- [AC_CHECK_HEADER(X11/Xaw/Dialog.h,xaw_headers="yes")
+- AC_MSG_FAILURE(
+- [--with-Xaw3d was given, but test for Xaw3d failed])],
+- [-lXaw])])
+-if test "$with_xaw3d" == "no" ; then
+- XAW_LIBS="-lXaw"
+-fi
+-AC_SUBST(XAW_LIBS)
+-
+-dnl | end Xaw3d test
+-
+-if test "$xaw_headers" == "no" ; then
+- echo Xaw headers not found
+- exit 1
+-
++AC_ARG_WITH(Xaw3d,
++[ --with-Xaw3d use Xaw3d instead of Xaw],
++[ with_xaw3d="$withval"], [enable_xaw3d="no"])
++
++if test "$withval" = yes; then
++ AC_DEFINE(USE_XAW3D)
++ XAW_LIBS="-lXaw3d"
++else
++ XAW_LIBS="-lXaw"
+ fi
+
++AC_SUBST(XAW_LIBS)
+
+ AC_CANONICAL_HOST
+
+diff -ru xboard-4.4.1.orig/xboard.h xboard-4.4.1/xboard.h
+--- xboard-4.4.1.orig/xboard.h 2009-10-26 02:04:15.000000000 -0400
++++ xboard-4.4.1/xboard.h 2009-11-02 00:22:45.408375832 -0500
+@@ -104,7 +104,7 @@
+
+ #define BORDER_X_OFFSET 3
+ #define BORDER_Y_OFFSET 27
+-#define FIRST_CHESS_PROGRAM "fairymax"
++#define FIRST_CHESS_PROGRAM "gnuchess"
+ #define SECOND_CHESS_PROGRAM "fairymax"
+
+ /* Default to no flashing (the "usual" XBoard behavior) */
diff --git a/games-board/xboard/xboard-4.4.3.ebuild b/games-board/xboard/xboard-4.4.3.ebuild
new file mode 100644
index 000000000000..12bcff2ce7b0
--- /dev/null
+++ b/games-board/xboard/xboard-4.4.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xboard/xboard-4.4.3.ebuild,v 1.1 2010/04/25 23:30:46 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="GUI for gnuchess and for internet chess servers"
+HOMEPAGE="http://www.gnu.org/software/xboard/"
+SRC_URI="mirror://gnu/xboard/${P}.tar.gz
+ mirror://gentoo/${PN}.png
+ http://dev.gentoo.org/~wolf31o2/sources/dump/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="Xaw3d +default-font zippy"
+RESTRICT="test" #124112
+
+RDEPEND="Xaw3d? ( x11-libs/Xaw3d )
+ x11-libs/libXpm
+ x11-libs/libXaw
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libICE
+ default-font? ( media-fonts/font-adobe-100dpi )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}*
+ sed -i \
+ -e '/icons/s:\$(datadir):/usr/share:' \
+ Makefile.am \
+ || die 'sed failed'
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_with Xaw3d) \
+ $(use_enable zippy)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS COPYRIGHT ChangeLog NEWS README TODO ics-parsing.txt
+ use zippy && dodoc zippy.README
+ dohtml FAQ.html
+ doicon "${DISTDIR}"/xboard.png
+ make_desktop_entry ${PN} "Xboard (Chess)"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "No chess engines are emerged by default! If you want a chess engine"
+ elog "to play with, you can emerge gnuchess or crafty."
+ elog "Read xboard FAQ for information."
+ if ! use default-font ; then
+ ewarn "Read the xboard(6) man page for specifying the font for xboard to use."
+ fi
+}