summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-10-22 10:57:13 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-10-22 10:57:13 +0000
commitee56e8fe93fd1c4b39e0efb00c79aada6d31380f (patch)
treeef9c68f20e1914bf61e624d30102d7cd9ea25474 /games-board
parentAdded initial ebuild for mono-fuse (mono-fuse-0.4.0) (diff)
downloadgentoo-2-ee56e8fe93fd1c4b39e0efb00c79aada6d31380f.tar.gz
gentoo-2-ee56e8fe93fd1c4b39e0efb00c79aada6d31380f.tar.bz2
gentoo-2-ee56e8fe93fd1c4b39e0efb00c79aada6d31380f.zip
Patches for amd64 & fix blas usage. Bug #127554
(Portage version: 2.1.1)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnubg/ChangeLog8
-rw-r--r--games-board/gnubg/files/digest-gnubg-0.14.3-r112
-rw-r--r--games-board/gnubg/files/gnubg-0.14.3-64bits.patch97
-rw-r--r--games-board/gnubg/files/gnubg-0.14.3-blas.patch11
-rw-r--r--games-board/gnubg/gnubg-0.14.3-r1.ebuild109
5 files changed, 236 insertions, 1 deletions
diff --git a/games-board/gnubg/ChangeLog b/games-board/gnubg/ChangeLog
index f59633b0ef06..6c2008ec1522 100644
--- a/games-board/gnubg/ChangeLog
+++ b/games-board/gnubg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/gnubg
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/ChangeLog,v 1.25 2006/07/08 08:11:02 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/ChangeLog,v 1.26 2006/10/22 10:57:13 tupone Exp $
+
+*gnubg-0.14.3-r1 (22 Oct 2006)
+
+ 22 Oct 2006; <tupone@gentoo.org> +files/gnubg-0.14.3-64bits.patch,
+ +files/gnubg-0.14.3-blas.patch, +gnubg-0.14.3-r1.ebuild:
+ Patches for amd64 & fix blas usage. Bug #127554 by playmiac
08 Jul 2006; Markus Rothe <corsair@gentoo.org> gnubg-0.14.3.ebuild:
Stable on ppc64
diff --git a/games-board/gnubg/files/digest-gnubg-0.14.3-r1 b/games-board/gnubg/files/digest-gnubg-0.14.3-r1
new file mode 100644
index 000000000000..16a6cf327157
--- /dev/null
+++ b/games-board/gnubg/files/digest-gnubg-0.14.3-r1
@@ -0,0 +1,12 @@
+MD5 b3ab1ace76fa4bea69db8e617ab587da gnubg-0.14.3.tar.gz 4241526
+RMD160 da7b2a3b52194ca11d505a70fba805e99f15c3ed gnubg-0.14.3.tar.gz 4241526
+SHA256 76d18f1a7952a4ba2372e439b3c4ecf2fcd244d334c609bb22d3f501067d1d72 gnubg-0.14.3.tar.gz 4241526
+MD5 9f1154a9b327954a260726aa6aa6eea5 gnubg.weights-0.14.gz 460747
+RMD160 5d588b1145f0d0489b5d70fa6cfccd9ce6738f04 gnubg.weights-0.14.gz 460747
+SHA256 6c134ded36d0875cb673a4f9fd84e2d30424935951baeffcd94852ccdb2daf70 gnubg.weights-0.14.gz 460747
+MD5 4015327219322eacab5ddd58f6fa268d gnubg_os0.bd.gz 906720
+RMD160 83fefa3c39544ca9a51f1ba7ae5e8bd5215e631c gnubg_os0.bd.gz 906720
+SHA256 e84a36f133ee7ea9fa3686af6c111088b8b43906db1b6c6b3db0035c84cda809 gnubg_os0.bd.gz 906720
+MD5 01bd14c184bd701ae484618eb8acec6e gnubg_ts0.bd.gz 5899380
+RMD160 9e0bea798a53374061014226aca9f5d2063133e8 gnubg_ts0.bd.gz 5899380
+SHA256 0934e4f2d84f5cd50c2ff4592c93c49d43f7cb89da342600736849c7362626d5 gnubg_ts0.bd.gz 5899380
diff --git a/games-board/gnubg/files/gnubg-0.14.3-64bits.patch b/games-board/gnubg/files/gnubg-0.14.3-64bits.patch
new file mode 100644
index 000000000000..d4b400a80ced
--- /dev/null
+++ b/games-board/gnubg/files/gnubg-0.14.3-64bits.patch
@@ -0,0 +1,97 @@
+--- gnubg.c.old 2006-10-21 09:42:47.000000000 +0200
++++ gnubg.c 2006-10-21 09:45:19.000000000 +0200
+@@ -8971,7 +8971,8 @@
+ #if HAVE_ICONV
+
+ iconv_t id;
+- int lIn, lOut, l, rc, nUsed;
++ size_t lIn, lOut, l;
++ int rc, nUsed;
+ #if WIN32
+ const char *pchIn;
+ #else
+--- renderprefs.c.old 2006-10-21 09:51:22.000000000 +0200
++++ renderprefs.c 2006-10-21 10:13:00.000000000 +0200
+@@ -158,11 +158,13 @@
+ #endif /* USE_GTK */
+
+ #if USE_BOARD3D
+-static int SetMaterialCommon(Material* pMat, char *sz)
++static int SetMaterialCommon(Material* pMat, char **newsz)
+ {
++ char *sz;
+ float opac;
+ char* pch;
+
++ sz = *newsz;
+ if (SetColourF(pMat->ambientColour, sz) != 0)
+ return -1;
+ sz += strlen(sz) + 1;
+@@ -206,38 +208,43 @@
+ {
+ sz += strlen(sz) + 1;
+ if (sz && *sz)
+- return (int)sz;
++ {
++ *newsz = sz;
++ return 1;
++ }
+ }
+ return 0;
+ }
+
+ static int SetMaterial(Material* pMat, char *sz)
+ {
++ int status = (sz != NULL);
+ if (fX)
+ {
+- sz = (char*)SetMaterialCommon(pMat, sz);
++ status = SetMaterialCommon(pMat, &sz);
+ pMat->textureInfo = 0;
+ pMat->pTexture = 0;
+- if (sz > 0)
++ if (status > 0)
+ {
+ FindTexture(&pMat->textureInfo, sz);
+- sz = 0;
++ status = 0;
+ }
+ }
+- return (int)sz;
++ return status;
+ }
+
+ static int SetMaterialDice(Material* pMat, char *sz, int* flag)
+ {
+- sz = (char*)SetMaterialCommon(pMat, sz);
++ int status;
++ status = SetMaterialCommon(pMat, &sz);
+ /* die colour same as chequer colour */
+ *flag = TRUE;
+- if (sz > 0)
++ if (status > 0)
+ {
+ *flag = (toupper(*sz) == 'Y');
+- sz = 0;
++ status = 0;
+ }
+- return (int)sz;
++ return status;
+ }
+
+ #endif
+--- board3d/misc3d.c.old 2006-10-21 10:16:16.000000000 +0200
++++ board3d/misc3d.c 2006-10-21 10:16:36.000000000 +0200
+@@ -787,10 +787,10 @@
+ float ***Alloc3d(int x, int y, int z)
+ { /* Allocate 3d array */
+ int i, j;
+- float ***array = (float ***)malloc(sizeof(float) * x);
++ float ***array = (float ***)malloc(sizeof(float **) * x);
+ for (i = 0; i < x; i++)
+ {
+- array[i] = (float **)malloc(sizeof(float) * y);
++ array[i] = (float **)malloc(sizeof(float *) * y);
+ for (j = 0; j < y; j++)
+ array[i][j] = (float *)malloc(sizeof(float) * z);
+ }
diff --git a/games-board/gnubg/files/gnubg-0.14.3-blas.patch b/games-board/gnubg/files/gnubg-0.14.3-blas.patch
new file mode 100644
index 000000000000..aa9c5425648a
--- /dev/null
+++ b/games-board/gnubg/files/gnubg-0.14.3-blas.patch
@@ -0,0 +1,11 @@
+--- lib/neuralnet.c.old 2006-10-22 12:12:20.000000000 +0200
++++ lib/neuralnet.c 2006-10-22 12:13:05.000000000 +0200
+@@ -39,7 +39,7 @@
+
+ #if HAVE_LIBATLAS
+ #warning "LIBATLAS processing..."
+-#include <cblas.h>
++#include <atlas/cblas.h>
+ #endif /* HAVE_LIBATLAS */
+
+ #if SIGMOID_BAUR
diff --git a/games-board/gnubg/gnubg-0.14.3-r1.ebuild b/games-board/gnubg/gnubg-0.14.3-r1.ebuild
new file mode 100644
index 000000000000..cdaa257ce1d7
--- /dev/null
+++ b/games-board/gnubg/gnubg-0.14.3-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/gnubg-0.14.3-r1.ebuild,v 1.1 2006/10/22 10:57:13 tupone Exp $
+
+inherit flag-o-matic eutils games
+
+WPV="0.14"
+DESCRIPTION="GNU BackGammon"
+HOMEPAGE="http://www.gnu.org/software/gnubg/gnubg.html"
+SRC_URI="ftp://alpha.gnu.org/gnu/gnubg/${P}.tar.gz
+ ftp://alpha.gnu.org/gnu/gnubg/${PN}.weights-${WPV}.gz
+ ftp://alpha.gnu.org/gnu/gnubg/gnubg_os0.bd.gz
+ ftp://alpha.gnu.org/gnu/gnubg/gnubg_ts0.bd.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ppc64 ~sparc x86"
+IUSE="arts esd gdbm gtk guile nas nls opengl python readline X"
+
+# test fail - bug #132002
+RESTRICT="test"
+
+# FIXME does this need to DEPEND on netpbm?
+DEPEND="dev-libs/glib
+ >=media-libs/freetype-2
+ media-libs/libpng
+ dev-libs/libxml2
+ sys-libs/zlib
+ arts? ( kde-base/arts )
+ esd? ( media-sound/esound )
+ gdbm? ( sys-libs/gdbm )
+ =dev-libs/glib-2*
+ gtk? (
+ =x11-libs/gtk+-2*
+ media-libs/libart_lgpl
+ opengl? ( x11-libs/gtkglext >=media-libs/ftgl-2.1.2-r1 )
+ )
+ guile? ( dev-util/guile )
+ nas? ( media-libs/nas )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )
+ X? ( x11-libs/libXmu )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv ../${PN}.weights-${WPV} "${S}/${PN}.weights"
+ mv ../*bd .
+ epatch \
+ "${FILESDIR}/${P}"-gcc4.patch \
+ "${FILESDIR}/${P}"-64bits.patch \
+ "${FILESDIR}/${P}"-blas.patch \
+ "${FILESDIR}/${P}"-as-needed.patch
+}
+
+src_compile() {
+ local myconf=
+ if use gtk ; then
+ # doesn't make any sense to add this without gtk or gtk2
+ if has_version x11-libs/gtk+extra ; then
+ myconf="--with-gtkextra"
+ else
+ myconf="--without-gtkextra"
+ fi
+ myconf="${myconf} --with-gtk --with-gtk2"
+ if use opengl ; then
+ myconf="${myconf} --with-board3d"
+ append-flags $(pkg-config ftgl --cflags)
+ append-ldflags $(pkg-config ftgl --libs)
+ else
+ myconf="${myconf} --without-board3d"
+ fi
+ else
+ myconf="${myconf} --without-gtk --disable-gtktest --without-board3d"
+ fi
+ if use arts || use esd ; then
+ myconf="${myconf} --with-sound"
+ else
+ myconf="${myconf} --without-sound --disable-esdtest --disable-artsc-test"
+ fi
+ if ! use guile ; then
+ myconf="${myconf} --without-guile"
+ fi
+
+ filter-flags -ffast-math #bug #67929
+
+ LIBART_CONFIG="/usr/bin/libart2-config" egamesconf \
+ $(use_enable arts artsc) \
+ $(use_enable esd) \
+ $(use_with gdbm) \
+ $(use_enable nas) \
+ $(use_enable nls) \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with X x) \
+ ${myconf} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins ${PN}.weights *bd || die "doins failed"
+ dodoc AUTHORS README NEWS
+ newicon xpm/gnubg-big.xpm gnubg.xpm
+ make_desktop_entry "gnubg -w" "GNU Backgammon" gnubg.xpm
+ prepgamesdirs
+}