summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-04-11 20:51:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-04-11 20:51:37 +0000
commit25c2595fa1512fff5801ab06e38ba47e69e48bd3 (patch)
tree328da8f1400869878979fe18a16d6c21697cb157 /games-emulation/generator
parentGrab several bugfixes from the 3.5 branch, for reference see the KDE bugs #66... (diff)
downloadgentoo-2-25c2595fa1512fff5801ab06e38ba47e69e48bd3.tar.gz
gentoo-2-25c2595fa1512fff5801ab06e38ba47e69e48bd3.tar.bz2
gentoo-2-25c2595fa1512fff5801ab06e38ba47e69e48bd3.zip
stable for x86; fix QA warnings with patch to configure.ac
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-emulation/generator')
-rw-r--r--games-emulation/generator/ChangeLog7
-rw-r--r--games-emulation/generator/files/generator-0.35-configure.patch61
-rw-r--r--games-emulation/generator/files/generator-0.35-execstacks.patch7
-rw-r--r--games-emulation/generator/generator-0.35-r3.ebuild16
4 files changed, 78 insertions, 13 deletions
diff --git a/games-emulation/generator/ChangeLog b/games-emulation/generator/ChangeLog
index f25e8ad057f1..497118fd2f95 100644
--- a/games-emulation/generator/ChangeLog
+++ b/games-emulation/generator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/generator
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/ChangeLog,v 1.17 2007/03/07 16:48:24 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/ChangeLog,v 1.18 2007/04/11 20:51:37 mr_bones_ Exp $
+
+ 11 Apr 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/generator-0.35-configure.patch,
+ files/generator-0.35-execstacks.patch, generator-0.35-r3.ebuild:
+ stable for x86; fix QA warnings with patch to configure.ac
07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> generator-0.35.ebuild:
Change all instances of [ to [[.
diff --git a/games-emulation/generator/files/generator-0.35-configure.patch b/games-emulation/generator/files/generator-0.35-configure.patch
new file mode 100644
index 000000000000..cc4046c7e62b
--- /dev/null
+++ b/games-emulation/generator/files/generator-0.35-configure.patch
@@ -0,0 +1,61 @@
+--- configure.ac.orig 2007-04-11 16:28:09.000000000 -0400
++++ configure.ac 2007-04-11 16:29:07.000000000 -0400
+@@ -202,50 +202,6 @@
+ CFLAGS="$CFLAGS -Wstrict-prototypes -Wunused"
+ fi
+ fi
+- if [[ "x$DEBUG" != "xno" ]]; then
+- AC_MSG_RESULT(Turning on debug flags)
+- CFLAGS="$CFLAGS -g -O"
+- optimum=no
+- else
+- if [[ "x$GCCVER" != "xno" ]]; then
+- AC_MSG_RESULT(Turning on gcc optimisations)
+- CFLAGS="$CFLAGS -O3 -fomit-frame-pointer"
+- if [[ "x$GCCVER" = "x3" ]]; then
+- AC_MSG_RESULT(Turning on gcc 3 optimisations)
+- CFLAGS="$CFLAGS -fno-math-errno"
+- fi
+- case "$CFLAGS" in
+- *mcpu*|*march*) AC_MSG_RESULT(Skipping target optimisations)
+- ;;
+- *) case "$target_cpu" in
+- i386) AC_MSG_RESULT(Turning on i386 optimisations)
+- CFLAGS="$CFLAGS -march=i386 -ffast-math"
+- ;;
+- i486) AC_MSG_RESULT(Turning on i486 optimisations)
+- CFLAGS="$CFLAGS -march=i486 -ffast-math"
+- ;;
+- i586) AC_MSG_RESULT(Turning on pentium optimisations)
+- # cannot do malign-double as we link to other libraries and
+- # it would break binary compatibility
+- CFLAGS="$CFLAGS -march=pentium -ffast-math"
+- ;;
+- i?86) AC_MSG_RESULT(Turning on i686 optimisations)
+- # cannot do malign-double as we link to other libraries and
+- # it would break binary compatibility
+- CFLAGS="$CFLAGS -march=i686 -ffast-math"
+- ;;
+- alpha*) AC_MSG_RESULT(Adding -mieee for Alpha)
+- CFLAGS="$CFLAGS -mieee"
+- ;;
+- *) AC_MSG_RESULT(Sorry unknown target CPU)
+- ;;
+- esac
+- esac
+- else
+- AC_MSG_WARN(You did not opt for gcc optimisations!)
+- optimum=no
+- fi
+- fi
+ AC_CHECK_LIB(jpeg, jpeg_start_compress,
+ [ MY_LIBS="-ljpeg $MY_LIBS"; AC_DEFINE(JPEG, 1, [JPEG features]) ])
+
+@@ -305,6 +261,7 @@
+ AC_CHECK_SIZEOF(unsigned long, 4)
+ AC_CHECK_SIZEOF(unsigned long long, 8)
+ AC_CHECK_HEADERS(sys/param.h)
++ AC_CHECK_HEADERS(sys/time.h)
+ AC_CHECK_HEADERS(bzlib.h)
+ AC_CHECK_HEADERS(zlib.h)
+ AC_CHECK_HEADERS(tcl8.0.h)
diff --git a/games-emulation/generator/files/generator-0.35-execstacks.patch b/games-emulation/generator/files/generator-0.35-execstacks.patch
index efe4c21483e2..f92ef6121f5a 100644
--- a/games-emulation/generator/files/generator-0.35-execstacks.patch
+++ b/games-emulation/generator/files/generator-0.35-execstacks.patch
@@ -1,5 +1,5 @@
---- raze/Makefile.in.old 2006-09-03 03:17:39.000000000 +0200
-+++ raze/Makefile.in 2006-09-03 03:16:36.000000000 +0200
+--- raze/Makefile.am.old 2006-09-03 03:17:39.000000000 +0200
++++ raze/Makefile.am 2006-09-03 03:16:36.000000000 +0200
@@ -343,6 +343,10 @@
raze: raze.o
raze.o: raze.asm raze.reg
@@ -9,5 +9,4 @@
+ >> raze2.asm
+ echo "%endif" >> raze2.asm
nasm -f @ASMOUTPUT@ raze2.asm -o raze.o -praze.reg
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
+
diff --git a/games-emulation/generator/generator-0.35-r3.ebuild b/games-emulation/generator/generator-0.35-r3.ebuild
index dcba5b7dfe4e..5fd5ba72cc2f 100644
--- a/games-emulation/generator/generator-0.35-r3.ebuild
+++ b/games-emulation/generator/generator-0.35-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35-r3.ebuild,v 1.2 2007/02/03 08:01:50 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35-r3.ebuild,v 1.3 2007/04/11 20:51:37 mr_bones_ Exp $
-inherit eutils toolchain-funcs games
+inherit autotools eutils toolchain-funcs games
DESCRIPTION="Sega Genesis / Mega Drive emulator"
HOMEPAGE="http://www.ghostwhitecrab.com/generator/"
@@ -10,7 +10,7 @@ SRC_URI="http://www.ghostwhitecrab.com/generator/${P}-cbiere-r2.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE="gtk sdlaudio svga"
S=${WORKDIR}/${P}-cbiere-r2
@@ -27,11 +27,10 @@ src_unpack() {
cd "${S}"
mkdir my-bins
- epatch "${FILESDIR}"/${P}-execstacks.patch
-
- sed -i \
- -e '/CFLAGS.*-O3/d' \
- configure || die "sed configure failed"
+ epatch \
+ "${FILESDIR}"/${P}-execstacks.patch \
+ "${FILESDIR}"/${P}-configure.patch
+ eautoreconf
}
# builds SDL by default since otherwise -svga -gtk builds nothing
@@ -51,6 +50,7 @@ src_compile() {
egamesconf \
${myconf} \
--with-${mygui} \
+ --without-tcltk \
--with-gcc=$(gcc-major-version) \
$(use_with sdlaudio sdl-audio) \
--disable-dependency-tracking || die