summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-04-24 20:04:08 +0000
committerDaniel Goller <morfic@gentoo.org>2005-04-24 20:04:08 +0000
commite3fa538c9a6cc0d71f2b48887b565782109e3b06 (patch)
tree301cc0a22b35485033be05e9dcfa1a319dbed469 /games-emulation
parentadded dev-util/xdelta (diff)
downloadgentoo-2-e3fa538c9a6cc0d71f2b48887b565782109e3b06.tar.gz
gentoo-2-e3fa538c9a6cc0d71f2b48887b565782109e3b06.tar.bz2
gentoo-2-e3fa538c9a6cc0d71f2b48887b565782109e3b06.zip
amd64 fixes
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-glN64/ChangeLog7
-rw-r--r--games-emulation/mupen64-glN64/files/digest-mupen64-glN64-0.4.1_pre11
-rw-r--r--games-emulation/mupen64-glN64/files/mupen64-glN64-noasmfix.patch11
-rw-r--r--games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_pre1.ebuild28
-rw-r--r--games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild3
5 files changed, 19 insertions, 31 deletions
diff --git a/games-emulation/mupen64-glN64/ChangeLog b/games-emulation/mupen64-glN64/ChangeLog
index 72d01a776cc6..baf9d783aa2f 100644
--- a/games-emulation/mupen64-glN64/ChangeLog
+++ b/games-emulation/mupen64-glN64/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/mupen64-glN64
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/ChangeLog,v 1.8 2005/04/24 00:34:33 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/ChangeLog,v 1.9 2005/04/24 20:04:08 morfic Exp $
+
+ 24 Apr 2005; Daniel Goller <morfic@gentoo.org>
+ +files/mupen64-glN64-noasmfix.patch, -mupen64-glN64-0.4.1_pre1.ebuild,
+ mupen64-glN64-0.4.1_rc2-r1.ebuild:
+ amd64 fixes
23 Apr 2005; Daniel Goller <morfic@gentoo.org>
mupen64-glN64-0.4.1_rc2-r1.ebuild:
diff --git a/games-emulation/mupen64-glN64/files/digest-mupen64-glN64-0.4.1_pre1 b/games-emulation/mupen64-glN64/files/digest-mupen64-glN64-0.4.1_pre1
deleted file mode 100644
index 8e038672d326..000000000000
--- a/games-emulation/mupen64-glN64/files/digest-mupen64-glN64-0.4.1_pre1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4ee96713c240c1124f78c47cefc0e983 glN64-0.4.1-pre1.so 315452
diff --git a/games-emulation/mupen64-glN64/files/mupen64-glN64-noasmfix.patch b/games-emulation/mupen64-glN64/files/mupen64-glN64-noasmfix.patch
new file mode 100644
index 000000000000..0b924cf095f8
--- /dev/null
+++ b/games-emulation/mupen64-glN64/files/mupen64-glN64-noasmfix.patch
@@ -0,0 +1,11 @@
+--- glN64-0.4.1-rc2/convert.h.old 2005-04-23 16:32:44.000000000 -0700
++++ glN64-0.4.1-rc2/convert.h 2005-04-23 16:40:43.000000000 -0700
+@@ -442,7 +442,7 @@
+ while (numDWords--)
+ {
+ u32 dword = *(u32 *)src;
+- __asm__ volatile( "bswapl %0\n\t" : "=q"(dword) : "0"(dword) );
++ dword = ((dword<<24)|((dword<<8)&0x00FF0000)|((dword>>8)&0x0000FF00)|(dword>>24));
+ *(u32 *)dest = dword;
+ dest = (void *)((int)dest+4);
+ src = (void *)((int)src +4);
diff --git a/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_pre1.ebuild b/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_pre1.ebuild
deleted file mode 100644
index d5ef1c3ecef7..000000000000
--- a/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_pre1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_pre1.ebuild,v 1.1 2005/01/06 03:04:36 morfic Exp $
-
-inherit games
-
-S=${WORKDIR}
-MY_P="glN64-${PV/_/-}"
-DESCRIPTION="An OpenGL graphics plugin for the mupen64 N64 emulator"
-SRC_URI="http://deltaanime.ath.cx/~blight/n64/blight_glN64_port/${MY_P}.so"
-HOMEPAGE="http://deltaanime.ath.cx/~blight/n64/"
-
-KEYWORDS="x86"
-LICENSE="as-is"
-SLOT="0"
-IUSE=""
-
-RDEPEND="media-libs/libsdl"
-
-src_unpack() {
- cp ${DISTDIR}/${A} ${WORKDIR} || die "cp failed"
-}
-
-src_install () {
- exeinto ${GAMES_LIBDIR}/mupen64/plugins
- doexe ${MY_P}.so || die "doexe failed"
- prepgamesdirs
-}
diff --git a/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild b/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild
index 3703e901123d..8848afda9da3 100644
--- a/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild
+++ b/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild,v 1.4 2005/04/24 00:34:33 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild,v 1.5 2005/04/24 20:04:08 morfic Exp $
inherit eutils games
@@ -29,6 +29,7 @@ src_compile () {
fi
epatch ${FILESDIR}/${PN}-ucode.patch || die "ucode patch failed"
+ epatch ${FILESDIR}/${PN}-noasmfix.patch || die "noasmfix patch failed"
if ! use asm; then
epatch ${FILESDIR}/${PN}-noasm.patch