summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-01-12 04:02:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-01-12 04:02:41 +0000
commitbe0866082a5617a37de0e186a47115c3b912ded0 (patch)
treee54245091cac5d21d28f76498b96ac164b0ea96b /games-puzzle
parentNew ebuild by Anton Romanov. Bug #90582 (diff)
downloadgentoo-2-be0866082a5617a37de0e186a47115c3b912ded0.tar.gz
gentoo-2-be0866082a5617a37de0e186a47115c3b912ded0.tar.bz2
gentoo-2-be0866082a5617a37de0e186a47115c3b912ded0.zip
touchups
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/xlogical/xlogical-1.0.7.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/games-puzzle/xlogical/xlogical-1.0.7.ebuild b/games-puzzle/xlogical/xlogical-1.0.7.ebuild
index 683c0d165879..de88e2edc389 100644
--- a/games-puzzle/xlogical/xlogical-1.0.7.ebuild
+++ b/games-puzzle/xlogical/xlogical-1.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xlogical/xlogical-1.0.7.ebuild,v 1.1 2007/01/12 03:40:02 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xlogical/xlogical-1.0.7.ebuild,v 1.2 2007/01/12 04:02:41 mr_bones_ Exp $
inherit versionator eutils games
@@ -20,29 +20,26 @@ DEPEND="media-libs/libsdl
media-libs/sdl-image
media-libs/sdl-mixer"
-S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)"
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-2)
src_unpack() {
unpack ${A}
cd "${S}"
edos2unix properties.h anim.h exception.h
- epatch "${FILESDIR}/${P}"-gcc41.patch \
- || die "epatch failed"
+ epatch "${FILESDIR}/${P}"-gcc41.patch
}
src_install() {
dogamesbin ${PN} || die "installing the binary failed"
- insinto ${GAMES_DATADIR}/${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
doins -r ${PN}.{properties,levels} music sound images \
|| die "installing game data failed"
- insinto ${GAMES_STATEDIR}/${PN}
+ insinto "${GAMES_STATEDIR}"/${PN}
insopts -m0660
doins ${PN}.scores || die "installing hi-score failed"
- dodoc AUTHORS ChangeLog NEWS README TODO \
- || die "Installing doc failed"
-
+ dodoc AUTHORS ChangeLog NEWS README TODO
prepgamesdirs
}