summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-12-24 18:36:43 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-12-24 18:36:43 +0000
commitb91bb10820c6b9f7d4f20836868f9cd108305950 (patch)
tree2e27c072b6d921bbe820df381bb9592682328b07 /games-strategy/triplea
parentVersion bump. Use VDA patch version 2.3.3. Closes bug #158033, reported by Au... (diff)
downloadgentoo-2-b91bb10820c6b9f7d4f20836868f9cd108305950.tar.gz
gentoo-2-b91bb10820c6b9f7d4f20836868f9cd108305950.tar.bz2
gentoo-2-b91bb10820c6b9f7d4f20836868f9cd108305950.zip
Use java-pkg_dolauncher to ensure >=jre-1.5 is used, bug #158643
(Portage version: 2.1.2_rc4)
Diffstat (limited to 'games-strategy/triplea')
-rw-r--r--games-strategy/triplea/ChangeLog5
-rw-r--r--games-strategy/triplea/triplea-0.8.2.2.ebuild18
2 files changed, 13 insertions, 10 deletions
diff --git a/games-strategy/triplea/ChangeLog b/games-strategy/triplea/ChangeLog
index 98e3538419d6..1e6df3afb89e 100644
--- a/games-strategy/triplea/ChangeLog
+++ b/games-strategy/triplea/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/triplea
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.24 2006/11/10 18:04:28 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.25 2006/12/24 18:36:43 nyhm Exp $
+
+ 24 Dec 2006; Tristan Heaven <nyhm@gentoo.org> triplea-0.8.2.2.ebuild:
+ Use java-pkg_dolauncher to ensure >=jre-1.5 is used, bug #158643
*triplea-0.8.2.2 (10 Nov 2006)
diff --git a/games-strategy/triplea/triplea-0.8.2.2.ebuild b/games-strategy/triplea/triplea-0.8.2.2.ebuild
index 2f776d99af32..677bcf1c5ef0 100644
--- a/games-strategy/triplea/triplea-0.8.2.2.ebuild
+++ b/games-strategy/triplea/triplea-0.8.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/triplea-0.8.2.2.ebuild,v 1.1 2006/11/10 18:04:28 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/triplea-0.8.2.2.ebuild,v 1.2 2006/12/24 18:36:43 nyhm Exp $
inherit eutils java-ant-2 java-pkg-2 versionator games
@@ -25,10 +25,11 @@ S=${WORKDIR}/${PN}_${MY_PV}
src_unpack() {
unpack ${A}
- cd "${S}"/lib
+ cd "${S}"
- rm *.jar
- java-pkg_jar-from jgoodies-looks-1.3 looks.jar looks-1.3.1.jar
+ rm lib/*.jar
+ java-pkg_jar-from jgoodies-looks-1.3 looks.jar lib/looks-1.3.1.jar
+ java-pkg_ensure-no-bundled-jars
}
src_compile() {
@@ -37,14 +38,13 @@ src_compile() {
}
src_install() {
- games_make_wrapper ${PN} \
- 'java -cp classes:$(java-config -p jgoodies-looks-1.3) \
- games.strategy.engine.framework.GameRunner' \
- "${GAMES_DATADIR}"/${PN}
-
insinto "${GAMES_DATADIR}"/${PN}
doins -r classes data games images maps || die "doins failed"
+ java-pkg_addcp "${GAMES_DATADIR}"/${PN}/classes
+ java-pkg_dolauncher ${PN} -into "${GAMES_PREFIX}" --main \
+ games.strategy.engine.framework.GameRunner
+
newicon icons/triplea_icon.bmp ${PN}.bmp
make_desktop_entry ${PN} TripleA /usr/share/pixmaps/${PN}.bmp