summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-17 20:46:58 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-17 20:46:58 +0000
commite8db055eb7822eef6f22a1b1857375a3265b18aa (patch)
tree03c7f72dfb34fe2e425d74d5316fe0b026901033 /gnome-base/libgnomekbd/libgnomekbd-2.32.0-r1.ebuild
parentarm stable, bug #386345 (diff)
downloadgentoo-2-e8db055eb7822eef6f22a1b1857375a3265b18aa.tar.gz
gentoo-2-e8db055eb7822eef6f22a1b1857375a3265b18aa.tar.bz2
gentoo-2-e8db055eb7822eef6f22a1b1857375a3265b18aa.zip
Apply upstream patches to stop relying on deprecated stuff, also drop .la files.
(Portage version: 2.1.10.28/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/libgnomekbd/libgnomekbd-2.32.0-r1.ebuild')
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-2.32.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnome-base/libgnomekbd/libgnomekbd-2.32.0-r1.ebuild b/gnome-base/libgnomekbd/libgnomekbd-2.32.0-r1.ebuild
new file mode 100644
index 000000000000..6e3301b1ab6a
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-2.32.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomekbd/libgnomekbd-2.32.0-r1.ebuild,v 1.1 2011/10/17 20:46:58 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+# gtk+-2.20 needed for tests
+RDEPEND=">=dev-libs/glib-2.18:2
+ >=gnome-base/gconf-2.14:2
+ >=x11-libs/gtk+-2.20:2
+ >=x11-libs/libxklavier-5.0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable test tests) --disable-static"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Unneeded casts removed
+ epatch "${FILESDIR}/${P}-unneeded-casts.patch"
+
+ # Remove GDK_DISPLAY() usage
+ epatch "${FILESDIR}/${P}-gdkdisplay-usage.patch"
+
+ # Replace GDK_keyname with GDK_KEY_keyname
+ epatch "${FILESDIR}/${P}-gdkkeyname-replace.patch"
+}