summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-01-25 18:50:25 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-01-25 18:50:25 +0000
commit3d07b94754031b3452f12ca6dd74ecfdbf69efa7 (patch)
treee4f616172471713c1744c12f5d1851f4d37278ef /gnome-extra
parentfix include location (diff)
downloadgentoo-2-3d07b94754031b3452f12ca6dd74ecfdbf69efa7.tar.gz
gentoo-2-3d07b94754031b3452f12ca6dd74ecfdbf69efa7.tar.bz2
gentoo-2-3d07b94754031b3452f12ca6dd74ecfdbf69efa7.zip
Bump to 2.2.1
* Fixed bug in libsensors4 plugin [ 1858005 ] segfault on startup * Fixed crash when removing applet from panel, whilst the preferences window is open - fixes Ubuntu bug #172991 * Work around memory leak in libsensors3 code by manually freeing the result of sensors_parse_chip_name() * Implemented a plugin system, so all interface specific code are compiled into separated plugin modules, allowing them to be shipped separately from the main GNOME Sensors Applet program, to fix Debian bug #375179, and allow the NVIDIA plugin to be split into a separate package if needed. * Use new GTK tooltip API when possible * Update GTK icon cache on uninstall to comply with GNOME bug #362604 * Use g_timeout_add_seconds() when possible to save power * GNOME Sensors Applet Version 2.0.0 Released * src/libsensors-sensors-interface.c: Added support for libsensors4 API - to be shipped with upcoming Fedora 9 and Ubuntu 8.04 (Portage version: 2.1.4)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/sensors-applet/ChangeLog27
-rw-r--r--gnome-extra/sensors-applet/files/digest-sensors-applet-2.2.13
-rw-r--r--gnome-extra/sensors-applet/sensors-applet-2.2.1.ebuild42
3 files changed, 70 insertions, 2 deletions
diff --git a/gnome-extra/sensors-applet/ChangeLog b/gnome-extra/sensors-applet/ChangeLog
index 186d13e3ed72..a4fb9a7daed7 100644
--- a/gnome-extra/sensors-applet/ChangeLog
+++ b/gnome-extra/sensors-applet/ChangeLog
@@ -1,6 +1,29 @@
# ChangeLog for gnome-extra/sensors-applet
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sensors-applet/ChangeLog,v 1.28 2007/12/02 18:29:33 dang Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sensors-applet/ChangeLog,v 1.29 2008/01/25 18:50:24 dang Exp $
+
+*sensors-applet-2.2.1 (25 Jan 2008)
+
+ 25 Jan 2008; Daniel Gryniewicz <dang@gentoo.org>
+ +sensors-applet-2.2.1.ebuild:
+ Bump to 2.2.1
+ * Fixed bug in libsensors4 plugin [ 1858005 ] segfault on startup
+ * Fixed crash when removing applet from panel, whilst the
+ preferences window is open - fixes Ubuntu bug #172991
+ * Work around memory leak in libsensors3 code by manually freeing the
+ result of sensors_parse_chip_name()
+ * Implemented a plugin system, so all interface specific code are
+ compiled into separated plugin modules, allowing them to be shipped
+ separately from the main GNOME Sensors Applet program, to fix Debian bug
+ #375179, and allow the NVIDIA plugin to be split into a separate package
+ if needed.
+ * Use new GTK tooltip API when possible
+ * Update GTK icon cache on uninstall to comply with GNOME bug
+ #362604
+ * Use g_timeout_add_seconds() when possible to save power
+ * GNOME Sensors Applet Version 2.0.0 Released
+ * src/libsensors-sensors-interface.c: Added support for
+ libsensors4 API - to be shipped with upcoming Fedora 9 and Ubuntu 8.04
*sensors-applet-1.8.2 (02 Dec 2007)
diff --git a/gnome-extra/sensors-applet/files/digest-sensors-applet-2.2.1 b/gnome-extra/sensors-applet/files/digest-sensors-applet-2.2.1
new file mode 100644
index 000000000000..5efa654e5886
--- /dev/null
+++ b/gnome-extra/sensors-applet/files/digest-sensors-applet-2.2.1
@@ -0,0 +1,3 @@
+MD5 4ba94415125db147efcc1ae76f9703ee sensors-applet-2.2.1.tar.gz 518257
+RMD160 3b6c5ea65b68e694c0db5b2776a89847b8fd57a9 sensors-applet-2.2.1.tar.gz 518257
+SHA256 6be95f70458d299f28bfc81dee201b3e1c328bc55df00fc7f2c30d7f8f6faba0 sensors-applet-2.2.1.tar.gz 518257
diff --git a/gnome-extra/sensors-applet/sensors-applet-2.2.1.ebuild b/gnome-extra/sensors-applet/sensors-applet-2.2.1.ebuild
new file mode 100644
index 000000000000..99b25a72fd0f
--- /dev/null
+++ b/gnome-extra/sensors-applet/sensors-applet-2.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sensors-applet/sensors-applet-2.2.1.ebuild,v 1.1 2008/01/25 18:50:24 dang Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="GNOME panel applet to display readings from hardware sensors"
+HOMEPAGE="http://sensors-applet.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sensors-applet/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="hddtemp libnotify lm_sensors nvidia"
+
+RDEPEND="
+ >=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.8.0
+ >=gnome-base/gnome-panel-2
+ >=gnome-base/libgnome-2.8
+ >=gnome-base/libgnomeui-2.8
+ >=x11-libs/cairo-1.0.4
+ hddtemp? ( >=app-admin/hddtemp-0.3_beta13 )
+ libnotify? ( >=x11-libs/libnotify-0.4.0 )
+ lm_sensors? ( sys-apps/lm_sensors )
+ nvidia? ( || (
+ >=x11-drivers/nvidia-drivers-100.14.09
+ media-video/nvidia-settings
+ ) )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12
+ >=app-text/gnome-doc-utils-0.3.2
+ dev-util/intltool"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="$(use_with nvidia) \
+ $(use_with lm_sensors libsensors) \
+ $(use_enable libnotify)"
+}